OpenWrt mesh routers problems (Encryption, MAC address & Hostname)

This my output:

root@OpenWrtX5000R180:~# iwinfo
wlan0     ESSID: "OpenWrtX5000Rmesh2.4GHz"
          Access Point: 5C:92:5E:37:E8:70
          Mode: Mesh Point  Channel: 1 (2.412 GHz)
          Center Channel 1: 1 2: unknown
          Tx-Power: 20 dBm  Link Quality: 70/70
          Signal: -6 dBm  Noise: unknown
          Bit Rate: 1.0 MBit/s
          Encryption: **none**  <================================== 
          Type: nl80211  HW Mode(s): 802.11bgnax
          Hardware: 14C3:7915 14C3:7915 [MediaTek MT7915E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

wlan1     ESSID: "OpenWrtX5000R5GHz"
          Access Point: 00:0C:43:4A:21:4E
          Mode: Master  Channel: 40 (5.200 GHz)
          Center Channel 1: 42 2: unknown
          Tx-Power: 20 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nacax
          Hardware: 14C3:7915 14C3:7915 [MediaTek MT7915E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

Yep, same thing here, when doing a scan using 2.4GHz radio, you can only see the turning wheel starting wireless scan.....no result output. Not sure if it because I have assigned the 2.4GHz to be a dedicated mesh backhaul, and scanning is disabled.

However 5Hz radio's wireless scanning is working

How did you get Mesh0 & Mesh1 listed like that?
Mine one is showing WLAN0 & WLAN1

If you want to make progress on this, please show the contents of:
/etc/config/wireless
and
/etc/config/network

Remember to use the "</>" option in the top line of the text box to make sure the contents are formatted correctly here.

It might be, that is the nature of snapshots.
By the way, I see you are using 22.03-snapshot. You do realise this is not even officially available - ..... It might be better to wait for the first release candidate before trying it.

1 Like

To get the hostname, Luci must do a reverse lookup of the ip address of the remote mesh node.
The mesh network (layer 2) neither knows nor cares about the layer 3 ip networking.
Have you added the mesh network to the lan bridge?

1 Like

Sure. here is my information
etc/config/wireless

                                                                                       

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HE20'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option key (redacted)
        option ssid 'OpenWrtX5000R5GHz'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'mesh'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option network 'lan'
        option encryption 'sae'
        option key (redacted)
        option mesh_id 'OpenWrtX5000Rmesh2.4GHz'

Hre is the output of
/etc/config/network


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd81:6440:7553::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.180'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

Yes, I notice, I am not using the official OpenWrt firmware, if I am going to use the official one, the
5GHz radio settings will be crashing Luci. 2.4GHz radio doesn't suffer this problem.

You can't use Luci to do any setting within the 5GHz radio. Configuration done on Luci will display
error message.

Yes, I have added the mesh to LAN network

For same MAC ADDRESS possible same error as my 3 * TenBay T-MB5EU-V01

resolved by blocktrron ( developper )

1 Like

Now show the output of:
ip link

and
iw dev wlan0 mpath dump

1 Like

Unless I'm missing something in 22.03, this should be:
option htmode 'HT20'

and this should be:
option htmode 'VHT80'

1 Like

I repeat::

It is certain that the identical MAC addresses mean that the 5 GHz WIFI cannot function correctly

1 Like

connect ssh

edit file : /etc/hotplug.d/ieee80211/10_fix_wifi_mac

add at last

tenbay,t-mb5eu-v01)
                hw_mac_addr="$(mtd_get_mac_binary factory 0x4)"
                 [ "$PHYNBR" = "1" ] &&  macaddr_add $hw_mac_addr "0x100000" > /sys${DEVPATH}/macaddress
                 ;;

		totolink,x5000r)
				 hw_mac_addr="$(mtd_get_mac_binary factory 0x4)"
                  [ "$PHYNBR" = "1" ] &&  macaddr_add $hw_mac_addr "0x100000" > /sys${DEVPATH}/macaddress
                  ;;

and test if MAC is correct 5C:92:5E:37:xx:yy after reboot

1 Like

If they are identical then it means the mesh will not work. It is an easy config fix if they are.

Edit: Yes I see what you are saying - it is a firmware problem for the 5 GHz radio.

But the OP is having problems with the mesh on 2 GHz....

1 Like

You are right, disabling the mesh gets wireless scanning working again. This wasn't necessary in earlier versions.

I edited the wireless file, but in luci, setting the mesh point's "Interface Name" in its wireless settings "Interface Configuration"->"Advanced Settings" tab should achieve the same effect.

1 Like

Appreciated your info given. :clap:
But as much as I like to solve the problem, I don't possess the technical
know-how in understanding solutions given to me, as I am not a developer.

I am just a Windows guy(nor a Linux guru), or just an average guy who is trying to learn OpenWrt as much as possible. Please don't be offended, your information is too overwhelming for me to comprehend.

Thank you.

Technically both parameters are correct.

My router is a Wifi 6 802.11 AX router, so it should be using High Efficiency (HE) standard rather than using HT or High Throughput which is 802.11n standard

Here is the output for ip link command

root@OpenWrtX5000R180:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
    link/ether 5c:92:5e:37:e8:72 brd ff:ff:ff:ff:ff:ff
3: lan1@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 5c:92:5e:37:e8:72 brd ff:ff:ff:ff:ff:ff
4: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 5c:92:5e:37:e8:72 brd ff:ff:ff:ff:ff:ff
5: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 5c:92:5e:37:e8:72 brd ff:ff:ff:ff:ff:ff
6: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether 5c:92:5e:37:e8:72 brd ff:ff:ff:ff:ff:ff
7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 5c:92:5e:37:e8:71 brd ff:ff:ff:ff:ff:ff
10: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 5c:92:5e:37:e8:72 brd ff:ff:ff:ff:ff:ff
11: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 5c:92:5e:37:e8:70 brd ff:ff:ff:ff:ff:ff
12: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 00:0c:43:4a:21:4e brd ff:ff:ff:ff:ff:ff

Here is the output for the iw dev wlan0 mpath dump command

root@OpenWrtX5000R180:~# iw dev wlan0 mpath dump
DEST ADDR         NEXT HOP          IFACE       SN      METRIC  QLEN    EXPTIMEDTIM     DRET    FLAGS   HOP_COUNT       PATH_CHANGE
00:22:68:6f:e9:b0 00:00:00:00:00:00 wlan0       0       0       0       0      1600     4       0x0     0       0
5c:92:5e:b7:7a:d8 5c:92:5e:b7:7a:d8 wlan0       40      8193    0       0      100      0       0x4     1       1

Ok got it, thank you :slightly_smiling_face:

You don't have to go deep into dts fille or hotplug to override the MAC, just add an option macaddr to the wifi-iface, using the factory MAC address from the sticker.

If you've been copying configs between the two units you may have ended up with a duplicate option macaddr in /etc/config/network. This should also be fixed by using the sticker MAC or a close one by increasing the last number by one or two.

Ah, Wifi 6, that explains it :wink:

No problem, we all have to start somewhere.

Let's simply work through the problems one by one.

  1. Mac address problem. This looks like a firmware image issue as @anon69880279 suggested and does not effect the mesh, but causes problems with the 5GHz network.
    We can work around this problem easily by setting the mac for the 5G radios on both routers.
    On each mesh node (router) in turn, in a terminal session do the following -

On the one with the 5c:92:5e:37:e8:70 mac:

uci set wireless.wlan1.macaddr='5c:92:5e:37:e8:70'
uci commit wireless

On the one with the 5c:92:5e:b7:7a:d8 mac:

uci set wireless.wlan1.macaddr='5c:92:5e:b7:7a:d8'
uci commit wireless

For simplicity, reboot both then check if the mac problem is fixed.

If it is we can go on to the next problem.

1 Like
  1. The encryption problem.
    802.11s mesh has an additional dependency and an addon to make it work properly.

To install these you need to make sure both routers in turn are connected to an Internet feed.
It looks like you have both configured as pure AP/Meshnodes so all you need to do is connect, each in turn to your isp router with an ethernet cable (lan port to lan port)

In a terminal session on each meshnode in turn do (making sure you do net get any errors):

opkg update
opkg remove wpad-basic-wolfssl
opkg install wpad-mesh-wolfssl
opkg install mesh11sd

Making sure you did both, then put the meshnodes back where you want them (only one connected to the isp router by ethernet) and power them both back up.

Test again and report back :smiley:

1 Like

Hello, 1st of all, thank you for helping me troubleshoot the problem :grinning:

Can you tell me on what basis, that you use to determine which router should have the
correct MAC address on the 5GHz radio?

Is it based on the ip link command or the iw dev wlan0 mpath dump output?

I am confused, as to why I am setting MAC address on the wlan1 (5GHz Radio) using MAC address from the 2.4GHz Radio?

Both 5c:92:5e:37:e8:70 & 5c:92:5e:b7:7a:d8 Both these MAC addresses are actually referring to the 2.4GHz Radios coming from the OpenWrtX5000R180 and OpenWrtX5000R182

Shouldn't I should be setting the ACTUAL(or REAL) MAC address for the 5GHz Radio?