OpenWRT -> LEDE Fails silently


I have been using Chaos Calmer on my Linksys 1900AC v1. It is time to upgrade so I can get some new packages going. I downloaded LEDE - Mamba and tried to upgrade. Everything seems to work great and then the router reboots and I am back in Chaos Calmer. I tried both CLI and LuCi with the same lack of success.

Why would you install the old LEDE 17.x this close to the big OpenWrt 18.06 release? At the very least get a current build, there are huge improvements across the board. Try davidc502's newest build until it's officially released:

Sounds like the image didn't flash to the partition that is "active" or the like.

1 Like

A check was added along the way, so I think you will have to force the upgrade:

sysupgrade -F -n

Thanks for jumping on this, guys.

I just tried to with the image from the @phinn post.

sysupgrade -F -n lede-mvebu-cortexa9-linksys-wrt1900ac-squashfs-sysupgrade.bin

Alas - after the router came back - it was still running 15.05.1

Someone mentioned partitions? How do I make sure I am using the right one? Is there any logging?

Some bits, there is no right partition.

#hacked from /lib/upgrade/

cur_boot_part=`/usr/sbin/fw_printenv -n boot_part`
if [ "$cur_boot_part" = "1" ]
    fw_setenv boot_part 2
    fw_setenv bootcmd "run altnandboot"
elif [ "$cur_boot_part" = "2" ]
    fw_setenv boot_part 1
    fw_setenv bootcmd "run nandboot"
# re-enable recovery so we get back if the new firmware is broken
fw_setenv auto_recovery yes
echo "$target_firmware"

Is there an error?

The WRT AC Series flashes using a round-robin, so if it's booting back to CC, your flash failed, and the bootloader loaded the only partition with a bootable firmware.

  • Did you flash via Ethernet, and not wifi?

  • To understand precisely what went wrong that's preventing the router from booting the flashed partition, a serial connection is required.

I've never had an issue flashing the 1900AC v1, but I also always flash via serial using a USB-TTL Audio Jack cable.

@codr1 can you install the advanced reboot package? This gives you a webUI option to reboot into the different partitions. I believe the davidc502 build linked above comes with this. If you're stuck in the old CC build I'm honestly not sure, like said above it should flash in a round-robin where it always flashes the other partition (i.e. the one you're not running).

Here's the thread for advanced reboot: Web UI to reboot to another partition (for Linksys/ZyXEL dual-partition routers) and to power off/power down

It wouldnt matter, as the flash failed. Again, it booted back to the partition containing CC because it was not possible to boot the partition which was flashed, due to the flash failing, of which is the default behavior of Uboot.

The correct and only way of troubleshooting exactly what went wrong is to connect via serial (which is also stated in the WRT AC Series ToH)