OpenWRT IPv6 delegation works on LAN but not on Wlan interface

I can get ipv6 delegation when setting up WAN6 on my eth0 connection, but when trying via the internal wifi adapter (Raspberry 4 model) it fails to receive delegation from my ISP.
Since the firewall rules apply equally to both, is there perhaps a limitation to the adapter that prevents IPv6 delegation? Or is there perhaps another method? I tried NDP mode, but that fails as well.

/etc/config/...

Is wifi bridged in to LAN? Or it is on a something separate? If it's bridged, everything should work the same.

1 Like

Here is my current config, if I just plug in the lan cable the delegation works, take it out, and it fails..
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdbf:389a:b87d::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'ethO'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '10.62.62.1'
option netmask '255.255.255.0'
option ip6assign '60'
option force_link '1'

config interface 'wwan'
option proto 'dhcp'
option peerdns '0'
option dns '9.9.9.9 149.112.112.112'

config interface 'vpnclient'
option proto 'none'
option device 'tun0'

config interface 'wan6'
option proto 'dhcpv6'
option device '@wwan'
option reqaddress 'try'
option reqprefix 'auto'

typo on eth0 was deliberate is not part of the network file...thanks

You don't appear to have configured IPv6 relay:

Also please apply the proper formatting to your configuration when you post on the forum. Helps massively with readability.

Thanks for the tip, but honestly, I don't think a relay will work since my router is already providing the delegation via lan cable. I had already installed 464 and that failed as well, so did ndp. For some reason the wireless interface refuses to grab the delegation from my router. (Fritzbox 7950).

Also, I don't know what you mean by proper formatting my configuration, I just copied and pasted, is there something else I should do to make it more....readable?

Yes. Write 3x Backtick. At the beginning and the end of a code block. (```)
It will then look like this

Option foo bar
Option yeah monospace
Option so much better to read

Ah, sorry, I misunderstood your question. Does other wireless devices successfully gets IPv6?

Forum uses markdown formatting, you can make it like so:

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdbf:389a:b87d::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'ethO'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '10.62.62.1'
option netmask '255.255.255.0'
option ip6assign '60'
option force_link '1'

config interface 'wwan'
option proto 'dhcp'
option peerdns '0'
option dns '9.9.9.9 149.112.112.112'

config interface 'vpnclient'
option proto 'none'
option device 'tun0'

config interface 'wan6'
option proto 'dhcpv6'
option device '@wwan'
option reqaddress 'try'
option reqprefix 'auto'

Forum help and the site feedback has nice instructions on how to do these.

More fundamentally, the Pi built in radio cannot run an AP and STA at the same time.

that I understand, I have an external antenna running as AP the internal is ST. I have tried several scenarios, using the AP as stand alone IPv6 or even changing the lan bridge to the AP antenna. Although it will provide plenty of v6 ip addresses, it refuses to create a delegation to allow other devices or even ping through diagnostics to openwrt.org. The only way I can get this to work is with a physical lan cable.
Odd that my standard wifi connection from my firtzbox works fine, just forwarding it to the Raspberry fails.
I have pretty much given up at this point,I don't think it is possible to have ipv6 working. Not really that important since my opvn files currently don't support it either.

I found the issue, my Fritzbox was not down streaming Prefix Delegation. Thanks for everyone's tips, help :+1:. works now like a charm

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.