OpenWrt ipv6 bug

OpenWrt SNAPSHOT r18468-4a2cca7824 / LuCI Master git-21.357.58153-63d9bcb
Powered by LuCI Master (git-21.357.58153-63d9bcb) / OpenWrt SNAPSHOT r18468-4a2cca7824

系统

主机名 OpenWrt
型号 FriendlyElec NanoPi R4S
架构 ARMv8 Processor rev 4
目标平台 rockchip/armv8
固件版本 OpenWrt SNAPSHOT r18468-4a2cca7824 / LuCI Master git-21.357.58153-63d9bcb
内核版本 5.10.89
本地时间 2022-01-10 10:25:35
运行时间 6h 55m 21s
平均负载 0.05, 0.11, 0.12

network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '24e5:8100::/32'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'

config device
	option name 'eth1'
	option macaddr '6a:27:19:b6:1e:3c'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option delegate '0'
	option ip6assign '64'

config device
	option name 'eth0'
	option macaddr '68:27:19:b6:1e:3c'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix '56'
无线局域网适配器 WLAN:

   连接特定的 DNS 后缀 . . . . . . . : lan
   IPv6 地址 . . . . . . . . . . . . : 24e5:8100::8045:c733:20ac:30c2
   IPv6 地址 . . . . . . . . . . . . : fdd7:50b8:e0c8:46e7:8045:c733:20ac:30c2
   临时 IPv6 地址. . . . . . . . . . : 24e5:8100::4c11:cf9a:66cc:bafe
   临时 IPv6 地址. . . . . . . . . . : fdd7:50b8:e0c8:46e7:84f5:c7bb:1b05:a616
   本地链接 IPv6 地址. . . . . . . . : fe80::8045:c733:20ac:30c2%7
   IPv4 地址 . . . . . . . . . . . . : 192.168.1.129
   子网掩码  . . . . . . . . . . . . : 255.255.255.0
   默认网关. . . . . . . . . . . . . : fe80::6827:19ff:feb6:1e3c%7
                                       192.168.1.1

I want to know where fdd7:50b8:e0c8:46e7:8045:c733:20ac:30c2 comes from? Can it be turned off?

It's a unique local address. It's a perfectly normal part of the ipv6 setup.

1 Like

I didn't find out in the previous version, how can I disable it?

What is this? That's not a valid ULA prefix.

ubus call network.interface dump should tell you where the other address prefixes are coming from.

{
"interface": [
{
"interface": "lan",
"up": true,
"pending": false,
"available": true,
"autostart": true,
"dynamic": false,
"uptime": 6825,
"l3_device": "br-lan",
"proto": "static",
"device": "br-lan",
"updated": [
"addresses"
],
"metric": 0,
"dns_metric": 0,
"delegation": true,
"ipv4-address": [
{
"address": "192.168.1.1",
"mask": 24
}
],
"ipv6-address": [

                    ],
                    "ipv6-prefix": [

                    ],
                    "ipv6-prefix-assignment": [
                            {
                                    "address": "24e5:8100::",
                                    "mask": 64,
                                    "local-address": {
                                            "address": "24e5:8100::1",
                                            "mask": 64
                                    }
                            }
                    ],
                    "route": [

                    ],
                    "dns-server": [

                    ],
                    "dns-search": [

                    ],
                    "neighbors": [

                    ],
                    "inactive": {
                            "ipv4-address": [

                            ],
                            "ipv6-address": [

                            ],
                            "route": [

                            ],
                            "dns-server": [

                            ],
                            "dns-search": [

                            ],
                            "neighbors": [

                            ]
                    },
                    "data": {

                    }
            },
            {
                    "interface": "loopback",
                    "up": true,
                    "pending": false,
                    "available": true,
                    "autostart": true,
                    "dynamic": false,
                    "uptime": 6825,
                    "l3_device": "lo",
                    "proto": "static",
                    "device": "lo",
                    "updated": [
                            "addresses"
                    ],
                    "metric": 0,
                    "dns_metric": 0,
                    "delegation": true,
                    "ipv4-address": [
                            {
                                    "address": "127.0.0.1",
                                    "mask": 8
                            }
                    ],
                    "ipv6-address": [

                    ],
                    "ipv6-prefix": [

                    ],
                    "ipv6-prefix-assignment": [

                    ],
                    "route": [

                    ],
                    "dns-server": [

                    ],
                    "dns-search": [

                    ],
                    "neighbors": [

                    ],
                    "inactive": {
                            "ipv4-address": [

                            ],
                            "ipv6-address": [

                            ],
                            "route": [

                            ],
                            "dns-server": [

                            ],
                            "dns-search": [

                            ],
                            "neighbors": [

                            ]
                    },
                    "data": {

                    }
            },
            {
                    "interface": "tun1",
                    "up": true,
                    "pending": false,
                    "available": true,
                    "autostart": true,
                    "dynamic": false,
                    "uptime": 6825,
                    "l3_device": "tun1",
                    "proto": "static",
                    "device": "tun1",
                    "updated": [
                            "addresses",
                            "routes"
                    ],
                    "metric": 0,
                    "dns_metric": 0,
                    "delegation": true,
                    "ipv4-address": [
                            {
                                    "address": "10.255.0.1",
                                    "mask": 24
                            }
                    ],
                    "ipv6-address": [

                    ],
                    "ipv6-prefix": [

                    ],
                    "ipv6-prefix-assignment": [

                    ],
                    "route": [
                            {
                                    "target": "0.0.0.0",
                                    "mask": 0,
                                    "nexthop": "10.255.0.1",
                                    "metric": 0,
                                    "table": 10,
                                    "source": "0.0.0.0/0"
                            },
                            {
                                    "target": "::",
                                    "mask": 0,
                                    "nexthop": "fe80::1",
                                    "table": 10,
                                    "source": "::/0"
                            }
                    ],
                    "dns-server": [

                    ],
                    "dns-search": [

                    ],
                    "neighbors": [

                    ],
                    "inactive": {
                            "ipv4-address": [

                            ],
                            "ipv6-address": [

                            ],
                            "route": [

                            ],
                            "dns-server": [

                            ],
                            "dns-search": [

                            ],
                            "neighbors": [

                            ]
                    },
                    "data": {

                    }
            },
            {
                    "interface": "wan",
                    "up": true,
                    "pending": false,
                    "available": true,
                    "autostart": true,
                    "dynamic": false,
                    "uptime": 6704,
                    "l3_device": "eth0",
                    "proto": "dhcp",
                    "device": "eth0",
                    "updated": [
                            "addresses",
                            "routes",
                            "data"
                    ],
                    "metric": 0,
                    "dns_metric": 0,
                    "delegation": true,
                    "ipv4-address": [
                            {
                                    "address": "192.168.2.2",
                                    "mask": 24
                            }
                    ],
                    "ipv6-address": [

                    ],
                    "ipv6-prefix": [

                    ],
                    "ipv6-prefix-assignment": [

                    ],
                    "route": [
                            {
                                    "target": "0.0.0.0",
                                    "mask": 0,
                                    "nexthop": "192.168.2.1",
                                    "source": "192.168.2.2/32"
                            }
                    ],
                    "dns-server": [
                            "192.168.2.4"
                    ],
                    "dns-search": [

                    ],
                    "neighbors": [

                    ],
                    "inactive": {
                            "ipv4-address": [

                            ],
                            "ipv6-address": [

                            ],
                            "route": [

                            ],
                            "dns-server": [

                            ],
                            "dns-search": [

                            ],
                            "neighbors": [

                            ]
                    },
                    "data": {
                            "dhcpserver": "192.168.2.1",
                            "leasetime": 86400
                    }
            },
            {
                    "interface": "wan6",
                    "up": true,
                    "pending": false,
                    "available": true,
                    "autostart": true,
                    "dynamic": false,
                    "uptime": 6379,
                    "l3_device": "eth0",
                    "proto": "dhcpv6",
                    "device": "eth0",
                    "metric": 0,
                    "dns_metric": 0,
                    "delegation": true,
                    "ipv4-address": [

                    ],
                    "ipv6-address": [
                            {
                                    "address": "241e:33d:9aba:5300:6a27:19ff:feb6:1e3c",
                                    "mask": 64,
                                    "preferred": 14384,
                                    "valid": 86384
                            }
                    ],
                    "ipv6-prefix": [

                    ],
                    "ipv6-prefix-assignment": [

                    ],
                    "route": [
                            {
                                    "target": "241e:33d:9aba:5300::",
                                    "mask": 64,
                                    "nexthop": "::",
                                    "metric": 256,
                                    "valid": 86384,
                                    "source": "::/0"
                            },
                            {
                                    "target": "::",
                                    "mask": 0,
                                    "nexthop": "fe80::7041:51ff:fe44:2fda",
                                    "metric": 512,
                                    "valid": 1784,
                                    "source": "241e:33d:9aba:5300:6a27:19ff:feb6:1e3c/64"
                            }
                    ],
                    "dns-server": [

                    ],
                    "dns-search": [

                    ],
                    "neighbors": [

                    ],
                    "inactive": {
                            "ipv4-address": [

                            ],
                            "ipv6-address": [

                            ],
                            "route": [

                            ],
                            "dns-server": [

                            ],
                            "dns-search": [

                            ],
                            "neighbors": [

                            ]
                    },
                    "data": {

                    }
            }
    ]

}

option ula_prefix '24e5:8100::/32'

This is my custom prefix. This is no problem. I just want to know where fdd7:50b8:e0c8:46e7:8045:c733:20ac:30c2 comes from and turn it off.

Regardless of my prefix, I just want to know how fdd7:50b8:e0c8:46e7:8045:c733:20ac:30c2 came from, it did not exist in the previous openwrt version, I use EdgeRouter ER-4/ER-6P Nor fdd7:50b8:e0c8:46e7:8045:c733:20ac:30c2

It's not valid

I'm wondering if OpenWrt is assigning you a proper ULA because yours isn't right? No idea. Worth trying though.

ula_prefix 'fc00:8100::/32'

Modified to,But I think this is unreasonable. Whatever I write, he just does it, and he doesn't need to help me correct it.

You think it's unreasonable that OpenWRT doesn't allow you to assign an invalid ULA prefix? What exactly is your issue with having valid ULA addresses assigned to your devices? Is it causing problems with connectivity?

It has no effect on the connection, but it is redundant

If it is not allowed, a range should be set to prohibit entering an invalid range instead of forcing redundant corrections.

ula_prefix 'fc00:8100::/32'

This ULA has two problems: it does not look very random and it has a /32 instead of the required /48.
You should use a 'ULA address generator' (e.g. https://cd34.com/rfc4193/) and paste the generated number into your config.

When you flash a new firmware there is a script /etc/uci-defaults/12_network-generate-ula which is run once on reboot and then deleted (you can still find it in /rom/etc/uci-defaults)

1 Like