OpenWrt installation on RPi 4

I have received my Raspberry Pi 4 and I'm trying to get up and running.

I have installed the snapshot using Rufus and have booted up. I can connect via SSH and have set the root password.

I am trying to get Wi-Fi working, but am receiving a Permission Denied error for the following command:


I have set a root password, but that didn't make any difference. Any ideas?

it's a text file, not a executable application, and he's not running /etc/config/wireless

Thanks. I really must check my glasses. I was missing the 'vi' at the start of the command.

I've tried to start over and I'm encountering some strange behaviour.

I removed the SD card and 'slow' formatted it in Windows.
Used Rufus to write the image to the SD card.
Booted from the SD card.

For some reason the Root password is still set, even though this is (should be) a completely fresh install?

if you did erase the whole SD, then yes, the password should have been wiped.

I found the issue. Windows Explorer only had visibility of the 'boot' volume and that was all I was wiping. I used Computer Management to delete all the volumes on the SD card.

*** edit **

That's still not worked! It keeps booting with the previous configuration even though I've completely deleted all the volumes and formatted.

Make sure you're telling your SSH client to log in to the Pi as root. If you use a different user name, you will be asked for a password. (This is a security measure so the ssh server does not confirm or deny that a user exists. Logging in as other than root is actually impossible since no other users are defined).

The Pi4 is included in 21.02 so you could consider using what is now the 21.02-rc2 build instead of snapshot. Release builds include LuCI.

That's not the problem I'm experiencing. I am formatting the SD card, but the old configuration is still present when I reinsert the SD card and boot the Raspberry Pi.

It seems the old file structure and configuration files are surviving the formatting process.

I am currently wiping the SD Card by writing zeros to the entire device in an attempt to resolve the issue. It's a 16GB card, so it's taking a while.

Properly writing the "factory" image to the card, starting at the first sector, will clobber any existing partition table (disk label) and make any previous data stored on the card moot. There is no need to format or zero the card first.

Do you have a link to the .img file for release 21.02?

I've presume I need 'aarch64_cortex-a72', but I can't find an image to download.

The Pi4 is a bcm2711 chip so it is under that target.
Note this image is gzipped it needs to be decompressed before using. On Linux this is usually done inline to pipe to dd and write to the card:

root@linux: gunzip -c openwrt.img.gz | dd of=/dev/sdb bs=1M

Thanks for your help. I've got that installed.

I'd like to use a USB3.0 to Gigabit ethernet dongle for my WAN connection. It is an ASIX model and I am aware that it will max out at 600Mbps. My WAN is 80/20 FTTC ADSL, so that shouldn't be an issue.

I can see there is a package for my particular device.

I have attempted to install it via the following command:

opkg update && opkg install kmod-usb-net-asix-ax88179

I received an 'unknown package' response.

Any ideas?

and does opkg update run standalone, succeed ?

I was able to install the driver via the GUI. I'm not sure why it didn't install via the command line.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.