OpenWrt installation on GL-AR300M

Has anyone been able to flash the OpenWRT v19 onto gl-ar300m?

I am very interested to be able to use openwrt only as I get too many bugs if I need advanced features.
And when I use the button for disabling the VPN it auto enables masquerading which breaks my VPN.

I tried to install by the UI the update and full version but it said file format is incorrect.
Have you tried Uboot? I tried before but it broke the router and I had to revert to GL's firmware.

Great little product but a shame with the lack of support. I always say be a master of what you are rather than trying to rush products out. Quality over quantity!

Since the wiki mentions telnet, try an older version of OpenWRT, you might also need to
downgrade the AR300Ms firmware, but it shouldn't really be required if you flash through UBoot recovery.

Read GL-AR300M and GL-AR750S NAND Support (ath79)

@frollic Thanks for your advice, but do you know why I received a message that my post has been hidden? it is in topic of installation I would have thought