OpenWrt installation on AVM Fritzbox 7362SL

The instructions here for installing to this router are here:

But they are scant, and I'm sure very adequate for pros, which I'm NOT.

So, any pro out here can take a quick look and translate it to noob help?

For example, how to "use scripts/flashing/ to send initramfs-kernel.bin to the router"

How is this step done?

As well, "Transfer the sysupgrade image to the /tmp directory of the router using scp". Never used this before, any help here, an example line perhaps, please?

" Run sysupgrade /tmp/openwrt-19.07.5-lantiq-xrx200-avm_fritz7362sl-squashfs-sysupgrade.bin" Does this mean the router would have been connected to the internet?

Thanks a lot.

...only bumping this one up a bit. and many thanks for your time.

No, you can (need to) transfer it to /tmp/ locally beforehand, e.g. using scp (or WinSCP).

So I have managed to find a way to issue the first command
python3 ./openwrt-21.02.1-lantiq-xrx200-avm_fritz7362sl-initramfs-kernel.bin

And now get this result, which I do not understand how to address:

< 200 SETENV command successful
> SETENV kernel_args_tmp mtdram1=0x87aa1000,0x88000000
< 200 SETENV command successful
< 200 Media set to MEDIA_SDRAM
Traceback (most recent call last):
  File "/home/lulu/Desktop/7362SL/", line 42, in <module>
    ftp.storbinary('STOR 0x%08x 0x88000000'%(haddr), img)
  File "/usr/lib/python3.9/", line 509, in storbinary
    return self.voidresp()
  File "/usr/lib/python3.9/", line 259, in voidresp
    resp = self.getresp()
  File "/usr/lib/python3.9/", line 254, in getresp
    raise error_perm(resp)
ftplib.error_perm: 553 Execution failed.

I hope a kind soul here would come to my help. Thanks

@slh thanks a lot. but I'm not there yet.

Can someone, please, PLEASE, tell me how to fix this error, or at least help me understand it. Please!

this can be completely omitted and run via FTP client like TCMD in windows . AVM FRITZ!Box 7412 stuck in ramboot - #3 by nicefile
calculation for ramdrive is set for max 4 587 520 bytes boot file (88000000 - 87BA0000 in hex). But can be increased if needed

Trying to use ftp to send "eva_ramboot" to router.

Directions here

says to "Set lzma compression in ramdisk options, bootloader stalls when receiving uncompressed images."

But I cannot find any place with further information on how and where to 'set lzma.' As well, clear directions on using ftp, as oppose to python3, which hasn't worked for me for days now. I' have a thread on this here:

Can someone please help? While I have your attention, ideas on where I could simply click and download the "eva_ramboot"? At github, I get the text of the script, not the actual file.

Thanks a lot.

";a=blob_plain;f=scripts/flashing/;hb=refs/heads/master" just save webpage (ctrl-s) as in browser and there You have

thanks a lot. not your fault or anyone's it's vivaldi. i put that link in firefox, and is simply asked me where I wanted to save the file. thanks a lot.

@slh @nicefile so put this command on in Terminal:

./ bin/targets/openwrt-21.02.1-lantiq-xrx200-avm_fritz7362sl-initramfs-kernel.bin

turn the router on and within 3 seconds hit "Enter"

And I get "Permission Denied" each time.

Any ideas?

A side note...

Make sure you know how to get the Fritzbox back to stock firmware in case something goes sideways.

no worries, there. I just need to figure out this issue about 'permission denied'.

Comparison of commands - first is tutorial, second is yours...

scripts/flashing eva_ramboot bin/targets/lantiq/xrx200/openwrt-lantiq-xrx200-avm_fritz7412-initramfs-kernel.bin
./ bin/targets/openwrt-21.02.1-lantiq-xrx200-avm_fritz7362sl-initramfs-kernel.bin

thanks a lot. I've tried both. majority users use the second version.

I think we can close this. I don't think the latest firmware, based on installation instructions available, will run on this box. Or, the installation instructions need to change. Thanks everyone. Moving on. If things change, then maybe. But doing the same thing over and again and getting the same results, well, someone said something about that being a form of insanity. Thanks everyone for your ideas and help.

Current OpenWrt does definitely work on Fritzbox 7362 SL. If you get Permission denied directly after running ./, that could be because the script is missing the executable permission. However, using python3 as you initially did should work then.

You should run the command just after all LEDs light up shortly, when the power LED starts blinking, and as soon as the network connection has been established (It may be easier to add a switch between the device and your computer, as the network connection would already be up then).

If the command runs successfully, you would just have to wait until OpenWrt has booted. Then you could install it permanently by installing the sysupgrade image using the web interface.