Openwrt 'freezes' putty commands to external ips

I have a couple of linux machines on my internal network in can putty into and do my thing just fine.
I have one external backup linux at a friends house where putty acts strange:

When logging in i can change dirs just fine, but once i run any command like NANO or TOP, putty stops responding. TOP gives me 3 to 4 lines of text and then freezes.

I also tried it on my android over the air and it works. Same android over wifi(openwrt), and freeze. Putty on my desktop freezes also.

ssh port at his house is 4444.


note: I just putty'd into Vultr VPS and it works there.

1 Like

This sounds like an MTU-related issue, so try to decrease MTU.

1 Like

Thats it! It was on default 1500. I have it on 1400 now as a test.

Does that mean my friend got a different mtu then me? Should i match his?

1 Like

It is supposed to work automatically with PMTUD.
Otherwise most likely firewalls on the way are too paranoid and/or the MSS clamping rule is missing.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.