OpenWrt for Zyxel WSM20 (Multy M1) development discussion

No, I just contribute to the project (mostly new device support), I'm not part of the developer team.

Ah, ok. But "even" as a contributor you might be able to advise me?

are they not the leds on the ethernet interface?

There are LEDs on the back of the router, integrated into the RJ45 jacks.

1 Like

how is the WiFi coverage / performance of these boxes ? Is it comparable to R7800. I'm planning to replace my three R7800 ( Dumb AP in AC mode only )

Well that will obviously depend on your deployment and lots of other factors.

I find it to be good in my extremely noisy urban environment (15-20 visible SSIDs) over a 3 floor house with brick walls using two APs and wired backhaul. Lots of devices (20+) across 2.4G and 5G. Real world WiFi transfer speeds over 300Mbps in most of the house (not just in the rooms with an AP).

Your mileage may vary.

Amazon.fr -> 69 € this day

https://www.amazon.fr/Zyxel-Multy-Système-AX1800-Maison/dp/B0BCWM7BBC/ref=sr_1_17_sspa?__mk_fr_FR=ÅMÅŽÕÑ&crid=1RWX14ECXWTQU&keywords=zyxel&qid=1697014134&sprefix=zyxel%2Caps%2C93&sr=8-17-spons&ufe=app_do%3Aamzn1.fos.2a4964d5-da8d-479b-a739-01ef3fadb618&sp_csd=d2lkZ2V0TmFtZT1zcF9tdGY&psc=1

1 Like

Seriously - how are they making any money on these?

My router, which works as a bridge, stops broadcasting if the main network disappears. It's normal? But this is not good for me.
2023-10-11_202927

Yes:

1 Like

Thanks , WSM20 has 2 ranges. I've set up transmission 2.4 -> 5 GHz and after that everything works!
2023-10-11_213659

3 Likes

Sorry for the late reply: I have no clue on that. These LEDs have been added not long ago and at the moment there is no way to configure them in the .dts (which would be the appropriate place). A similar question has been asked some time ago, with no answers.

1 Like

Hi,

can we get confirmation that the current (final 23.05.0, not yet officially released) release (https://downloads.openwrt.org/releases/23.05.0/targets/ramips/mt7621/) works here, so that we can update https://openwrt.org/toh/zyxel/wsm20 ?

thanks


Two devices are running fine for me with 23.05.0 (and since the fixed MT76 WiFi driver was merged into the RCs of 23.05)

2 Likes

I can confirm now as well that installing the new 23.05.0 release worked. However, contrary to information on https://openwrt.org/toh/zyxel/wsm20, no cloud registration is strictly necessary to access the initial firmware upload page http://192.168.212.1/gui/#/main/debug/firmwareupgrade. Reports about this is already in this thread: OpenWrt for Zyxel WSM20 (Multy M1) development discussion - #630 by ghen. I could access it even without long-pressing reset, like this: I unpacked the fresh unit from its box and attached it only to my laptop via lan-port. That laptop was not connected to the Internet as well, so there was no Internet connection at all. As described, http://192.168.212.1 shows a page that essentially tells you to wait until connection with the Internet would be established and trying http://192.168.212.1/gui/#/main/debug/firmwareupgrade redirected to the main page. I left the unit in this state for a while. I do not know for how long exactly, but probably about on hour or so. Some time in that timeframe, the unit must have hit a timeout, because after that time, while http:/192.168.212.1 stills showed the waiting info, the direct link http://192.168.212.1/gui/#/main/debug/firmwareupgrade worked, without ever connecting to the Internet. Using this and the procedure described at https://openwrt.org/toh/zyxel/wsm20 I could first flash the openwrt initramfs image and later the full image - without any need for an Internet connection. If there will be no objections here, I will describe this procedure on https://openwrt.org/toh/zyxel/wsm20 later as well.

Something else that I found curious is: do we know what system the the OEM firmware actually is? I read here that the GPL source is supposed to be available (OpenWrt for Zyxel WSM20 (Multy M1) development discussion - #659 by Annick), but I could not find a repo or download of said code. Could it please be made available? There should not be any reason against it if it is GPL.

The reason I am asking is that I noticed that with still the OEM firmware running as it came out of the box, the unit redirects https traffic to the http port, and for that it uses a certificate that looks like this (note the common name (CN) "Openwrt"):

Certificate:
    Data:
        Version: 3 (0x2)
        Serial Number:
            f2:38:dc:ab:46:19:0d:78
        Signature Algorithm: sha256WithRSAEncryption
        Issuer: C = DE, ST = Berlin, L = Berlin, CN = OpenWrt
        Validity
            Not Before: Nov  5 03:55:29 2021 GMT
            Not After : Nov  5 03:55:29 2023 GMT
        Subject: C = DE, ST = Berlin, L = Berlin, CN = OpenWrt
        Subject Public Key Info:
            Public Key Algorithm: rsaEncryption
                Public-Key: (2048 bit)
                Modulus:
                    00:a7:2c:72:65:ab:8a:16:cd:52:76:47:b7:da:a6:
                    99:d8:49:fa:0e:f8:04:7b:9d:25:ef:0a:a4:61:01:
                    b7:bd:b6:83:ab:b0:0d:1e:cd:f8:6a:22:3f:8a:24:
                    0a:5d:64:5a:42:ec:f9:36:24:1b:a6:8d:2a:3b:7b:
                    b6:82:91:1d:27:5a:2f:fd:e5:87:bb:96:0d:fb:b7:
                    55:36:d0:2d:0b:bd:58:1b:8b:1e:bc:9e:eb:49:58:
                    75:14:80:62:8b:d4:0b:01:34:0d:43:8f:e2:91:d6:
                    ce:1a:66:e8:98:b4:f0:61:69:72:4c:4b:52:ec:05:
                    f3:fd:ba:7d:81:ee:6b:d4:88:b7:a0:a0:8a:d3:03:
                    4e:fc:12:33:41:db:0f:16:97:3c:48:ac:82:cb:4a:
                    00:fe:a3:c1:d6:25:6f:ef:20:3f:b5:88:ad:f3:36:
                    ff:33:ff:a8:1b:70:d8:29:8b:09:d1:90:54:95:c5:
                    8d:19:9c:75:34:40:91:70:b5:de:72:7f:81:e9:e5:
                    6f:11:e0:19:27:fa:7c:26:64:34:8a:f5:2b:68:95:
                    c1:c8:2c:b8:c6:38:3a:95:74:64:16:3b:71:8d:d4:
                    5d:a4:76:a4:c8:8d:3b:92:89:c5:62:69:b1:e4:67:
                    69:7e:3d:a5:84:8f:74:fd:6e:93:e2:e8:75:f5:09:
                    60:b3
                Exponent: 65537 (0x10001)
        X509v3 extensions:
            X509v3 Subject Key Identifier: 
                E9:75:93:1F:45:D6:E2:31:5F:B7:81:E8:C0:86:79:46:B1:0E:4F:C7
            X509v3 Authority Key Identifier: 
                E9:75:93:1F:45:D6:E2:31:5F:B7:81:E8:C0:86:79:46:B1:0E:4F:C7
            X509v3 Basic Constraints: 
                CA:TRUE
    Signature Algorithm: sha256WithRSAEncryption
    Signature Value:
        9d:db:d5:f2:0e:79:15:1f:38:de:9c:00:3a:f7:58:a5:6c:46:
        2a:ca:39:d9:d1:46:2d:08:38:0d:af:47:b3:a2:6b:27:c1:8d:
        7e:58:ff:9b:62:4a:ec:61:ee:71:c8:83:e8:d5:83:c6:08:88:
        28:e9:29:b4:4a:2f:55:fa:f1:11:53:6d:60:20:43:af:20:7b:
        d0:34:d2:41:16:10:93:b1:c2:3e:81:e9:ef:b7:3d:af:2d:e3:
        ef:6a:8a:71:df:57:4e:9b:11:0c:d9:2a:dd:7d:35:a2:79:19:
        0a:a0:c5:92:e5:ff:69:66:2c:ea:51:7a:7d:a8:aa:8d:6c:5b:
        cc:f0:8f:1b:3c:13:5c:85:10:58:ff:12:91:36:74:71:ed:37:
        5d:7c:1d:9b:7d:70:5f:f7:49:d0:a1:ec:55:de:40:a2:da:1f:
        fb:f9:39:25:4d:bd:f9:65:ae:0a:a7:a2:49:01:bf:ce:a6:ad:
        73:7e:c1:13:0a:b3:44:f0:2d:87:7f:2d:f2:3f:62:fa:ed:bb:
        f7:46:0c:c8:37:aa:ef:87:5f:06:37:42:3f:ae:ad:24:c9:12:
        70:24:c1:2e:91:96:5b:a6:2e:f0:e4:6e:39:94:4c:4d:19:51:
        2d:f2:f3:70:73:40:da:2f:3b:89:af:6a:57:35:fe:26:03:47:
        c0:85:52:94

Of course, this being a self-signed certificate, anyone could create a certificate with that CN, but why would Zyxel use a ssl-certificate with a common name "Openwrt", unless their stock firmware is/was some variation of Openwrt?

You can request the GPL drop from ZyXEL and they will send you a download link.

Yes, it's some variation of OpenWrt, just scroll to the beginning of this thread and read the first few hundred posts where we tried to get into the stock firmware.

When setting up my first WSM20 (of a 3-pack, great deal btw, tks for the links!), I have mistakenly accepted the suggestion to update the firmware. Now it seems impossible to access the firmware upgrade link, as it always redirects to the login page. With the other two devices this was not an issue. Waiting for over 1 hour, disconnecting from WAN or any other attempts also did not work.

Anyone faced a similar issue and would know what to do in this case?

The attempt after making the post did work.

  1. Reset the router (I pressed the button for pretty long). This brings the wifi setup back to factory default
  2. Connect to the factory default wifi (I was previously connected over LAN cable, this did not work)
  3. Open the setup page of the router, which asks for connecting the WAN. Connect the WAN and let it finish the initial setup
  4. After this, the firmware page could be accessed again.

Here some information I came across (V1.00(ABZF.5)C0.pdf), concerning differences between OEM firmware versions. I am not sure if it ever might come in handy. The only interesting thing I see so far is the the firmware upgrade page we use to flash OpenWRT was only added in version V1.00(ABZF.1)C0. For me, that was the version my devices came with. But it would mean also that there might be devices with older firmware (ABZF.0), for which this might not work, at least not before upgrading the stock FW.

(The rest ist copy & paste from the PDF file. Note that the given date for V1.00(ABZF.5)C0: 07/03/2022 might be a typo and actually mean 07/03/2023, given that the file date is 07/10/2023 (a week later, but in 2023) and Zyxel itself currently shows a 100ABZF5C0 "End-User License Agreement" file from the exact same date in 2023 on https://www.zyxel.com/de/de/support/download?model=multy-m1-wsm20 - but with a broken link.)

V1.00(ABZF.0)C0: 08/31/2021
[Initial Version]

V1.00(ABZF.1)C0: 11/15/2021

Enhancements:

  1. Update DUT's root password process for root access of the device.
  2. Add debug firmware upgrade page and remove SSH remote.

Bugs fixed:

  1. Notifications cannot work fine.
  2. In Diagnose/Mesh page, Multy name should show user-defined name
  3. Home > Multy Router > enable IPv6, then IPv6 page not display WAN IP and
    LAN IP
  4. Install as stand alone, the wireless clients not show in Parental control page
  5. If Controller is in bridge mode. then Agent not show detail information in GUI
  6. After Device reboot, New client notification will inform to APP again.

V1.00(ABZF.2)C0: 02/21/2022

Bugs fixed:

  1. Fix Power LED and Wireless LED non reason blinking.
  2. Change System Name and Domain Name, agent LED is blinking and cannot
    connect controller.
  3. Change WiFi setting and agent sometimes cannot connect to controller.
  4. After Agent associate to Controller via WPS, Agent reboot without log
  5. DUAL Stack+IPv6 LAN End number less than Start number "Apply" should not
    be accepted
  6. Use GUI install M1 then Multy Android APP open IPv6 that LAN address will
    repeat
  7. Parental Control add same profile name and fail to change profile
  8. APP can not delete "off-line" client from client list
  9. If Agent uplink is down, then Agent LED is not blinking for WPS downlink
    process

V1.00(ABZF.3)C0: 03/31/2022

Enhancements:

  1. Support IGMPv3

V1.00(ABZF.4)C0: 05/12/2022

Enhancements:

  1. Support Mesh uplink information
  2. Support External Guest function
  3. OpenSSL vulnerability update 1.1.1n patch

Bugs fixed:

  1. Remove UPnP Network device detail information with serial number
  2. Force FW upgrade tap cancel direct to wrong page

V1.00(ABZF.5)C0: 07/03/2022

Known Issues

  1. With IPv6 enabled, pictures, files, etc. on Line cannot be sent and received

Enhancements:

  1. Modify agent online check & fix update bssid.
  2. support “Digitalisierungsbox PREMIUM 2” and “Digitalisierungsbox SMART 2”
    follow uMeshController db.
  3. Add patch to remove mtk mesh send arping.
  4. Add HLD to send reload mesh req.

Bugs fixed:

  1. Fix uMeshController daemon failed.
  2. Fix Write /tmp/ApplicationData/map.cfg failed.
  3. When set traffic_separation data, to check old value.
  4. If controller mesh daemon failed, send request to reload agent mesh.
  5. When change backhaul type [Ethernet->WiFi], send request to reload agent
    mesh.
1 Like

Concerning that version: I got a message by Zyxel that "RD team found some code issue on ABZF5C0.Therefore, the internal decided to remove ABZF5C0 from the Website. Right not, only ABZF4C0 is available."