OpenWrt for Zyxel WSM20 (Multy M1) development discussion

I just received my WSM20 and did some tests:
Power consumption idle + 2x wifi-AP (idle) 4,5W; +0,3W per connected ethernet port; +3W on WiFi loaded with 100 Mbit/s downstream AP-> device, +2W with 35 Mbit/s Upstream Client -> AP

In comparison to the WAX206, the WiFi signal was about 3 dB weaker on my Google Pixel 6a. Also, throughput via iperf3 (Pixel 6a towards my computer, Phone via WiFi, computer via ethernet) was in most cases 30..50% faster on the WAX206, at one position 10% faster on the WSM20.
I achieved ~750 Mbit/s download (vs. 850 Mbit/s WAX206) 10m with line of sight
... 300 Mbit/s (vs. 500 Mbit/s with WAX206) 10m with obstacles
... 30-50 Mbit/s (vs. 100 Mbit/s with WAX206) 15m with more obstacles (both running on 80 MHz with max. transmit power of 23dBm).
In most cases, the MCS index on the WSM was lower than the one on the WAX, sometimes also the MIMO count dropped to 1.

WSM20 firmware was todays snapshot ad233c6ddd63, WAX206 was on r22565-877ec78e23, so quite a bit older.

Also, I had the "mediatek AX upload problem" with the WAX, not with the WSM20: As soon as I had obstacles on the way, the client device upload was stuck on the lowest MCS level. I did not follow recent patches that might have been on snapshot or not, in any case afaik so far this was only ever reproduced with apple devices? Well, I reproduced it with my Pixel6a.

All in all, the WSM20 is a great device for its price but the WAX206 is superior with range and throughput.
Still, the WSM20 is a far superior device than the well known Archer C5 on ath79, as long as you don't need USB :wink:

5 Likes

Also the WAX206 has 2.5G Ethernet, which future proofs for when connections are that fast.

I’m still pretty happy with my 3 WSM20 (~£85) devices for the cost of of one WAX206 (RRP £145, prime day offer ~£80) device. Also my range is excellent despite being in a city and having ~50 visible SSIDs! :blush:

Looking forward to 23.05.0 RC3 as it should have the fix for AX capable iOS devices, which I think is the last significant bug on this device?

1 Like

May I ask how long it takes from here forwards to a final release version incl. Luci?

And may I flash the latest sysupgrade.bin just over the old one and keep Luci? Or have to install again?

Depends on how many critical issues are found in the RCs.

Yes, RCs and stable come with luci, snapshots don't.

1 Like

Thx! Very appreciated!

Hello everyone,

I guess I made a mistake ... I wanted to go for a WAX206, but availability and price of the WSM20 was much better, and in the end, I chose the latter... and I am stuck in the installation :worried:
So, I have tried to follow the procedure here: https://openwrt.org/toh/zyxel/wsm20#via_web_interface
I downloaded the snapshot files, verified the ha256sum and then started... after connecting the Multy M1 to the internet via cable, I could access the web GUI and upload the file xxxxkernel.bin.
The problem is that the Multy had not rebooted (after many minutes), it was stuck loading something, the message was "Welcome to the web configurator" and then "Warning, we are experiencing some service problems. Refresh the page and try again later". Which I did, but always same results, even after 1 hour.
Last resort, I thought of disconnecting the power supply or resetting the Multy M1 by pressing the reset button on the rear. In the first case, after reconnecting again, it was stuck on the same page, and in the second case, the device did not respond to the button (it did not turn off or reboot), but keep staying on the same page.

Since I am not an expert on flashing OpenWRT, I would appreciate some guidance.

Thank you in advance to those who will take the time to read and reply.

To reset you need to hold the reset button for quite a while then release it.

The first install doesn’t do a full reboot, it just reloads from RAM. There’s no web ui so you will need to log in via ssh and scp the sysupgrade firmware

Since I am not an expert on flashing OpenWRT, I would appreciate some guidance.

I am not an expert either, but I have successfully flashed two of my three WSM20s. I have not tried the last one yet.

As timothyjward says above, the problem probably was that you did not login using SSH after the initramfs image upload was done in the OEM firmware.

I have not tried it myself, but I believe it is possible to use the firmware selector to build an initramfs/"Kernel" image with the LuCI GUI for use with the OEM flash web page. Add "luci" without quotes to the "Customize installed packages and/or first boot script"/"Installed packages" text box and click "Request build".

When OpenWrt boots it should assign an IP in the default 192.168.1.1/24 range to the computer attached to a LAN port. From there you should be able to login at 192.168.1.1 with SSH (putty in Windows) and run the sysupgrade command on a sysupgrade image file (which you can transfer to the router with WinSCP on Windows, chose file protocol SCP). Or if you added luci in the firmware selector, you should get LuCI at http://192.168.1.1 from where you could go to the firmware flash page and flash the sysupgrade image.

When you flash the WSM20 from the OEM firmware, the LED patterns looks like this according to my notes:

  1. initramfs is being written: Red flash
  2. Boot is starting: Green steady
  3. Linux starting: White flash
  4. Linux ready: White steady

It can take a few more seconds before everything is ready. Wait 30 seconds or so with the white steady LED before trying to connect.

1 Like

If you use a snapshot image, there is no LuCI. If you use a 23.05 RC image (i.e. a release build), LuCI is included by default.

Is that the case for the initramfs images? I assembled custom snapshots including Luci, but the initramfs image used as the intermediate installation step still had no web interface.

Following my request I received today the GPL code for the WSM20

No problem for build with Ubuntu 16.04 LTS Desktop 32bit

1 Like

Thank you @timothyjward for your reply.

I pressed for more than 10 seconds ... I thought it was enough

I should have misunderstood the instructions then, where it is written "Wait for OpenWrt to boot"... I thought I should see a different page when connecting to the router

OK, I can try again during the weekend. Now that I stopped in the middle of the process (and removed the power supply), I am wondering what I should do ... even by unplugging the device, the web page was stuck as explained above ....

I am jealous :laughing:
Would you like me to send a new sealed unit in exchange for one of yours already flashed?
OK, just kidding...
Or perhaps the 3 of them in exchange for the 2 flashed? OK.... I will stop here...

Back to the serious topics:

Yes, I confirm. I was waiting for "Wait for OpenWrt to boot and log in via SSH" before trying with SSH...

Thank you for all your suggestions @KAD
Do I understand well that if I use

I can Luci directly installed and available without additional effort?
If yes, I do feel completely dumb... I believed that the easiest way was following the instructions in https://openwrt.org/toh/zyxel/wsm20#via_web_interface

Hi again @KAD,

I have just tried, but what I can understand from that page is that the file created is sysupdate, so I should

  • first upload the -initramfs-kernel.bin file and flash it,
  • then wait for OpenWrt to boot and log in via SSH
  • finally, transfer the sysupgrade file via SCP

I mean, I cannot use the file generated directly in the OEM flash web page. Is the above correct?

Thank you in advance

This is correct.

While some people are saying that you can get an initramfs image including Luci this hasn’t been my experience, so the ssh/scp approach is what I would recommend. Note that you will need -O for scp to work (as I found in OpenWrt for Zyxel WSM20 (Multy M1) development discussion - #534 by timothyjward)

Hi @timothyjward,

Thank you for the confirmation.
I will try to give another try... let's see

It's weird because for once a manufacturer Zyxel makes available the GPL code of a product :
wsm20
and the compilation works that nobody is interested in

Hi @Annick,

I guess my problem is that I know noghing about OpenWRT, which means that, if I do not have a step by step guide, I will not be able to follow. Just to explain that I do not understand what I should do with GPL code and compilation ...
Apologies ...

Where is it? I did not receive the GPL code upon my request a few months back.

Can you private message me the link for educational purposes?