OpenWrt for Xiaomi Mi Router 4C

Hello again friends, I share a capture where you can see what I explain in the message. I look forward to your kind help. Thanks!

Does anyone
mesh running without packet loss

Packet loss occurs only with activated wpa3

no loss without security

Wpa2 is not possible

and the device fails even when the wifi is very busy

The device should not be bought for openwrt

I'm using 4C + openwrt, works fine for me. I donot use wpa3.
4C is a simpliest MT7628DAN router, the IC is many years in the market. Many cheap routers use this IC.

1 Like

Hi guys, my Mi Router 4C (MediaTek MT7628AN) was with 21.02.0-rc1 OpenWRT then I upgraded the router to 21.02.1. It was installed successfully. But after it, I need to change back to original firmware, so I flashed miwifi_r4cm_firmware 3.0.16_ENG.bin but after for a while, Orange LED light shows up, it starts to blink, it takes at least an hour so I tried to hardset with reset button. But now after it, the Orange LED light keep blinking. I cannot access to both 31.1 and 1.1. via WAN and LAN, How I can debrick this router? Thanks guys.

try this:

1 Like

802.11s It does not work
Client It does not work

Connection breaks

When the wifi is marginally loaded

packet loss with wpa3

If you can call it working then it's really funny :crazy_face:

Before mocking me, maybe you should try to find out what you've done wrong. And you should also know that you have to visit OpenWrt wiki to get the latest version. :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face: :crazy_face:

1 Like

Hi, stock rom is very old and very customised version of OpenWrt and we can't help you here.


I use Openwrt not stock :rofl:

1 Like

That message wasn't a reply to you. Can't you see it?

Thank you very much for answering friend. I have another question if you can guide me, the function of limiting the speed or bandwidth per individual device I can manage if I install OpenWRT without news for my 4c router. Already grateful

Hi guys! I have been using my MI router 4C with openwrt for a while (Thanks to you @MacTavishAO). I have tried implementing mesh using 2 MI4C routers. But couldn't get it to work. Is there any limitation in hardware or software in the router that prevents me from implementing 802.11s or its just me making some mistake? Thanks!

Hi guys! I have a Mi rounter 4C. I want to flash openwrt follow the guide from
But I can't connect telnet to device although OpenWRTInvasion is run normal.
My stock firmware verion: MiWiFi Release 3.0.23.
I also change the version of OpenWRTInvasion follow the but it does not help

Reboot your router and try again. It happens rarely but it happens.

Thank you very much. I can flash openwrt after downgrade to miwifi_r4cm_firmware_3.0.23_INT.bin and a few times reboot.

Hi @Dharun_561, I plan to setup mesh with MI router 4C too. Have you make it work yet?

I'm not recommending using this device for OpenWRT. Thank developers for putting effort to make this device supported.

your post ,it is usefull,The wish I was waiting for come true

I changed ubouut, used sources with webconsole, and removed unncecessary mtd. Nasically only uboot uboot-env factory and rest empty. Desolder flash with hot air is a minute job. now im trying make new uboot from upstream sources...