OpenWrt for Greatek WR2500N?

Hi. Greetings from Brazil.
I have a Greatek WR-2500N (Firmware I found on the internet and save the manufacturer discontinued this model and the WR-2500HP). I am using this router to receive internet via Wifi (Wireless ISP configuration) and it not has IPv6 support.

I would like to use OpenWRT on it (or maybe modify the original firmware), but it's not on the supported hardware list. May be it is a rebrand router?

I do not know much about the technical especifications of this router, but I know it has 100Mbps ethernet ports, 750mWatts and it has the following text on the router's log:

Nov 20 04:48:09  klogd started: BusyBox v1.1.3 (2012.06.25)
Nov 20 04:48:09  RTL8192C-RTL8188C driver version 1.5 (2012-05-04)

Can you run dmesg on its command line shortly after booting?

1 Like

I didn't find the command line on the router's configuration web access.
It refuses connection on the SSH port

Looks like a very old, 801.11g, WPA-only (trivially insecure) device from

Knowing the chips inside would be helpful, but hardware that old is unlikely to perform even moderately well. Given its age, it probably does not have enough flash or enough RAM to run secure firmware.

Given its age, have you tried Telnet?

1 Like

I think the manufacturer released some upgrade version, mine router is running at 801.11n and 150Mbps WPA2.

The original firmware has 1,7MB, maybe it has only 2MBytes of storage?
I can't open it on this moment, but as soon as possible I will open and take pictures of the chips.

I haven't tried telnet yet. I will try, thank you.

1 Like

2 MB of flash is not a possibility. 4 MB is very, very tight, likely no GUI possible.

RAM is another challenge -- at least 32 MB is required for very basic operation.

1 Like

Telnet doesn't work.

~$ telnet
telnet> open
telnet: Unable to connect to remote host: Connection refused

I can't upload all photos in the post, so I uploaded to imgur: [] (Greatek WR-2500N internal images)

25L1606E is where the firmware is stored?
It is the same type of chip PC BIOSes uses. I have tools to program (CH341) and replace it if the problem is the flash size.

W9812G6JH-6I seems to be the RAM chip, 16MBytes.

Aside from the obvious issues with the RAM (16 MB RAM are impossible), your bigger issue would be the Lexra SOC - which is unsupported in OpenWrt (and probably never will be; there are plenty of more verbose threads about the implications of Lexra in this forum).


Thank you.

I found this page
I will read this threads, but because these implications I maybe put aside this project.

1 Like