OpenWrt Firmware for Archer c6 v3.2

My archer c6 v3.2 has stuck on all green light. not working. what can i do right now?

Well it seems your device is bricked i can say that because i also had the same problem, so you can simply do one thing. Go to lan settings and set your lan ip as 192.168.0.66 and set subnet mask 255.255.255.0 then save it, after that open up a browser and type 192.168.0.1 and see if the routers default recovery partition page is loaded, If yes then just load up the Default firmware from official tplink site must be v3.2 and you router should flash the firmware and up and running. Let me know if it helps.

Actually, I just realize that I already updated the router with snapshot images, how to go on Luci or stock img. how to access router with windows 10.

Snapshot images does not include LuCI. You can install it by using SSH, connect to the router, run:

opkg update
opkg install luci

Make sure the router has internet acces, if not, you have to configure it with SSH or, if you have one, upload a backup that has the correct settings.

If the router is bricked, it also behaves like this, all LEDs on, steady, not blincking. You can recover it with the "recovery page". Get the right firmware from TP-link website, same region and HW revision. Set your PC a static IP, such as 192.168.0.2(not the router ip, wich is 192.168.0.1), subnet mask, etc.
Then open a browser and go to 192.168.0.1, you will see a page that asks for uploading a image. Click on "browse" to get the image from the PC, then "upload" and wait for the install, in about 2-3 minutes you should have the default firmware back.

1 Like

Have anyone tried this build, please let me know. Does it come with pre installed luci?

https://downloads.openwrt.org/releases/23.05.0-rc3/targets/ramips/mt7621/openwrt-23.05.0-rc3-ramips-mt7621-tplink_archer-c6-v3-squashfs-factory.bin

It should, I think it does, I'm on the sysupgrade version of RC3 and it definitely has LuCi.

Hey there,
I have big issues with MT76XX devices one is a TP-Link RE200 v2 (with ramips/mt76x8), the other is the TP-Link Archer C6 V3.2 mentioned in this thread. We have several virtual APs for different "user" groups: internal, guests, iot, etc. (conecting to different vlans) In addition to that I'd like to use the RE200 in traveller mode, connecting to a wifi a client.
however, when I set up more than 3 virtual APs, the interface always crashes. Right now I have no log showing that, but the problem persists with all firmware versions (even with 23.05.0.rc1/2). is this a known problem (haven't found anything about it anywhere)?

Many greetings Flomow

Any news on performance? is the Luci interface working ok with the latest release? Is the 5Ghz dropping connections issue solved? I want to install it but it is a bother for me not having a "bug free"build,

1 Like

Doesn't that counts as an issue?

Hello, I have a question to ask for people who have done something similar or have a little more experience.

I currently have a C6 v3.2 with OpenWrt "SNAPSHOT" r21164-ef597b026b and I had to install LuCI (Master git-22.299.72136-a98e2ea) to have a graphical interface. All this works perfectly and super stable. But now I want to update my router from the current SNAPSHOT version I have to the stable release 22.03.5. To then install the recently released stable version of OpenWrt 23.05.0. My questions are the following:
1.is there a problem with moving from a SNAPSHOT version to a stable release 22.03.5?
2. Is the installation order to use okay: snapshot>22.03.5>23.05.0?
3. I have the option to update my snapshot to the latest version: SNAPSHOT - r24124-518923178c, is it necessary for me to update and then install stable release 22.03.5?

Thanks for your answers and sorry for my English.

You can install 23.05.0 directly from snapshot. You'll have to reinstall packages you added. I think that config is compatible, but if it is not, you can start from scratch. Why do you want to install 22.03.5 - it is not required if you are going to be installing 23.05.0.

Hello, because in the reléase of 23.05 Say that * Sysupgrade from 21.02 to 23.05 is not officially supported. It also doesn't say anything about updating from a snapshot. Mainly that's why I was asking to check that the installation doesn't give me problems later. and thanks for your answers.

https://forum.openwrt.org/t/mt7628-problem-with-wifi-4-vaps/176628

here is that log, that shows the crashing, is exactly the same at the archer c6

any1 that updated to 23.05.2 experienced problems?

i did a update selecting keep settings and retain configuration on my archer c6v3 i use as dumb ap and update went very badly.

after update i could not access router using Luci and needed to perform a factory reset (so retain configuration was useless), and even so sometimes i cannot log into Luci using the IP assigned from my main router.

I updated the C6 v3 to 23.05 and did not have any problems. After the update my config has been wiped and I had to re-do it (there was a warning before the update process).
I am using the device as a wireless bridge.

same here. not letting me to do vlans. evertime i try it gets stuck and have to reset

Hi, lucioosvaldoXD,
Do you a new link for the google drive files as it is not working?.

Thanks

hello, help please people, led power on, 3 min reboot, need full flash dump c6 v3.2, send please rzcalex@gmail.com

power on
lan dont work
uart - good, command httpd - server on, link diod 5 on, and lan dont change status - off, not connect to network....i don't understand, help please, need dump fullflash spi

Hi @dsouza. The link isn't working anymore. Can you send it again?