OpenWrt Firmware for Archer c6 v3.2

To install on a stock firmware, I just have to upload the factory.bin into the tp link stock? and If I want to go back to stock firmware, what do I do? is it safe? I have a Archer C6 3.2

Yeah, I did that. I was unable to get it to work as the connection kept dropping. May be a job for another weekend :wink:

1 Like

Unless you brick the router, the same process works the other way...
On the firmware page in LUCI you can upload the stock firmware and reset the device back to it...

I have uploaded the factory bin on my c6 v3.2 and its been running fine for 2 weeks now! fingers crossed, i dont want to jinx it!

I updated too, I still do have the 5GHz stopping when I have more than 1 STA on it ! Hope this will get fixed asap !

Was this fixed , I also own a c6 v3.2.And was hoping if I could flash openwrt Onto it.
What are the Current issues.And can I get the links to flash it.

1 Like

Unfortunately, this chipset is really bugged right now, see the amount of issues for unexpected disconnections here: https://github.com/openwrt/mt76/issues
Also, linux kernel development for these devices seems not very active. Too bad, I have the device only operating on 2.4GHz right now.

1 Like

Hi all,

I'm a newbie, I have never modified the stock firmware of my routers, yet.... I'm another unhappy owner of two Archer C6 routers, facing many disconnections, among other minor issues; at this stage, I don't really care if I bridge one of the units, although I prefer not to...
Just to check I have understood the procedure, I should first do a hard reset on the C6 to return iti to factory settings, then through the TP-Link menu go to the Advanced > Firmware, and seect the file provided by @amishv (many thanks for the file). Is this OK?

Thanks in advance.

1

you may download the latest snapshot from https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/ and flash as the steps given. There are some issues with 5G WiFi but it should work fine if you let country as driver default.

2 Likes

How do I go back to stock firmware? using Luci firmware upgrade itself?

Does this router have tftp recovery mode?

just put the stock firmware file into the luci upgrade bin . Should Be done

1 Like

I flashed the openwrt firmware through tplink webui, and it flashed successfully, but 192.168.1.1 refuses to connect, I can access it through putty but can't update luci because I have a static ip connection so I will have to manually put in ip , dns to access the internet, stuck. What do I do? Router is not booting into recovery mode also

Hardware- Archer C6 v3.2 eu

1 Like

You got a couple of ways to do this (usual cause is that by default sometimes the firmware does not allow you to go into admin console over WiFi)

Option 1 : in the system settings enable access to admin over WiFi. Then make sure your WiFi settings are updated to allow for Internet connection...

Option 2 : use 2 routers, one that's running your Internet, connect this router to lan port of other router and use a cable to connect to the this one.. That will make the ip work....

So I make connect it to a router with internet access and assign it a DHCP ip , will that work to install luci?

Nopes.
The client IP of your routers wan port won't be same as the static ip of your routers lan port.

If the router is set to default it will connect the lan to wan...

Butmake sure your main routers ip is not same series as this ones...

So in nutshell

Other router 192168 xx. 1
Client up for your openwrt router 192168xx.yyy

Lan ip of your open wrt router (static) 192. 168.1.1

Then when u connect your lan cable to pc your PC will have
192.168.1.xx

Now I don't wanna confuse you, there is away to access router as 2 clients also but just do above... Its simple...

You could configure it from ssh, you need to edit /etc/config/network using vi which is the default editor present in openwrt.

complete noob here,
ran in to same bug as chirantan300 , cant able to access 192.168.1.1. after upgrading to snapshot given in the above link.
please link me to any video tutorial so that i can revert back to stock firmware use SSH

1 Like

First of all it is not a bug. snapshot builds don't contain luci .

To ssh into your router, plug in lan cable and open cmd, and type in

ssh root@192.168.1.1

Then you will recieve a prompt, then type yes.
Now verify that you have internet access by typing in :-

ping google.com

If you see any thing other than failure, that means your internet is working and you are using DHCP. Now we can install luci, which is the configuration interface. to do that, type

opkg update && opkg install luci

Thats it.Once that command completes you should be able to access your router through your web browser, and use openwrt normally or revert to stock.


However if you dont have internet access when pinging google.com , then that means you dont have a modem with DHCP support, and are probably using a static IP or PPPOE . This is where it gets slightly compicated. There are a few things to know before you proceed. Your static ip address if you are using static ip, or your pppoe username and password if you are using pppoe.

then when you are in ssh, type :-

uci set network.wan.proto=pppoe
uci set network.wan.username='yougotthisfromyour@isp.su'
uci set network.wan.password='yourpassword'
uci commit && service network restart

If you have a static IP steps are very similar

uci set network.wan.ipaddr=your-ip-address
uci set network.wan.proto=static
uci set network.wan.gateway=your-gateway
uci set network.wan.netmask=255.255.255.0
uci set network.wan.dns=your-dns
uci commit && service network restart

and then you should have internet access, and then you can install luci.

opkg update && opkg install luci

refer here for more info

4 Likes

refer to my previous comment above

thanks for this comprehensive guide, i had internet access and was able to install luci n for now i've reverted back to stock firmware.

1 Like

Hi,
I am also facing the same issue with 5Ghz.
I choose country as default , even though the driver doesn't start.
I also tried after flash, in that case also 5Ghz didn't start.
I don't know how to tshoot this in hardware level.
Please help.