OpenWrt Firmware for Archer c6 v3.2

You got a couple of ways to do this (usual cause is that by default sometimes the firmware does not allow you to go into admin console over WiFi)

Option 1 : in the system settings enable access to admin over WiFi. Then make sure your WiFi settings are updated to allow for Internet connection...

Option 2 : use 2 routers, one that's running your Internet, connect this router to lan port of other router and use a cable to connect to the this one.. That will make the ip work....

So I make connect it to a router with internet access and assign it a DHCP ip , will that work to install luci?

The client IP of your routers wan port won't be same as the static ip of your routers lan port.

If the router is set to default it will connect the lan to wan...

Butmake sure your main routers ip is not same series as this ones...

So in nutshell

Other router 192168 xx. 1
Client up for your openwrt router 192168xx.yyy

Lan ip of your open wrt router (static) 192. 168.1.1

Then when u connect your lan cable to pc your PC will have

Now I don't wanna confuse you, there is away to access router as 2 clients also but just do above... Its simple...

You could configure it from ssh, you need to edit /etc/config/network using vi which is the default editor present in openwrt.

complete noob here,
ran in to same bug as chirantan300 , cant able to access after upgrading to snapshot given in the above link.
please link me to any video tutorial so that i can revert back to stock firmware use SSH

1 Like

First of all it is not a bug. snapshot builds don't contain luci .

To ssh into your router, plug in lan cable and open cmd, and type in

ssh root@

Then you will recieve a prompt, then type yes.
Now verify that you have internet access by typing in :-


If you see any thing other than failure, that means your internet is working and you are using DHCP. Now we can install luci, which is the configuration interface. to do that, type

opkg update && opkg install luci

Thats it.Once that command completes you should be able to access your router through your web browser, and use openwrt normally or revert to stock.

However if you dont have internet access when pinging , then that means you dont have a modem with DHCP support, and are probably using a static IP or PPPOE . This is where it gets slightly compicated. There are a few things to know before you proceed. Your static ip address if you are using static ip, or your pppoe username and password if you are using pppoe.

then when you are in ssh, type :-

uci set network.wan.proto=pppoe
uci set network.wan.username=''
uci set network.wan.password='yourpassword'
uci commit && service network restart

If you have a static IP steps are very similar

uci set network.wan.ipaddr=your-ip-address
uci set network.wan.proto=static
uci set network.wan.gateway=your-gateway
uci set network.wan.netmask=
uci set network.wan.dns=your-dns
uci commit && service network restart

and then you should have internet access, and then you can install luci.

opkg update && opkg install luci

refer here for more info


refer to my previous comment above

thanks for this comprehensive guide, i had internet access and was able to install luci n for now i've reverted back to stock firmware.

1 Like

I am also facing the same issue with 5Ghz.
I choose country as default , even though the driver doesn't start.
I also tried after flash, in that case also 5Ghz didn't start.
I don't know how to tshoot this in hardware level.
Please help.

Hi guys,
First of all, thank you for this thread. Lot of useful information on here regarding the TP-Link Archer c6 v3.2.

I'm using the snapshot OpenWrt SNAPSHOT r17178-373c08bcbb / LuCI Master git-21.196.22411-7d9ab8d and I seem to be having a problem with connecting to the WAN.

My ISP requires me to have a static public IP. I'm able to configure a static IP for the WAN, but when I try to connect to the internet, I'm unable to.

There is a MAC address restriction, so when I'm switching routers (from my current router to the TP-Link having OpenWRT) I'm on the phone with the ISP and they're resetting the MAC address restriction so the new router can connect.

I want to point out that before installing OpenWRT, when using the stock firmware, I was able to connect to the internet without any problems.

Any thoughts?

1 Like

A post was split to a new topic: Wifi performance Archer C7 v4 vs. Archer C6 v3.2

Have you actually tried and can confirm this works? I mean, the stock firmware image normally cannot be flashed directly in OpenWRT without firstly stripping bootloader (with the risk of bricking the router requiring TFTP or a recovery mode to restore it).

I am asking since I've tried to enter the recovery mode by cycling power four times (see below from A6 v3) but it did not work.

I am OK running OpenWRT for now but I would like to know how to revert to stock firmware just in case.


Archer A6 V3 has recovery page activated if SPI booting from flash fails.
Recovery page can be activated by powercycling the router four times;a=commit;h=d22fb7f4fd833c420bc2ab34384862da0a6688b5

OK, answering my own post... :roll_eyes:

I previously successfully reverted a RE200 v2 from OpenWRT to stock firmware using the tplink-safeloader utility as documented in the RE200 wiki here.

So I checked the tplink-safeloader source code and it seems that A6/C6 v3 are supported:

/** Firmware layout for the Archer C6 v3 */
/** Firmware layout for the Archer A6 v3  */

So I just took the stock firmware a6c6_v3-up-ver1-0-10-P1[20210513-rel63256]_2021-05-13_17.34.01.bin and executed the following command:

./build_dir/host/firmware-utils/bin/tplink-safeloader -z a6c6_v3-up-ver1-0-10-P1[20210513-rel63256]_2021-05-13_17.34.01.bin -o a6c6_v3_sysupgrade_factory_revert.bin

And now I have a a6c6_v3_sysupgrade_factory_revert.bin file that can potentially be flashed via OpenWRT sysupgrade to revert both A6/C6 v3 back to the stock firmware if needed (sysupgrade a6c6_v3_sysupgrade_factory_revert.bin -F).

I HAVE NOT TESTED IT yet since I do not have a UART/serial console connection to activate TFTP recovery in case things go wrong.

Anyway, if anyone wants to try (with the risk of bricking your device and needing a UART/serial console to recover) here is the revert .bin file in my OneDrive that could be flashed via OpenWRT (forced) to revert back to the stock firmware:

Size: 16121856 bytes
SHA256: 9D6F0AB90E04601C4150C320E9FC8A9642F26327E87104504DC6531CF02E2713

BTW, if anyway manages to activate the Archer C6/A6 recovery mode without a serial console please share.



I flashed the stock firmware taken from TP-Link website using OpenWrt. Which soft bricked my router and turned on the recovery web page and from there i was successfully able to flash the stock firmware.


Wondering how to get the Stable release instead of the Snapshot.
I've been using Snapshot for about a month but there are issues.
Can I just use the A6 V3 binary from release or do I need to patch and rebuild ?
I'm guessing the lazy option is to wait for 21.02.1 however that can be another 6 months.

Unfortunately the Archer C6 v3.2 has not been commited to the 21.02 branch yet. I just confirmed that it is not available in the "make menuconfig" in the 21.02 branch.

Therefore for now using Snapshot builds is the only option.

However I am not sure about installing the OpenWRT build of Archer A6 v3 build on the C6 v3.2. I have never tried, but since the stock firmware for the A6v3 and the C6v3.2 are exactly the same, I believe here is a chance it should work with OpenWRT as well (someone has to test it! :slight_smile: )

1 Like

[Openwrt newbie here]


I used your stripped file to revert my device to default (using sysupgrade ...) and it worked! (In fact it preserved my old configuration).

I tried to use openwrt-ramips-mt7621-tplink_archer-c6-v3-squashfs-factory.bin , install the sysupgrade and then luci but i wasn't able to login, so i returned to stock. Anyone have accomplished it?


Thank you for confirming that the stripped stock image allowed you to revert the Archer C6 v3 back to the stock firmware!

Upon the first OpenWRT install, the default logon is "root" with a blank password. If you are unable to login this way, you may try to perform an OpenWRT factory reset.

To do so, after the device is powered on and you are able to see the OpenWRT logon screen, press and hold the "Reset" button in the device for at least then seconds and release it. This should clear all OpenWRT settings and remove any previous password. More details in the OpenWRT wiki here.

1 Like

Oh, i did that, however the Luci interface didn´t show (my browser show that server sent an empty response). I followed the instructions in:

I made a little bit of research and found that installing the package luci-ssl-nginx (instead of all others) allowed me to see the GUI but it didn't allow me to gain access due ¿main? faile damaged of XHR request timeout.

Just installing LuCI and accessing via http (not https) should work.

It might be an issue with the recent Snapshot builds (see SNAPSHOT: LuCI will not launch r17571 and r17581 on WRT1900ACv1)