OpenWrt Firmware for Archer c6 v3.2

@RaresC95 I also tried that with holding reset for 6 seconds and even until WPS led started to flash. The router could not connect and leave logs on the tftpd64 running on my computer. I found somewhere that this might be caused by Windows not bringing up the ethernet interface fast enough.

Maybe using Linux will solve the issue? I successfully used windows 10 for this operation on other routers and it worked.
You can intentionally brick the router so you could get to the recovery page and upload the firmware there. The router will show a steady light on all LEDs and it will only be accessible through static IP. Set as IP address and as default gateway. Be sure u have the correct TP-link Fw before u do it in case the OpenWRT don't work so you can reinstall original Fw through web interface.
Acces the router at and try it on multiple browsers, for me the page don't show up on Google Chrome, only Firefox and edge.
The page is a simple one with only "browse" and "upload". U can't go anything wrong.

BUT BE CAREFUL, on some cases even the recovery page isn't available depending on the "bricking level". Try bricking the router by installing a wrong firmware from other router, not by power off during install, the second ones are much bad and can result in a complete brick instead of a smaller one with web acces to recovery page.

Installing openwrt is very easy process.openwrt can be installed directly from tplink web interface.if it is not working then something is can create a seperate thread for the issues.
Maybe this will help you solve the problem,check wheather sha256 checksum of your downloaded file matches with the checksum given in the download page of openwrt, if it is not matching redownload the file again and install.

@RaresC95, I am just planning to learn Linux by using OpenWrt :wink: so no chance right now. How I can "You can intentionally brick the router"?

@Magneto, for some reason, it is not as simple as it should be :frowning:
Checksum is correct:

but when I try to upload it via TP-Link software, then I get:

If the router can't boot normally, it will show a recovery page where you are asked to upload a FW image.
In general, the routers are bricked in 2 ways:

  1. Power off during install firmware procedure.
  2. Wrong firmware, another router/wrong version

BUT, sometimes, if the router is bricked because of a power failure during the install procedure there are some chances that the recovery page won't show up, and, then you have 2 options: TFTP or opening the router to connect your PC via UART.
You can intentionally brick the router by install a wrong firmware file, another router version/another region version, after that, u will get the "boot fail" or "U-BOOT" page that will ask for a FW file. The same thing is happening when you have OpenWRT and try to install back the TP-LINK FW, it will fail and the recovery page will show up asking to upload the firmware, there u can upload any firmware, the OpenWRT again or the TP-link. It is the same if u have the TP-Link Fw and brick the router so you get the page where u can install any Fw like OpenWRT.

Which variant of archer a6 v3.2 you have?

1 Like

Last night I had the first issue since 22.03.3 update, the router, after about 4d uptime, rebooted itself during night, I finded out this morning and I saw the time of the reboot in the PPPoE connection logs offered by the ISP. As I said, it rebooted itself and remained in a weird state, only the power led was on, no WiFi, no ethernet link. It came back to "life" after powering off then on. I connected a laptop with a SSH running with "logread -f" command, maybe I can catch the last logs before any crash/reboot.

It looks like you are also affected by

What version were you using before? Do you have HW acceleration enabled?

It started to happen after update to 22.03.3, no problems with 22.03.0 - 22.03.2. I will revert back to 22.03.2 to see if it's happening on that version too, but, on those versions I had +30 days of uptime. I never used the HW/SW Offloading, the only change since the update is using WPA2/WPA3 instead of only WPA3, since I got an older tablet that can't connect with WPA3.

I am back on Openwrt after having taken a break from it since July and I wanted to say thanks to the developers for having fixed the biggest issue that I was having.
I've been on Openwrt 22.03 from RC1 to RC4 and I think RC5 and I was having an issue where my main phone would disconnect and not reconnect to wifi, it was unusable so I flashed back to stock in July, to give Openwrt a bit more time to mature for this router.
Everything is completely stable on stock, I wasn't getting any disconnects.
Then I saw people having problems with 22.03.0 so I didn't flash it.
Today I wanted to flash Openwrt again but I saw that people are having problems here with 22.03.3. So I decided take versions step by step from 22.03.1 and 22.03.1 was a disaster, none of my devices would connect to wifi.
Then I remembered seeing that 22.03.2 was released shortly afterwards because 22.03.1 was buggy.
So I flashed 22.03.2 and it looks better, now my phone still disconnects at times but quickly reconnects so it at least looks like things are on the right track, it is usable for the most part now.
I've now unchecked "Disassociate on low acknowledgement", to see if that helps.

Before, I was getting AP-STA-DISCONNECTED, disassociated and deauthenticated in the log and that was it, no automatic reconnect.
Now after these 3 lines I get within seconds the next lines: authenticated, associated (aid 2) and AP-STA-CONNECTED.

Other than that, when it comes to network spikes, I am having a similar experience to stock. I am using a VR headset that's connected to Wifi and just like on stock, I get a network spike for a split second every few seconds which means a rather unpleasant frame flashes on the screen when that happens but while things aren't better than on stock, they aren't worse either, I don't know if there could be an external factor.

I'll keep testing and hopefully it will be decently stable, maybe then 22.03.4 will be bug free when it lands and I'll be able to flash Openwrt up to date without issues, without my phone disconnecting at all.
Best regards to the developers!

Just like with the release candidates, I continue to be having a problem not connecting to the internet through Openwrt in my Meta Quest 2 headset (which is running Android 10 basically on Snapdragon XR2) with one of the apps. The app is Deo VR, other apps such as Youtube VR still run just fine. This is one of the reasons why I reverted to stock in the summer as I need wifi connectivity to that app. I am on Openwrt 22.03.2 but I'm not sure that anything has been fixed about this in 22.03.3 and I wouldn't want to be having the problems that you are having with the new firmware.
This is something that has to do with the wifi connection of Openwrt because if I plug in another router into an ethernet port of the C6 (with Openwrt), I am able to connect to the internet in that app, on wifi to that second router.

Try using it non-stop for days and you should run into this bug.

Tested on 22.03.0, 22.03.2 and 22.03.3.

Hi gents, do we have a stable version for this router ?

i have two units, i need to install in a place i dont have external acess later, maybe its better to go back to stock ? :frowning:

I'm on 22.03.2 and I haven't noticed any reboots in more than a week since flashing it, I only have the small specific issues mentioned above. (though Deo VR not having Internet on this router on OpenWrt over wifi on either 2.4GHz or 5 GHz is a significant issue for me)

The issue seems to be related to wifi load, and there’s a memory usage spike just beforehand. Restarting the wifi at that point seems to fix it, but if left too long the device goes into a reboot loop requiring a hard restart by removing power.

It may be possible to script something that watches the memory use and restarts the wifi if the issue is starting.

Have been using the 22.03.0 r1 version for 6 months now (didn't upgrade as don't upgrade if not broken thinkin) and never faced reboots until now. Had some people over and 10+ devices connecting over Wifi simultaneously and guess what it; gets into a bootloop like you mentioned above. Rebooted the router; however, the issue pops up again. Will check for comments here regarding a solution.

As I need the Deo VR app to work over wifi with my VR headset and I have to plug in my previous router (TP-Link WR841N) into the C6 for that but didn't want to use the stock firmware on that either, I've flashed DD-Wrt on it. Even though OpenWrt is available for that router, which also stopped being updated for it since 2020, I thought I shouldn't risk compatibility again between Deo VR and OpenWrt.
I wasn't sure if something other than the stock firmware would work with Deo VR but DD-Wrt on the WR841N does work with it. Hopefully the problem will be solved in OpenWrt so that I can stop using the old 2.4GHz router and use the C6 over 5 GHz.

Wi-Fi Clients Intel AX201 and Edimax EW-7811utc (Realtek 8812AU) - breaks 5Hz.
There is no ping, but you can connect/disconnect as much as you want.

C6 v3.20 22.03.3 After a few days only the power LED is on, no internet. After turning it off, everything works for a few days. 22.03.3 very unstable software. I installed the original TP-LINK for the client. Customer reports no problems for 2 weeks.