OpenWrt failed to configuring FTTH VLAN based PPPoE


My china provider requires that the traffic over the WAN interface is tagged with id 3961, and the rest can be untagged (I don´t have other services like IPTV or VoIp). Anyone could explain how i must configure ?

                     -----------------------
                     |    Netgear Switch   |
                     +---------------------+
                     ^       vlan 3961     ^
                   Port 1               Port 10
                     ^                     ^
                     |                     |
                  OpenWrt(WAN)       FTTH(EPON SFP stick)

openwrt network config

config device
	option type '8021q'
	option ifname 'eth1'
	option vid '3961'
	option name 'epon-ftth'

config interface 'wan'
	option ifname 'epon-ftth'
	option proto 'pppoe'


PPPoE log

[  842.244445] pppoe-wan: renamed from ppp0
[  844.269445] br-lan: port 1(eth0) entered disabled state
[  844.539496] device eth0 left promiscuous mode
[  844.541043] br-lan: port 1(eth0) entered disabled state
[  846.286104] ixgbevf 0000:00:06.0: NIC Link is Up 1 Gbps
[  846.287668] 8021q: adding VLAN 0 to HW filter on device eth0
[  846.288766] br-lan: port 1(eth0) entered blocking state
[  846.288768] br-lan: port 1(eth0) entered disabled state
[  846.290358] device eth0 entered promiscuous mode
[  846.292668] br-lan: port 1(eth0) entered blocking state
[  846.292669] br-lan: port 1(eth0) entered forwarding state
[  846.308114] 8021q: adding VLAN 0 to HW filter on device eth1
[  846.308126] ixgbevf 0000:00:0a.0: NIC Link is Up 1 Gbps

Update:

port 1 and 10 tagged Now its working.....

config interface 'wan'
	option ifname 'eth1.3961'
	option proto 'pppoe'

and you probably want to make port 10 tagged too.

1 Like

Both tagged.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.