OpenWrt EAP225-outdoor v3 "firmware is incompatible"

Hi folks,

Sorry if this topic is not at the correct forum.

Recently purchased a TP-Link EAP225-Outdoor version, which came with version 3 of the hardware. Reading some post of this forum more or less i understood that before installing i have to run via ssh a command "cliclientd stopcs" which answers me "Success.". But when i go and try to update the firmware with versions found on wiki page it says "upgrade failed because the firmware is incompatible. Please check the firmware file". I tried with firmware versions 5.0.7 (which came out of the box) and 5.0.6. And openwrt versions "openwrt-21.02.0-ath79-generic-tplink_eap225-v3-squashfs-factory" and "openwrt-21.02.3-ath79-generic-tplink_eap225-v3-squashfs-factory", same result.

Here are the questions: ¿is this AP really openwrt supported? ¿which firmware version? ¿am i updating the wrong way?

Thanks in advance.

Only v1 of the outdoor is officially supported.


Only hw version 1.

EAP225 ceiling mount v3 is supported.

May actual firmware be compiled to adapt to this version?

Do you know what chip set is in the Outdoor V3? If it is the same chips and memory sizes as one of the other model versions, it might run builds for that version. And it could just be a matter of modifying the header of the "factory" file so the V3 stock firmware will accept it.

The thing is that I would be little more hopeful if they actually had the same physical form and size.

The ceiling version is a TP-link standard square wave box, and on the eap245 the PCB is pretty much the same size as the box.
But the 225 outdoor is a small diameter tube!?

So we know for a fact the hardware have really heavy differences in design, the question is what differences.

Well i could not open it yet, but i have saved kernel-log and mtd-partitions.

Here are a few lines from dmesg:

[    0.000000] CPU revision is: 00019750 (MIPS 74Kc)
[    0.000000] SoC: Qualcomm Atheros QCA956X rev 0
[    0.000000] Clocks: CPU:775.000MHz, DDR:650.000MHz, AHB:258.333MHz, Ref:25.000MHz
[    0.000000] Memory: 126596k/131072k available (2034k kernel code, 4476k reserved, 500k data, 180k init, 0k highmem)
[    0.000000] SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.070000] gpiochip_add: registered GPIOs 0 to 22 on device: ath79
[    0.080000] MIPS: machine is Qualcomm Atheros AP152 reference board
[    0.980000] 9 cmdlinepart partitions found on MTD device spi0.0
[    0.990000] Creating 9 MTD partitions on "spi0.0":
[    0.990000] 0x000000000000-0x000000020000 : "u-boot"
[    1.000000] 0x000000020000-0x000000030000 : "pation-table"
[    1.010000] 0x000000030000-0x000000040000 : "product-info"
[    1.010000] 0x000000040000-0x0000001c0000 : "kernel"
[    1.020000] 0x0000001c0000-0x000000f00000 : "rootfs"
[    1.030000] mtd: partition "rootfs" set to be root filesystem
[    1.030000] 0x000000f00000-0x000000f30000 : "config"
[    1.040000] 0x000000f30000-0x000000fb0000 : "mutil-log"
[    1.050000] 0x000000fb0000-0x000000ff0000 : "oops"
[    1.050000] 0x000000ff0000-0x000001000000 : "ART"
[    1.060000] ag71xx_mdio: probed
[    1.070000] eth0: Atheros AG71xx at 0xb9000000, irq 4
[    1.620000] ag71xx ag71xx.0: eth0: connected to PHY at ag71xx-mdio.0:06 [uid=001cc916, driver=RealTek 8211FS-CG PHY]
[    9.230000] ART Version : -48.0.0
[    9.230000] SW Image Version : -
[    9.230000] Board Revision :  
[    9.240000] ar9300_eeprom_attach: ======= ov_write_ctl:0 ========
[    9.240000] ar9300_attach: nf_2_nom -110 nf_2_max -60 nf_2_min -125 
[    9.350000] wifi0: Atheros 956X: mem=0xb8100000, irq=47

Hope it helps.

Support for v3 hardware is being prepared:

Discussion can be found here: