OpenWrt don’t allow android's samba server /w unusual ports while stock firmware allow


  1. I always ping-ed the IP to confirm they can meet, also I always FTP into the phone
    to make sure the connection is working. What strange is PC to PC using normal ports
    are OK, with openwrt or TPlink stock. But the modified samba app and the modified ports on windows only work on TPlink stock and not TWO openwrt devices.

  2. summary: the routers I only use them as router, it's the phone's app "landrive" act as
    samba server, but using the 3 unusual ports as it's un-rooted.
    The PC were the CIFS servers and the clients, as PC-A and PC-B can access each other's CIFS share.


The pc and Android device are in the same subnet right? I.e. they both have a 192.168.1.x address?

I got this already. I want to know how your phone is accessing the share. Over plain IP or hostname? E. g. smb://192.168.x.x or smb://mypc
Did you try another SMB application on your phone. E. g. TotalCommander with SMB plugin?

for GL inet's brumeW, router is, PC could be (58 is I chose,
as my laptop is T580 lenovo),
phone is (231 is by default)

for TP link that will be 192.168.0.*
for self flashed openwrt Dlink it will be 192.168.1.*, as above.

for ALL combinations,
PC-A can ping others, FTP into others, got into another PC-B's CIFS (using normal port), it's just when android samba server app is used, due to un-root, the
samba server's port is different, and the PC, as a client, need install freeware multi
port forwarder and use the above 3 unusual ports.

btw, PC-A, even with the multi port forwarder ON,
can still reach PC-B's CIFS share, using normal ports.



  1. the android samba server app shows itself using IP,
    and indeep the PC-A can reach it either by IP or by hostname (xiaomi in my case).

  2. my xiaomi is un-rooted, so LAN drive is the only samba SERVER app I knew of.


LANdrive is the only android app I know that act as samba SERVER while you dont need the phone rooted i.e. it works UNROOTED.

provided every ping is working, every FTP into is working,
also every win10 to win10 CIFS normal port is working, (in all 3 router of stock TPlink,
openwrt brumeW, openwrt dlink 842)

and the landrive working in TPlink and NOT working with openwrt (two different openwrt).

I simply can conclude it's the openwrt somehow prevented the landrive from working.

I could further do a regular testing later when free.


I've just installed LAN drive onto my phone and installed multi port forwarder on my pc. It works without any issues or needing to make any changes on my router.

I would double check the IP address assigned to the phone when you use a different router and ensure that any change has been updated in the multi port forwarder rules.


wow is it!?

using the phone as samba SERVER?!

let me try again and let me close all win/android firewall then!

thanks first.

Yep, literally just installed the app off the play store and added the rules in multi port forwarder as described in their tutorial. Then just used my phone's IP address in explorer (i.e. \\192.168.1.x\) to connect and browse the local storage.

1 Like


mind to try copy/move some files into the phone's share? becoz i could enter but it say "this folder is empty" but indeep it is not connected. thanks

I can only do limited testing as I don't have the full version and the trial is very speed limited, but I can open files stored on the phone from my pc so it's definitely connected.


ok, thank you.

i will check on my side, thanks

It's all MY faults, I apologize for this.
LanDrive WORKS perfectly with openwrt.

In Verigio, in the TCP tab, there is a hard code-ed IP address,
And after trial period, you can still USE it but you cannot CHANGE it.

So I setup my Tplink within the trial period, thus working well.
With the recently bought openwrt I forget/don’t remember there is a hard code-ed
IP address, so of course openwrt 's IP will never work with that.

Very much Thank you esp to Krazeh who helped by installing the app and software for me.
Thank you everybody.

(PS seems that one have to buy the ultimate version of
Verigio for working with LanDrive, which is 20USD….)

The tutorial of landrive is here:


The limitation of trial version of verigio is here:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

title cant be changed,
but as ur post say in #5,
i added the solution tag.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.