OpenWrt DNS redirect/hijack not working

Hi guys,

First i would like to mention i have 1 pihole connected to my OpenWrt router and everything is working great, pihole is doing its thing.

Now i want to redirect/hijack all DNS queries to pihole, and i follow this link: ( but it just didn't work. I have forwarded port 53, 853, 8053 and 5353... none worked.

I would like to mention that i have tried setting my phone (connected to the same OpenWrt router) with a public DNS (, and i get "no network" alert... but immediately got network again after using my pihole DNS agaib. However, when "no network" was showing, i could not access any websites at all, except WhatsApp and Telegram (both works)!
I even tried to put () as regex blacklist in pihole, and everything was blocked.... except WhatsApp and Telegram! Now how can i tell these apps to use my pihole? Are there any settings i need to? Searching the web i found lots of iptable configurations, but the new OpenWrt don't support that anymore (or i have no idea how to).
I also found this page ( but i have no idea which files to type those comments in... clearly the "Web Interface Instructions" did not work cause the guide above used that method...

Please help me as i bought an OpenWrt router specifically for blocking WhatsApp cause pihole alone was not enough.

Not sure if it will make a difference
Unlike the Jeff Keller tutorial at your link,
OpenWrt tutorial instructs
Destination zone: unspecified

1 Like

@Warlock no it does not make a difference. I have already tried that.

I have found this document ( saying that Telegram uses Google's DoH. So in this case may i know if i wanted to follow the OpenWrt guide, where do i save the configuration file, and what should i call the file?

Thank you!