OpenWrt device bottlenecking internet connection speeds

Ahoy ahoy friends.
Last week i have recevied my 1Gbit connection upgrade using a docsis 3.0 internet connection. I got my ISP router (Fritz! 6591), and my OpenWrt device behind it.
When i get a direct connection to my Fritz! 6591 ISP router and run a speedtest, i get more or less 1001mbps download, and 57mbps upload. Behind the OpenWrt device only 560mbps download and full 57mbps upload. I have used a Raspberry Pi 4 before, and now upgraded to a x86 Xeon device for OpenWrt but the performance stays the same, still only 560mbps download rate. What might be the issue here in this case? The ISP router provides the full bandwidth, but somehow the OpenWrt device is bottlenecking here. I have monitored the system load using htop and there is nothing exceptional. I hope someone could help in my case. I got a second internet connection (DSL) configured in mwan3, but only for backup, not for load balancing. Thanks in advance!

/etc/init.d/sqm stop

Thanks a lot. I have tried that already, it fixed my upload from 37mbps to 57mbps now, but the download rate not.

that is not the test... it's a sane prerequisite...

Thanks a lot. That's the speedtest result.

     Server: Händle & Korte GmbH - Dusseldorf (id = 28624)
        ISP: Vodafone Germany Cable
    Latency:     4.49 ms   (2.82 ms jitter)
   Download:   474.71 Mbps (data used: 641.0 MB)                               
     Upload:    51.27 Mbps (data used: 23.2 MB)                               
Packet Loss:     0.0%

1 Like

ok now test with a notebook / pc... (i'm calling provider on this tho')

apologies... i see you stated you already have...

please state a little more about how you did this test...

the only other thing I see interfering is mwan/etc. or arbitrary MTU or something... (it's very unusual for rpi + x64 to be choked to the same rate)

did you forget to explain / include some network config information?

Oh, i have re-run the test on my notebook, which was directly connected to the ISP router.

chairman@kali:/tmp$ ./speedtest

   Speedtest by Ookla

     Server: Händle & Korte GmbH - Dusseldorf (id = 28624)
        ISP: Vodafone Germany Cable
    Latency:     7.68 ms   (2.97 ms jitter)
   Download:   917.58 Mbps (data used: 1.2 GB)                               
     Upload:    51.03 Mbps (data used: 24.9 MB)                               
Packet Loss:     0.0%
 Result URL:

On both cases i got a ROAS setup, so only one LAN interface and routing between vlans (Maybe there is a Duplex issue?). I will check the MTU thingy and maybe disable mwan3, or try a dedicated lan interface for the wan facing edge.

1 Like

That's probably the issue. Use a separate physical interface for LAN and WAN.


Thanks, i think this might be the issue. I am also facing this issue during LAN transfers, so not limited to the WAN edge.
I am building up a new setup, using a 4 Port Intel i340 NIC. I'd like to deploy a ROAS setup as well, but using a 4-Port LACP Etherchannel instead. Do you think this is a good idea, or are seperate interfaces still superior?

Hmm now it's really really bad.
Got a new x86 device and a LAG using 4 interfaces with LACP connected to my core switch. iperf3 performance is great, but the speedtest now really sucks hmm.
Is there maybe an issue with mwan3? And how can i disable mwan3 for testing purposes?

Traffic between all subnets and interfaces is flowing with Gigabit speed now. Except the WAN ones.

Do you accept the license? [type YES to accept]: YES
License acceptance recorded. Continuing.

   Speedtest by Ookla

     Server: Händle & Korte GmbH - Dusseldorf (id = 28624)
        ISP: Vodafone Germany Cable
    Latency:     7.86 ms   (2.23 ms jitter)
   Download:   265.95 Mbps (data used: 392.9 MB)                               
     Upload:    36.39 Mbps (data used: 16.4 MB)                               
Packet Loss:     0.0%
 Result URL:

something just doesn't add up with what you've shown so far...

all the symptoms are indicating issues with some unknown software config ( you should run bare stock to exclude nothing else ) or something between the wan port and ntd ( you've tested other devices... so we are left with something we don't know about or the ntd itself )...

lag is internal?(not really relevant) either way it's only adding complexity to something that needs to be isolated...

( yes I understand there were possible router-on-a-stick constraints... but the first test we did was wan-out... i.e. nolan involved and it still bottlenecked )

From sales pictures, I am assuming i340 is a 4 port 1 gb switch with VLAN and a CPU port on a PCI Express card.

That means, you would get full gigabit from LAN to LAN, as the embedded switch transfers data directly on chip of the i340.

From LAN to WAN, data has to flow through the NIC chips CPU port to PCI express to the x86 CPU, there routing and firewall magic happens and then further to the designated WAN port.

Is one of the i340s ports used as WAN port? or is there another dedicated separate NIC in the PC that you are using as WAN port?

Thanks a lot. It is not configured as a switch, just simple nic with Software-VLAN.
I tried a dedicated network interface as well for WAN, my eth4 interface, but there is no difference in performance, so i moved it back to the bond again.
I got a Ryzen 3000G CPU and 4GB of DDR4 memory. CPU usage is max. 15 percent and memory usage 200mb.

I tried to visualize my network a little further.
When i connect to the ISP router, using VLAN 2100 in my network, doesn't matter where, i get the full bandwitdh.
When i connect to my network through the OpenWrt device, doesn't matter where, i get only 400mbps.
Everything else where WAN is not involved, works with 1gbit now (before it didn't).
Something interesting: When i got a second device connected to my ISP router, let's say my laptop, in (ISP Router is, and when i run iperf3 from router to this device the bandwidth is even worse.

I have tried with mwan3 disabled, no difference.

root@OpenWrt:~# iperf3 -c
Connecting to host, port 5201
[  5] local port 37648 connected to port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  4.79 MBytes  40.2 Mbits/sec    0   58.0 KBytes       
[  5]   1.00-2.00   sec  4.60 MBytes  38.6 Mbits/sec    0   58.0 KBytes       
[  5]   2.00-3.00   sec  4.47 MBytes  37.5 Mbits/sec    0   58.0 KBytes       
[  5]   3.00-4.00   sec  4.47 MBytes  37.5 Mbits/sec    0   58.0 KBytes       
[  5]   4.00-5.00   sec  4.60 MBytes  38.6 Mbits/sec    0   58.0 KBytes       
[  5]   5.00-6.00   sec  4.47 MBytes  37.5 Mbits/sec    0   58.0 KBytes       
[  5]   6.00-7.00   sec  4.60 MBytes  38.6 Mbits/sec    0   58.0 KBytes       
[  5]   7.00-8.00   sec  4.47 MBytes  37.5 Mbits/sec    0   65.0 KBytes       
[  5]   8.00-9.00   sec  4.66 MBytes  39.1 Mbits/sec    9   56.6 KBytes       
[  5]   9.00-10.00  sec  4.47 MBytes  37.5 Mbits/sec    0   60.8 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  45.6 MBytes  38.3 Mbits/sec    9             sender
[  5]   0.00-10.00  sec  45.3 MBytes  38.0 Mbits/sec                  receiver

Hey friends, i am really really sorry, i didn't recognize it. I had SQM QoS installed as well as QoS. After disabling LuCi QoS it now works...

Thanks a lot for all your help!! Thanks for bearing with me
From OpenWrt device to, my iperf3 laptop, i also got full gbit bandwitdh now.

How did you have the SQM configured? I'd guess that the RPi4 could run SQM at that rate with no problem. Say, try setting it to 800 and 48mbits, and see how it goes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.