OpenWrt cuts the speed when I insert USB 3.0

Hi guys. I have a problem. Let me describe it. There are 2 routers. The main (1) into which the provider cable goes and the secondary (2). On the first is TP link installed, on the second is OpenWrt 19.07.

I connected the second router to the first one through the air (repeater) at a frequency of 2.4 GHz. I configured the second one and everything was ok. The speed was on the top level.

I inserted the USB flash drive (Transcend 3.0) into the second router and then the real hell began. Either the speed drops completely on the second router or the Internet is completely disappear and I can’t even connect to the second rounter. Sometimes I need to reboot my PC and the router to login into Even if I put the USB flash, using just default Openwrt (no usb modules that support ext4, the router just cuts the speed, cuts to 1mb upload 1 mb download. That’s really sad!

What I did with the first router to decide this problem:

  1. I changed 20 mhz to 40 and set it up

  2. Changed the channel (from 1 to 6, then to 11)

  3. Completely reset to factory settings and set up from scratch

  4. Tried another power supply

What did with the second router:

  1. Change, channels, mhz

  2. Removed kmod-usb3 and set kmod-usb2

  3. Tried various guides on repeaters and bridges

  4. Changed the patch cord (cable between the router and the PC)

  5. Tried another power supply

  6. Jumped from 07.19 to 06.19.6

Towards evening I got another router, started it as the main one and set it up. I connected with a second router, inserted a USB flash drive (I recall that it is 3.0, a USB 2.0 flash drive also cuts speed, but exactly 2 times, and not tens like a 3.0 flash drive) and ... it's okay, if the speed drops then it is within the margin of error, ping is good , everything flies, I could enters the router, no problems at all. What is the reason? Is OpenWrt incompatible with my first router? What to do? Who to contact? What could be the reason, and did anyone have the same?

I would also like to take this opportunity to ask what kind of utility adds the ability to lower the usb port on the router from 3.0 to 2.0 in the OpenWrt firmware?


P.S. When I used Padavan on the second router everything was really smooth with the speed, not cutting using USB flash drive. Xiaomi mi router 3G is my device.

Does the issue with the speed happen with both 2.4 GHz band and 5 GHz or just one of them?

As for forcing the port to work as USB 3, you could try a USB 2 extention cable if convenient. That way you keep USB 3 support in case you need it.

Yes. the issue only with 2.4 ghz band. 5ghz works nice.

Then its likely just USB3 to 2.4GHz wifi interference. They run at the same frequency and interfere with each other, and manufacturers are not putting in sufficient shielding.

1 Like

Then if the 5 GHz band works with all your devices you can just use it instead. You could probably use N instead of AC for better range.

But, when I asked my friend to get his router to test, his router works fine as a main router which I connected from the second one. So it's not 2.4ghz 3.0 problem.

Unfortunately most of my devices works only on 2.4 Ghz.

Could you elaborate a bit more? You connected his router as main router, your router as downstream router using a cable, you corrected a USB 3.0 device to your router and got good 2.4 GHz speed from your router?

Yes I can. I got a router from my friend which is a neighbor of me.
I set his router up, put the provider cable and them just connected to it from my second router that I had problems with. Thru the air (repeater). And both routers works fine. But when the main router is my TP link, then I have problems with my second router which is Xiaomi 3G. As I said when I put 3.0 or even 2.0 flash card or hdd, then the speed is being cut, down to 1mb/s. So bad really. I don't have the same problem when I used my friend's router as a main router, only when I use as a main my tp link. So I guessed the problem is in OpenWrt side (because when my second router was on Padavan firmware then everything was ok) or just my router (repeater) when it's on OpenWrt firmware just not compatible with the main TP link router :confused:

Ok it might be a driver problem if you say it was working with stock firmware.

Though I am totally lost with how the setup is when you're friend's router is involved. If you could make a diagram or otherwise answer these bullets one by one:

  • Main router is your friend's router, connected to ISP modem? What are the make, model and firmware?
  • your router is connected by cable to your friend's router? What are the make, model and firmware? LAN to LAN or LAN to WAN?
  • PC connected to your router's 2.4 GHz WiFi?
  • USB connected to your router's USB port?