OpenWrt Chaos Calmer 15.05.1- No Valid Architectures (Technicolor)

Hi all, freshly minted noob here, please forgive me.

I'm running a rooted Technicolor TG799vac, using terminal in OSX to administer. Below are my specs as reported via ssh

DISTRIB_DESCRIPTION='OpenWrt Chaos Calmer 15.05.1'
DISTRIB_TAINTS='no-all busybox'

My problem is that whatever I try I cannot install via opkg

At first I just thought I was making noobie syntax/protocol type errors and that I could muddle through and although I'm sure I am doing that stuff, there's a problem here too.

opkg update reports no valid architecture from every repo and although one step might be to modify opkg.conf I am both having issues using vi and I'm also skeptical that it's going to solve the problem.

Can anyone tell me what might be causing this (rather than speculate how to solve it)? Seems to me there must be some really obvious FUBAR I just can't see as it's too close to me face.


It seems they have been archived

Thanks for your reply.

I’ve tried several repos (some I know are live) and am also unable to intall from a local repository. I guess I was hoping there might either be an idiot’s guide or some kind of logical explanation that could show me what I’m missing.

Archived repo’s a good stab but I’m aware of that issue for starters.

Thanks for your time.

Likely reason is that it is not a real Openwrt build, but a private build from their own repo where they have added new target and subtargets suited for their devices. (To my knowledge there has never been brcm63xx-tch here, so the subtarbet brcm63xx-tch/VANTF is even more exotic.)

Earlier discussion about Techniocolor devices can be easily found with forum search. That is probably your FUBAR if there is any :wink:


Some key results

@0jay Please see (the paragraph named "installing other packages" might be of interest to you).
That webpage applies to the TG789vac, but as far as I know the TG799vac is the same board, just with DECT support added.

1 Like

Thanks to everybody who replied, this is fair out of my depth but I’ll work through it as best I can.

Thanks again.

Actually, the link provided by @Zen96 offers quite simple straightforward advice that might work for you:

Installing other packages

The platform is marked 'brcm63xx-tch' rather than 'bcrm63xx'. To install other packages, edit /etc/opkg.conf and add the following:

 arch all 1
 arch noarch 1
 arch brcm63xx 3
 arch brcm63xx-tch 10

That might teach opkg to accept the normal brcm63xx packages (assuming that the opkg links lead into the normal Openwrt 15.05.1 packages download repo.)

cat /etc/opkg.conf
delivers the following

dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
arch brcm63xx-tch 200
arch brcm63xx 300

I still get the no valid architecture error

your build is based on a private build likely based on 15.05 branch after 15.05.1
Then there might be also /etc/opkg/distfeeds.conf

Like this:

root@OpenWrt:~# cat /etc/opkg/distfeeds.conf
src/gz openwrt_core
src/gz openwrt_base

The paths should now likely point to subdirectories found in


But to be honest, your firmware is based on ancient 15.05.1, so nobody active here really remembers how things exactly looked before LEDE forking and 17.01 and re-merging and 18.06 and formal EOLing of 15.05 branch...

Thanks for your time.

Sorry, a bit off topic. I have a couple of those TG789vac v2. Since this is ISP provided free modem, you can find them at a low or free price at gumtree. I followed this link and install LUCI successfully on it at port 81. I played a while, it seems LUCI works without any issue. Does it mean this modem could install openwrt?

I am a newbie for openwrt. May I ask why this blog used an old version LUCI? Can I install the latest version LUCI?

technicolor-tg789vac-v2 has 400MHZ cpu, 256M ram and 128M flash. It should fit for latest version openwrt for hardware perspective.

Please open a new topic for the TG789vac v2.

1 Like

Sorry for that. Moved to Technicolor TG789MYRvac v2 HP install openwrt?. Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.