Openwrt build is failing


I am trying to compile openwrt 19.x with ntpd and ntp-utils. All goes fine but in the end it gives the error that ntp-utils install failed due to missing '' library. although i have selected 'libintl' and libintl-full' from the make menuconfig.

Can anyone suggest, please?


The check is more on the ntpd/Makefile that the resulting binaries depends on but DEPENDS in that file does not specify it explicitly.

One way to fix the issue is to make the result binaries not depend on Usually this can be done by adding --disable-nls to CONFIGURE_ARGS

Another way is to include and add ICONV_DEPENDS explicitly as a dependency. You can find examples for this by searching ICONV_DEPENDS in the codebase.

1 Like
install -m0755 /home/user/jdixit/v2050_new/cygwp_t2081-V20.50-src/openwrt_V20.50/build_dir/target-powerpc64_e6500_glibc/ntp-4.2.8p15/util/ntptime /home/user/jdixit/v2050_new/cygwp_t2081-V20.50-src/openwrt_V20.50/build_dir/target-powerpc64_e6500_glibc/ntp-4.2.8p15/ipkg-powerpc64_e6500/ntp-utils/usr/sbin/
find /home/user/jdixit/v2050_new/cygwp_t2081-V20.50-src/openwrt_V20.50/build_dir/target-powerpc64_e6500_glibc/ntp-4.2.8p15/ipkg-powerpc64_e6500/ntp-utils -name 'CVS' -o -name '.svn' -o -name '.#*' -o -name '*~'| xargs -r rm -rf
Package ntp-utils is missing dependencies for the following libraries:
Makefile:158: recipe for target '/home/user/jdixit/v2050_new/cygwp_t2081-V20.50-src/openwrt_V20.50/bin/packages/powerpc64_e6500/packages/ntp-utils_4.2.8p15-1_powerpc64_e6500.ipk' failed

This is the Error that i am getting. I tried by editing the configure args as you said still getting the same error.
added the


The 2nd method is also worth a try. Otherwise consider opening an issue at

1 Like