OpenWrt Build Error : Cannot satisfy the following dependencies for asterisk : jansson

Hi, I am building the asterisk with OpenWrt. I am facing this error at the end. I checked jansson, it’s installed in the system. Please help me resolve this.!

Do you have jansson set to Y in your build config?

1 Like

Can you be more specific?. Like which file exactly? path of it?

Can you please post your .config file (it should be in /home/user/lede_projects/ in your case)?

.config file is 5000 lines+ , i cannot post it all.

I did search whole file for keyword "jansson". could not find anything.

You can upload it to Pastebin, GitHub gist, etc., and then post the link here.

Did you switch to another branch in buildroot? Did you notice any message like WARNING: No feed for package 'jansson' found?

Yes. I switched to "Minibox-v3-16m" branch.

Oh, this may be the reason. Perhaps you can try this suggestion?

If you switch branches in the same buildroot, you need to clear the semi-hidden package data in tmp directory. (several .dot starting files there). delete the whole tmp from the buildroot, in addition to the normal make clean.

1 Like

Okay. Thank you so much. I will try it and let you know.

OpenWrt should house the libraries internal to the build system, not on your host machine..

In your .config, check for the following line:

# CONFIG_PACKAGE_jansson is not set

If you need it, you should set it in your config.

I did not find this "# CONFIG_PACKAGE_jansson is not set" in .config file. How to enable it? How did you get this menu(screenshot)?

make menuconfig brings up the build menu system. Are you building from source? If you are using something like the image builder, someone else will have to step in as I have never used it. I build all my images and packages from the main branch.

In menuconfig, it'll be under libs.

If you're talking about that specific screenshot, in menuconfig, hit / to search and type jansson

1 Like

I tried building after deleting the tmp directory. But this is creating different errors.

1 Like

I searched "jansson" in the menuconfig, and added it to build and compiled it. I am getting an error. Please look into these screenshots.

You still are not actually turning on the jansson library.

1 Like

I tried searching under "LIbrary", but I could not find it. Any idea why its not available under Library. I am not in the main branch. I am compiling it for "Minibox-V3" , so I changed to "Minibox-v3-16m" branch.