OpenWRT build does not boot on PC Engines Alix 2d3 board

Hello everyone,

So I have successfully built an image of OpenWRT with a small application running OpenC2X protocol, it can be found here:

The target board is PC Engines Alix 2d3.
Then I put the image on a CF card that connects to the board, but the booting process is unsuccessful.
I first get the screen where I can select LEDE or LEDE-failsafe, and after the choice is made, I simply have an empty terminal where nothing happens.
For getting the image on the CF card I followed the instructions here (section Flashing by CompactFlash):
and I also executed the sync command after running dd.
I am connected to the board with a serial cable and I run
sudo picocom -b 115200 /dev/ttyUSB2
to communicate with the board.
I have tried all the image files that I get after building the packages (there is for instance an ext4 and squashfs build available and so on, but with the same result). However, when I run a "minimal" OpenWRT build (ext2), then the system boots. Another thing I have tried is to run other available (pre-built) OpenWRT, as well as LEDE images from here (x86-64 versions):
What I noticed is that they are all ext4 (or squashfs), but there are no ext2 options - could that be the reason (because that one ext2 image of OpenWRT did boot)?
Also, is there maybe at least some kind of verbose mode with this that would show some useful output to help with finding the problem?
Thank you.

I have exactly the same problem. Did you find a solution?
Thank you