OpenWrt assistance

Hi all

I have an asus router, which have DHCP range of
A lan cable is going out to the openWRT mi router 4a gigabyte, to it's WAN port.

The desired state would be

  1. LAN needs to be working ( between the MI router and other devices)
  2. Both 2.4 &5 Ghz wireless network should work as well and give to customers other ip range ( not like the asus).

Can anybody help please? I tried so many things and Im starting to think that something is broken with my firmware

define this

1 Like

I want to have internet on a PC that is connected wired to the MI router

if there's no other requirement

but there is, in addition to this lan connection, i want to have two wireless networks (2.4 & 5 Ghz)

configure and enable them ?

this is a long, but probably relevant thread Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

thanks, I've managed to make it work. Now the asus ( main router) is giving addresses between - and all is working fine. BUT - the asus is getting for some reason 169.254 (only on lan connected devices) and it won't get fixed until I unplugged ethernet cable that connects the MI router and the Asus.

Does it have any solution?

To set up a dumb AP, disable its DHCP server and bridge all the Ethernet ports and wifi APs into one network, the LAN.

Having two active DHCP servers on the same network will not work.

169.254 results when Windows does not receive DHCP. Probably because you don't have all the ports bridged back to the main router.

1 Like

I know. everything is configured ccorrectly, dhcp is disabled on the mi router.
Theres something else....

That's the manual I followed:

I must say, it worked for couple of minuets, and than all of a sudden the asus start getting 169.254. It wasn't resolved until I unplugged the lan that goes to the MI router

I found that even when I'm disconnecting the mi router it's still happens
This can be closed. To
Thanks everybody

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.