Openwrt as dumb ap, streaming issue


I have a Linksys wrt32x which I installed openwrt on.
I configured it as dumb AP as explained on this webpage:

I enabled two wifi radio's (2.4 & 5 GHz) with same name and password as my main router upstairs.

All my devices work great except of my streamer. Before the router I had a switch which had everything working correctly. But now that the router is in place I can't stream any music above 96khz Quality. The library is hosted on the NAS connected to the main router upstairs. Watching 4k content on my pc downstairs from that same NAS works perfectly.

As Stated on the bottom of the Page I linked it seemed like I had to activate Multicast forwarding. I think I managed to enter that command line but I'm a Total noob with the SSH.

The streaming device is an auralic aries music streamer. Primary router is a modem+router provided by my internet provider.

Hi, how is your WRT32X connected back to your main router?

Going from the modem/main router lan port to the wrt32x lan port.

Direct wired ethernet connection and not over an Ethernet-over-Power connection or similar?

That's right. Just direct wire

Well, the document says that you add that condemns to rc.local, not just enter it at SSH client.

If you are on Windows, you could use WinSCP to edit rc.local in place.

@Hegabo that's what I used in the end. Tried it with PuTTY first but that didn't work out for me... I used WinSCP and added the line in RC.local.

It says " Replace br-lan with your actual bridge interface, sometimes also called br0 ." Could it be that my bridge interface is something Else than those two? And if so, where can I find that?!

I'm not sure why that document is still there, do NOT enter those lines in rc.local. multicast snooping should work fine for you and turning it off will stuff up your wifi with multicast packets.

Multicast over wifi uses the slowest configured modulation. You should turn off legacy rates in the advanced config of your Luci page for the wifi SSID. This will make 6Mbps be the slowest rate and should help with airtime congestion.

1 Like

I don't know. If it's outdated, maybe you could fix it.

@dlakelan The streamer is also wired into the wrt32x. I tested before I entered the line into RC.local but no difference... I assume turning off the legacy rates won't help when they streamer is connected by wire?

I've made some edits to that text, I hope to make it better.

@Vitalbullet turning on igmp_snooping and off legacy rates will help as follows:

  1. turning on igmp_snooping will prevent packets from hitting the wifi in the first place (unless someone on wifi requests them)
  2. turning off legacy rates will cause multicast that is hitting wifi to at least go at a higher modulation rate, reducing the amount of airtime it takes up.

I'd add option igmp_snooping '1' to your /etc/config/network for the bridge (or click the box under physical settings on luci for the network interface) and also add option legacy_rates '0' to your /etc/config/wireless (or fiddle the checkbox in LuCI) and see if this helps you a lot. I imagine it will.

1 Like

@dlakelan I just got home. I'll test it out in a minute. I'll keep u updated.

sounds good. I imagine that having the low rates on wifi might limit the rate at which packets could be processed on the bridge even for wired. I'm not sure though. In theory wired might go straight through the hardware switch. If it doesn't work, I'd still leave those settings turned on as you debug the next wired part.

Where exactly should I add "option igmp_snooping '1'" & "option legacy_rates '0'"

option igmp_snooping '1' goes under
config interface 'lan'

option legacy_rates '0'

goes in /etc/config/wireless under each of the config wifi-device .... sections

1 Like

@dlakelan Applied those changes but still no luck with the streaming device :cry:

did you eliminate the stuff from rc.local?

But, yeah, if both devices are wired, I can see how this isn't the solution.

what is the symptom when you try to stream higher bitrate music?

I did eliminate the line in rc.local.

anything high bitrate plays in intervals (+/- 3 seconds). After about 7-8 passes the app that I use also displays a pop-up that says my connection is to slow for that file size.
Starting any song also takes longer than it did with the switch connected.

The streamer itself doesn't have a lot I can fiddle with either.

Trying to be clear in how it works. As I understand it the file is on a NAS run on your upstairs router, and then that's wired to your WRT32x which is then wired to a streaming device which consumes the packets via wired and plays the music locally (it's not forwarding the stream to your phone or some such thing right?)

Thats right, the app is just used as a controller.