OpenWRT and AdGuard DHCP Issue

Hello Geniuses,

I need your help once again to resolve an issue that I have been struggling with for the past week.

I have an OpenWRT on a mini PC, and it is connected to my ISP router.
I have an AdGuard DNS lxc container running on Proxmox on the same MiniPC.

Note: I am using MWAN3 on my OpenWRT setup

What I am trying to achieve here is to run DHCP entirely on the AdGuard Home, instead of OpenWRT. I configured Adguard for issue DHCP, but when I disable DHCP on the OpenWRT, my client devices can't see the DHCP server on AdGuard.

Things I have tried so far

  1. Disable DHCP on the LAN interface
  2. Configuring DHCP relay

None of them help me solve the issue.

Previously I ran AdGuard Home on my OpenWRT and it worked fine and issued DHCP as expected.

Can someone point me in the right direction, please? if OpenWRT isn't doing DHCP and if I have another DHCP server in the same network, I was expecting the devices to discover the DHCP server, but I think I have something wrong and need a way to get this up and running

Any directions would be appreciated