openWRT 23.x luks now working?

Since openWRT 20.x I have problems with luks. I get read/write errors when I use a luks encrypted stick oder HDD. openWRT 19.x works fine...
My question ist, anybody knows, that openWRT 23.x now working with luks?

nobody can help?

could you test-try the 23.5rc x86 image with enabled LUKS in a throwaway virtual machine on your regular PC?
This way you do not need to messup your main router, but still get a verified result within 2-3h.

Oh, thats a good idea ... I will try it ...

I did it :wink: 23.05.0-rc3 x86 image and luks works fine in libvirt/qemu ... there are no errors any more in r/w on virtrual discs ...
but there is no image for my 'AVM FRITZ!Box 7362 SL' on the firmware selector ...

rc version uses big ram

It looks like, that it works now, coz I havent any errors in the VM with luks. I will try it now on my real router ... I will build the image by myself.

nope, its not working on this device:

https://openwrt.org/toh/avm/avm_7362_sl

I am still getting rw/errors:

Upper than 19.x luks no more working with my router ...

After this release, luks never works for me on this machine ...

Iam wondering, why it dont works on my real hardware ...
Nobody can help?

Its still not working ...

Interesting! Ever got it working?

I'm on the same route (same hardware) and fail already unlocking LUKS: