OpenWrt 23.05: Unable to connect to the Wi-Fi network

Hello Folks,

I'm trying to connect my OpenWrt (23.05) based router to available networks wirelessly. But I'm facing issue while connecting. Below are the logs:

[  222.332583] 3g-cell: renamed from ppp0
[  222.594591] device wlan0-2 left promiscuous mode
[  222.599661] br-apspt: port 1(wlan0-2) entered disabled state
[  230.505129] 3g-cell: renamed from ppp0
[  232.771814] br-apspt: port 1(wlan0-2) entered blocking state
[  232.777886] br-apspt: port 1(wlan0-2) entered disabled state
[  232.784190] device wlan0-2 entered promiscuous mode
[  234.878341] br-apspt: port 1(wlan0-2) entered disabled state
[  234.886005] device wlan0-2 left promiscuous mode
[  234.890950] br-apspt: port 1(wlan0-2) entered disabled state
[  235.897882] wlan0: authenticate with 5e:1e:54:6e:03:7f
**[  235.903377] wlan0: 80 MHz not supported, disabling VHT**
[  235.922267] wlan0: send auth to 5e:1e:54:6e:03:7f (try 1/3)
[  235.933634] wlan0: authenticated
[  236.104614] wlan0: associate with 5e:1e:54:6e:03:7f (try 1/3)
[  236.124572] wlan0: RX AssocResp from 5e:1e:54:6e:03:7f (capab=0x411 status=0 aid=1)
[  236.132968] wlan0: associated
[  236.226244] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  236.490162] br-apspt: port 1(wlan0-2) entered blocking state
[  236.496141] br-apspt: port 1(wlan0-2) entered disabled state
[  236.502367] device wlan0-2 entered promiscuous mode
[  237.351581] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-2: link becomes ready
[  237.358649] br-apspt: port 1(wlan0-2) entered blocking state
[  237.364599] br-apspt: port 1(wlan0-2) entered forwarding state
[  237.503046] IPv6: ADDRCONF(NETDEV_CHANGE): br-apspt: link becomes ready
[  239.402108] 3g-cell: renamed from ppp0
[  247.034593] 3g-cell: renamed from ppp0
[  254.775303] 3g-cell: renamed from ppp0
[  262.610678] 3g-cell: renamed from ppp0
[  263.842543] device wlan0-2 left promiscuous mode
[  263.847567] br-apspt: port 1(wlan0-2) entered disabled state
[  264.750048] wlan0: deauthenticating from 5e:1e:54:6e:03:7f by local choice (Reason: 3=DEAUTH_LEAVING)
[  271.066963] 3g-cell: renamed from ppp0
[  273.341582] br-apspt: port 1(wlan0-2) entered blocking state
[  273.347537] br-apspt: port 1(wlan0-2) entered disabled state

It tries to authenticate, associate and then deauthenticates itself.

Is there any issue with the log "wlan0: 80 MHz not supported, disabling VHT"?

Let me know if anyone has any idea about this.

doesn't look like an issue with the log, but does show a possible cause of your issue ?

I have another router with OpenWrt 22.03, there is no issue while connecting with the Wi-Fi network and with the same logs except one log "wlan0: 80 MHz not supported, disabling VHT".

Hello folks,

I think one of the reasons of this issue is due to the iwconfig command not working with this build.

I have the script that executes when we connect the Wi-Fi network. In that script, there is command (iwconfig wlan0) to check whether the Wi-Fi is connected or not.

Below is the output of this command:

root@xyz-AABB:~# iwconfig wlan0
wlan0     no wireless extensions.

Can anyone tell what can be the issue? Does OpenWrt 23.05 release has some issue with this command and interface?

Regards,
Bobby

Using the device you haven't told us anything about?

Post the output of the ubus call system board command.

Let's see the complete config:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

@frollic @psherman - Below are the output of the requested files:

ubus call system board
{
        "kernel": "5.15.150",
        "hostname": "iobot-50EE",
        "system": "Qualcomm Atheros QCA9533 ver 2 rev 0",
        "model": "GL.iNet GL-XE300",
        "board_name": "glinet,gl-xe300",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ath79/nand",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option phy 'phy0'
        option htmode 'HT40'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'DSSS_CCK-40'
        option hwmode '11ng'
        option disabled '0'
        option noscan '1'
        option channel 'auto'

config wifi-iface 'sta_0'
        option device 'radio0'
        option ifname 'wlan0'
        option mode 'sta'
        option network 'wwan'
        option disabled '1'

config wifi-iface 'ah_0'
        option device 'radio0'
        option ifname 'wlan0-1'
        option network 'mesh_0'
        option bssid 'XX:XX:XX:XX:XX:XX'
        option ssid 'ssid'
        option encryption 'none'
        option mode 'adhoc'
        option hidden '1'
        option disabled '1'

config wifi-iface 'ap_0'
        option device 'radio0'
        option ifname 'wlan0-2'
        option network 'apspt'
        option mode 'ap'
        option maxassoc '30'
        option disabled '0'
        option hidden '1'
        option ssid 'ap-wifi'
        option encryption 'psk2'
        option key '*********'

config wifi-iface 'ap_2'
        option device 'radio0'
        option ifname 'wlan0-3'
        option network 'apspt2'
        option mode 'ap'
        option maxassoc '30'
        option disabled '1'

config wifi-iface 'ap_3'
        option device 'radio0'
        option ifname 'wlan0-4'
        option network 'apspt3'
        option mode 'ap'
        option maxassoc '30'
        option disabled '1'

config wifi-iface 'ap_4'
        option device 'radio0'
        option ifname 'wlan0-5'
        option network 'apspt4'
        option mode 'ap'
        option maxassoc '30'
        option disabled '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option readethers '1'
cat /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdcc:6470:e6c9::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'apspt'
        option type 'bridge'
        option dns '8.8.8.8'
        option proto 'static'
        option ipaddr '10.130.0.1'
        option netmask '255.255.255.0'
        option gateway '255.255.255.255'

config interface 'apspt2'
        option type 'bridge'
        option dns '8.8.8.8'
        option proto 'static'
        option ipaddr '10.130.5.1'
        option netmask '255.255.255.0'
        option gateway '255.255.255.255'

config interface 'apspt3'
        option type 'bridge'
        option dns '8.8.8.8'
        option proto 'static'
        option ipaddr '10.130.6.1'
        option netmask '255.255.255.0'
        option gateway '255.255.255.255'

config interface 'apspt4'
        option type 'bridge'
        option dns '8.8.8.8'
        option proto 'static'
        option ipaddr '10.130.7.1'
        option netmask '255.255.255.0'
        option gateway '255.255.255.255'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.8.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option metric '1'
        option proto 'dhcp'
        option hostname 'xyz'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config interface 'wwan'
        option proto 'dhcp'
        option metric '2'

config interface 'cell'
        option ifname '3g-modem'
        option service 'umts'
        option apn 'J108.com.attz'
        option proto '3g'
        option device '/dev/ttyUSB4'
        option node '1-1.2:1.3'
        option auth 'NONE'
        option metric '3'
        option disabled '0'


cat /etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'disabled'
        option ra 'disabled'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'apspt'
        option interface 'apspt'
        option leasetime '120m'
        option start '10'
        option limit '30'
        option dynamicdhcp '1'

config dhcp 'apspt2'
        option interface 'apspt2'
        option leasetime '120m'
        option start '10'
        option limit '100'
        option dynamicdhcp '1'

config dhcp 'apspt3'
        option interface 'apspt3'
        option leasetime '120m'
        option start '10'
        option limit '100'
        option dynamicdhcp '1'

config dhcp 'apspt4'
        option interface 'apspt4'
        option leasetime '120m'
        option start '10'
        option limit '30'
        option dynamicdhcp '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config dhcp 'wwan'
        option interface 'wwan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
cat /etc/config/firewall

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             apspt
        list   network          'apspt'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             apspt2
        list   network          'apspt2'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             apspt3
        list   network          'apspt3'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             apspt4
        list   network          'apspt4'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        list   network          'wwan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

config forwarding
        option src              apspt
        option dest             wan

config forwarding
        option src              apspt2
        option dest             wan

config forwarding
        option src              apspt3
        option dest             wan

config forwarding
        option src              apspt4
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
        option name             Support-UDP-Traceroute
        option src              wan
        option dest_port        33434:33689
        option proto            udp
        option family           ipv4
        option target           REJECT
        option enabled          false

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

This configuration has major issues (way too many to even begin to enumerate them). I would recommend that you reset to defaults and start fresh.

@psherman Can you tell me the issue is in specific to which configuration?

That would take a lot of time... there are probably more than 20 major issues that I see.

Did you upgrade from GL-inet's firmware to OpenWrt and keep settings?

I did fail safe procedure that I think will also remove the default settings.

What do you mean by that? Failsafe won't remove defaults, but it is a good way to reset to defaults if you end up with an invalid configuration.

Feel free to make a backup before you reset, but you do need to start over as there are major problems.

firstboot -y && reboot

@psherman I'm using this debrick method: Debrick via Uboot - GL.iNet Router Docs 3 (gl-inet.com)

You shouldn’t need to de-brick, just reset to defaults. Or, run the sysupgrade using the official openwrt firmware (from openwrt.org, not glinet) and do not keep settings when tin run the upgrade (uncheck the keep settings box or use the -n argument on the command line sysupgrade)

I'm using the custom build based on OpenWrt 23.05 release.

I cloned the OpenWrt 23.05 release from their official GitHub page and modified the build with my own changes as per the requirements.

who's "their" ?

@frollic I mean OpenWrt's official GitHub page.

Download from here:

https://firmware-selector.openwrt.org/?version=23.05.3&target=ath79%2Fnand&id=glinet_gl-xe300

@psherman Once I download and upgrade with the above build, Can I upgrade again with my custom build using sysupgrade?

Because the reason is I want my custom changes in the build.

Where did the custom build come from? Please provide the link to the source.

And what is customized?