Openwrt 23.05.5 Randomly hanging router

Hello there.
I installed to the router Asus RT-AX59U openwrt 23.05.5 240924 / LuCI openwrt-23.05 branch git-23.118.79121-6fb185f.
But 7-8 days working fine, and started randomly hanging. I can't ping the router and can't ssh access. After pressing power button on the router, working fine again. for 7 days, or may be hanging after 1 hour or 30 minutes or 5 minutes.
Before was stock firmware, the router working fine and never hanging.
I still not undarstanding is the router hanging or just network ports are down.

This is unusual behavior, for sure.

A few possibilities:

  • If you've installed additional packages, it's possible you're ending up in an out-of-memory condition
  • you could have an issue with your configuration
  • You could have a failing power supply

Let's start with the first 2 -- have you installed any additional/non-default packages? And if so, what are they?

And let's look at your configuration:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thanks for answer. I not sure that is power supply, because on stock firmware router working fine.

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.167",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "ASUS RT-AX59U",
        "board_name": "asus,rt-ax59u",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.5",
                "revision": "r24106-10cc5fcd00",
                "target": "mediatek/filogic",
                "description": "23.05.5 240924"
        }
}
root@OpenWrt:~
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd84:98bd:a673::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config device
        option name 'lan1'
        option macaddr ''

config device
        option name 'lan2'
        option macaddr ''

config device
        option name 'lan3'
        option macaddr ''

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr ''

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option hostname '*'
        option peerdns '0'
        list dns '8.8.8.8'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

root@OpenWrt:~#
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HE20'
        option disabled '0'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2'
        option key ''

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option disabled '0'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2'
        option key ''

root@OpenWrt:~#
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option mac ''
        option ip '192.168.1.2'

config host
        option mac ''
        option ip '192.168.1.3'

root@OpenWrt:~#
root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option src 'wan'
        option src_dport '26724'
        option dest_ip '192.168.1.3'

config redirect
        option dest 'lan'
        option target 'DNAT'
        option src 'wan'
        option src_dport '53759'
        option dest_ip '192.168.1.2'

root@OpenWrt:~#

I don't see anything unusual about your config, so that's not likely the issue.

It does appear you installed miniupnp... have you tried disabling this? Have you installed anything else?

This is probably fair, but there are situations where the device may be consuming more power and thus pushing the power supply to its limits. Take for example, using an older computer with a new operating system -- the computer likely has more demands placed on it due to the additional features of the operating system, sometimes making it slower. But even if the computer can keep up, it may have fewer idle cycles than it did previously, meaning that is pulling more power and in turn asking the power supply to work harder. Same thing may be true in your situation. If you have a spare power adapter that is compatible (the correct voltage output + the same or greater current capacity), it would be worth trying it.

I couldn't install anything. thats all services.

There are a lot of heavy services that are not standard for OpenWrt (available, but not installed by default)... things like Adblock, banip, radius, etc.

Are you sure you didn't install anything? Where did this image come from?

Install from here: OpenWRT-23 – Google Диск

Ah... so not from here. I suspect there is something wrong with the image -- potentially as simple as it is running out of memory or some other thing. I also cannot vouch for the potential modifications that have been made, so we don't know if they have done anything else that makes it unusable and/or reduces security.

Since you've obtained your image from another source, you should ask them for help.

Or, install a standard default image for your device directly from openwrt.org:

https://firmware-selector.openwrt.org/?version=23.05.5&target=mediatek%2Ffilogic&id=asus_rt-ax59u

Thanks, and one question, how i can check logs after crash router? but logs writing in /tmp, and empty after power off/on.

As you know, logs are stored in /tmp (RAM) so they are lost upon a crash/reboot. So... the options are:

  1. send logs to an external syslog server.
  2. write logs to a USB stick
  3. use the internal serial port connected to a computer to get continuous logging from the UART output.

The first two of these are not guaranteed to find the issue as it depends on the timing/sequencing of things crashing... if the network goes down before the logs can be output via the network to the syslog server, obviously that's not going to reveal much info. A USB stick is a similar issue -- if the USB/mount fails before the log gets written to disk, you won't have a useful output. (also, be aware that the USB stick's memory can wear out quickly, but they are cheap and ubiquitous so IMO that's not a big deal). The serial UART method is likely the most reliable.

But, I think the best option is to install from the official source, and then if there are any specific packages you need, just install those (rather than the whole package that somebody else put together).

A very simple solution is a permanently active ssh session, running "logread -f"

2 Likes

Hi, I'm don't think it was PSU, beause i read other peoples also reported hangs Asus ax-59U with standart firmware Openwrt 23.05.5 from firmware-selector.
But in russian community 4pda. I think maybe this is cpu scale too high?

Well, put it this way, we have no way to know what they've done. You can ask them for help.

But there is no reason to have all those extra services installed unless you are actively using them. Therefore, install a standard official stable release downloaded from here and test to see if you still have issues.

1 Like

Dont even think about overclocking.

Can you help me please with this issue? wan port down randomly. On the stock firmware working fine.

[135661.563409] mt7530-mdio mdio-bus:1f lan1: Link is Down
[135665.723603] mt7530-mdio mdio-bus:1f lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[135665.723625] br-lan: port 1(lan1) entered blocking state
[135665.736906] br-lan: port 1(lan1) entered forwarding state
[187766.135334] br-lan: port 1(lan1) entered disabled state
[187766.135453] mt7530-mdio mdio-bus:1f lan1: Link is Down
[187769.256063] mt7530-mdio mdio-bus:1f lan1: Link is Up - 10Mbps/Full - flow control rx/tx
[187769.256083] br-lan: port 1(lan1) entered blocking state
[187769.269462] br-lan: port 1(lan1) entered forwarding state
[216508.135241] br-lan: port 1(lan1) entered disabled state
[216508.135362] mt7530-mdio mdio-bus:1f lan1: Link is Down
[216511.255918] mt7530-mdio mdio-bus:1f lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[216511.255941] br-lan: port 1(lan1) entered blocking state
[216511.269224] br-lan: port 1(lan1) entered forwarding state
[219770.255271] br-lan: port 1(lan1) entered disabled state
[219770.255386] mt7530-mdio mdio-bus:1f lan1: Link is Down
[219773.375912] mt7530-mdio mdio-bus:1f lan1: Link is Up - 10Mbps/Full - flow control rx/tx
[219773.375934] br-lan: port 1(lan1) entered blocking state
[219773.389312] br-lan: port 1(lan1) entered forwarding state
[238125.409404] br-lan: port 1(lan1) entered disabled state
[238125.409520] mt7530-mdio mdio-bus:1f lan1: Link is Down
[238128.530581] mt7530-mdio mdio-bus:1f lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[238128.530602] br-lan: port 1(lan1) entered blocking state
[238128.543892] br-lan: port 1(lan1) entered forwarding state
[272949.051056] br-lan: port 1(lan1) entered disabled state
[272949.051179] mt7530-mdio mdio-bus:1f lan1: Link is Down
[272951.142893] mt7530-mdio mdio-bus:1f lan1: Link is Up - 10Mbps/Full - flow control rx/tx
[272951.142916] br-lan: port 1(lan1) entered blocking state
[272951.156283] br-lan: port 1(lan1) entered forwarding state
[306798.238208] br-lan: port 1(lan1) entered disabled state
[306798.238324] mt7530-mdio mdio-bus:1f lan1: Link is Down
[306802.397757] mt7530-mdio mdio-bus:1f lan1: Link is Up - 1Gbps/Full - flow control rx/tx
[306802.397776] br-lan: port 1(lan1) entered blocking state
[306802.411066] br-lan: port 1(lan1) entered forwarding state

Have you installed official OpenWrt (obtained from OpenWrt.org)? Or are you still using this version:

That looks like windows WoL keeping port up at slow speed?

Looks like auto-negotiation of ethernet speed not working correctly. You might use fixed speed.

Hello. I find in the logs at morning: Can you help please?

[386720.066062] mt7530-mdio mdio-bus:1f lan1: Link is Down
[386723.186309] mt7530-mdio mdio-bus:1f lan1: Link is Up - 10Mbps/Full - flow control rx/tx
[386723.186337] br-lan: port 1(lan1) entered blocking state
[386723.199711] br-lan: port 1(lan1) entered forwarding state
[391574.725973] ------------[ cut here ]------------
[391574.730680] NETDEV WATCHDOG: eth0 (mtk_soc_eth): transmit queue 6 timed out
[391574.737744] WARNING: CPU: 2 PID: 0 at 0xffffffc0086c6494
[391574.743126] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet l2tp_ppp batman_adv wireguard pptp pppox ppp_mppe ppp_generic nft_tproxy nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_compat nft_chain_nat nf_tables nf_nat_tftp nf_nat_snmp_basic nf_nat_sip nf_nat_pptp nf_nat_irc nf_nat_h323 nf_nat_amanda nf_nat nf_flow_table nf_conntrack_tftp nf_conntrack_snmp nf_conntrack_sip nf_conntrack_pptp nf_conntrack_netlink nf_conntrack_irc nf_conntrack_h323 nf_conntrack_broadcast nf_conntrack_amanda nf_conntrack mt7915e mt76_connac_lib mt76 mac80211 libchacha20poly1305 iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables chacha_neon cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS
[391574.743264]  xt_LOG xt_HL xt_DSCP xt_CLASSIFY x_tables usblp ts_kmp ts_fsm ts_bm tls slhc sch_cake poly1305_neon nfnetlink nf_tproxy_ipv6 nf_tproxy_ipv4 nf_reject_ipv6 nf_reject_ipv4 nf_log_syslog nf_defrag_ipv6 nf_defrag_ipv4 libcurve25519_generic libchacha compat br_netfilter crypto_safexcel sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred act_gact msdos ip6_gre ip_gre gre ifb sit l2tp_netlink l2tp_core udp_tunnel ip6_udp_tunnel ip6_tunnel tunnel6 tunnel4 ip_tunnel veth tun ntfs hfsplus cdrom cifs oid_registry cifs_md4 cifs_arc4 asn1_decoder dns_resolver nls_utf8 nls_iso8859_15 nls_iso8859_1 nls_cp850 nls_cp437 nls_cp1250 xxhash_generic crypto_user algif_skcipher algif_rng algif_hash algif_aead af_alg sha1_generic seqiv md5 des_generic libdes blake2b_generic authencesn authenc arc4 usb_storage leds_gpio xhci_plat_hcd xhci_pci xhci_mtk_hcd xhci_hcd gpio_button_hotplug vfat fat exfat btrfs xor xor_neon raid6_pq
[391574.830703]  libcrc32c usbcore usb_common aquantia crc_ccitt
[391574.923533] CPU: 2 PID: 0 Comm: swapper/2 Not tainted 5.15.167 #0
[391574.929696] Hardware name: ASUS RT-AX59U (DT)
[391574.934122] pstate: 40400005 (nZcv daif +PAN -UAO -TCO -DIT -SSBS BTYPE=--)
[391574.941150] pc : 0xffffffc0086c6494
[391574.944709] lr : 0xffffffc0086c6494
[391574.948267] sp : ffffffc008b7bdb0
[391574.951651] x29: ffffffc008b7bdb0 x28: 0000000000000140 x27: 00000000ffffffff
[391574.958853] x26: 0000000000000000 x25: 0000000000000002 x24: ffffff800099e4c0
[391574.966054] x23: 0000000000000000 x22: 0000000000000001 x21: ffffffc008a46000
[391574.973257] x20: ffffff800099e000 x19: 0000000000000006 x18: ffffffc008a5a2a8
[391574.980458] x17: ffffffc017485000 x16: ffffffc008b78000 x15: 00000000000004ec
[391574.987660] x14: 00000000000001a4 x13: ffffffc008b7bae8 x12: ffffffc008ab22a8
[391574.994863] x11: 712074696d736e61 x10: ffffffc008ab22a8 x9 : 0000000000000000
[391575.002065] x8 : ffffffc008a5a258 x7 : ffffffc008a5a2a8 x6 : 0000000000000001
[391575.009266] x5 : 0000000000000000 x4 : 0000000000000000 x3 : 0000000000000000
[391575.016468] x2 : ffffff801feb3090 x1 : ffffffc017485000 x0 : 000000000000003f
[391575.023670] Call trace:
[391575.026189]  0xffffffc0086c6494
[391575.029401]  0xffffffc0080a5b50
[391575.032613]  0xffffffc0080a63c8
[391575.035824]  0xffffffc0080a6918
[391575.039036]  0xffffffc00803b04c
[391575.042248]  0xffffffc00803b404
[391575.045460]  0xffffffc00803b5d0
[391575.048672]  0xffffffc008089454
[391575.051883]  0xffffffc0080100e0
[391575.055096]  0xffffffc00801584c
[391575.058307]  0xffffffc00801609c
[391575.061519]  0xffffffc008835d90
[391575.064730]  0xffffffc008836544
[391575.067942]  0xffffffc008011374
[391575.071154]  0xffffffc008836b24
[391575.074365]  0xffffffc008069350
[391575.077576]  0xffffffc008069564
[391575.080787]  0xffffffc00801ebe0
[391575.083999]  0xffffffc00883f2cc
[391575.087211] ---[ end trace 6882411206c6d7e7 ]---
[391575.091915] mtk_soc_eth 15100000.ethernet eth0: transmit timed out
[391575.230319] mtk_soc_eth 15100000.ethernet eth0: Link is Down
[391575.775939] mtk_soc_eth 15100000.ethernet: warm reset failed
[391575.796780] mtk_soc_eth 15100000.ethernet eth0: configuring for fixed/2500base-x link mode
[391575.805273] mtk_soc_eth 15100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
[391635.872705] page_pool_release_retry() stalled pool shutdown 404 inflight 60 sec
[391696.154012] page_pool_release_retry() stalled pool shutdown 404 inflight 120 sec
[391756.440522] page_pool_release_retry() stalled pool shutdown 116 inflight 180 sec
[391816.729093] page_pool_release_retry() stalled pool shutdown 99 inflight 241 sec
[391877.018451] page_pool_release_retry() stalled pool shutdown 83 inflight 301 sec
[391937.308123] page_pool_release_retry() stalled pool shutdown 54 inflight 361 sec
[391997.597883] page_pool_release_retry() stalled pool shutdown 41 inflight 422 sec
[392057.887728] page_pool_release_retry() stalled pool shutdown 36 inflight 482 sec
[392118.177569] page_pool_release_retry() stalled pool shutdown 36 inflight 542 sec
[392178.467443] page_pool_release_retry() stalled pool shutdown 30 inflight 603 sec

Is this the image you were using previously, or did you install OpenWrt directly from openwrt.org?