OpenWRT 23.05.3 N95 slow NICs

Hello

I have questions about how to check if the latest version of OpenWRT 23.05.3 is going to solve the speed problem I have with PPPoE.

I have 500Mbps contracted but I only get 59~ download and 81~ upload
image

I leave the ubus call system board command here to give you more information about the device

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "OpenWrt",
        "system": "Intel(R) N95",
        "model": "Default string Default string",
        "board_name": "default-string-default-string",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "x86/64",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}
root@OpenWrt:~#

If you need anything else, I will be very attentive to the topic to provide you with the information quickly.

Thanks

Realtek NICs ?

Install a snapshot instead - ACEMAGICIAN T8PLUS (Intel N95) - #53 by frollic

Dont know how to check that

i dont understand you, i think.
Do you mean that i should install a not stable version?

Sorry for the confusion

lspci via ssh.

correct.

but you can start with the echo 0:s from ACEMAGICIAN T8PLUS (Intel N95) - #47 by devast, running your current version of OpenWRT.

What does your ISP say? Can you test your connection with a different router?

99% chance of it being a RTL NIC quirk, read the linked thread.

root@OpenWrt:~# lspci
00:00.0 Host bridge: Intel Corporation Device 4618
00:02.0 VGA compatible controller: Intel Corporation Alder Lake-N [UHD Graphics]
00:14.0 USB controller: Intel Corporation Alder Lake-N PCH USB 3.2 xHCI Host Con                                 troller
00:14.2 RAM memory: Intel Corporation Alder Lake-N PCH Shared SRAM
00:16.0 Communication controller: Intel Corporation Alder Lake-N PCH HECI Contro                                 ller
00:17.0 SATA controller: Intel Corporation Device 54d3
00:1c.0 PCI bridge: Intel Corporation Device 54bb
00:1d.0 PCI bridge: Intel Corporation Device 54b2
00:1d.3 PCI bridge: Intel Corporation Device 54b3
00:1f.0 ISA bridge: Intel Corporation Device 5482
00:1f.3 Audio device: Intel Corporation Alder Lake-N PCH High Definition Audio C                                 ontroller
00:1f.4 SMBus: Intel Corporation Device 54a3
00:1f.5 Serial bus controller: Intel Corporation Device 54a4
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8211/8                                 411 PCI Express Gigabit Ethernet Controller (rev 15)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac P                                 CIe Wireless Network Adapter
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8211/8                                 411 PCI Express Gigabit Ethernet Controller (rev 15)
root@OpenWrt:~#

Is it safe? I mean, will i lose any functionality or have problems with all the configuration i have? (Wireguard PTP, dumb ap, etc, etc)

500~mbps more or less...

it's safe, and gone after a reboot.

I think i should start doing this (?) ACEMAGICIAN T8PLUS (Intel N95) - #47 by devast as @devast says:

echo 0 > /sys/class/net/eth0/device/link/l1_aspm
echo 0 > /sys/class/net/eth1/device/link/l1_aspm

right?

yes, run those two, then retest.

Should i restart any interface after run those two comands?

image
Seems like improved a little without restart anything

EDIT: sometimes...
image

perhaps your ISP is doing some serious over booking ?

is all your traffic going via the WG tunnel ?

boot a snapshot from a flashdrive (to keep your current setup intact), and try the same two lines while you run the snapshot.

Dont think so... look at this:

image

But is a problem of the Archer C6 i have as "Dumb AP", i have connected the N95 by wire to my PC and that's the speedtest...

EDIT: Dont seem like a CPU problem:


(While running a speed test)

you lost me me at

1 Like

Ok, i explain myself better. Sorry

I have the N95 as router and a TP-Link Archer C6 as dumb AP. I thought the problem was with the N95 but I took the cable that gives internet to the Archer C6 and connected it directly to my PC and as you can see, the speed test was flying. so I have to understand that the problem is in the Archer C6

ok.

is the C6 configured correctly - https://openwrt.org/docs/guide-user/network/wifi/dumbap ?
the archer shouldn't throttle the LAN traffic, if configured correctly.
are you using the WAN port ?

Yes it is, i followed that guide:

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option synflood_protect '1'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'REJECT'
        option forward 'REJECT'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~#

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd15:41f3:262b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.2'
        option gateway '192.168.2.1'
        list dns '192.168.2.1'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '20'
        option ports '0t 5t 1t'

config route
        option interface 'lan'
        option target '192.168.2.226/24'
        option gateway '192.168.2.1'
        option disabled '1'

root@OpenWrt:~#

No, only the LAN ports

weird, since it's transparent, network wise.

I suggest you start a new thread about the C6 issue.

What radio are you using?
2.4Ghz or 5Ghz?

Yes, would be good. Ok

Those slow speed test are made with 5Ghz. With 2.4Ghz the speed is 14mbps