OpenWrt 23.05.2 - Service Release

@a-z didn’t you encounter reduced memory in 23.05 giving rise to OOM situations with the otherwise exact same adblock settings?

Had over 200mbit x 20mbit when attempting to update but the wired connection helped. Ultimately installed the attended upgrade package for luci and that worked.

I skipped the initial release of 23.05, so this is my first experience with any v23.

No adblock in use, but I do have the same additional packages installed that I had on v22, though of course they would have been updated because they were installed anew post v23. It's possible that it's an issue with one of them that would have materialized on v22 with the same package version, but that would be pretty unlucky.

I don't know if it this issue ultimately leads to OOM.

1 Like

Might be worth installing luci-app-statistics (and the depencies) to plot ram usage over time. If you store the rrd files on USB they will survive reboot.

Lot easier than trying to tell the trend by manually collecting values occasionally. Compare with an uptime graph to see what happens after reboots etc.

4 Likes

I have two TP-Link Archer A7 v5 routers. One acts as router and other just an AP. For both of them, I replaced the following packages:

ath10k-firmware-qca988x-ct ==>> ath10k-firmware-qca988x (non-ct)
kmod-ath10k-ct ==>> kmod-ath10k-smallbuffers (non-ct and uses small buffers for low RAM usage)

I had high RAM usage if I used the kmod-ath10k (without smallbuffers, irrespective of -ct and non-ct version). Switching to -smallbuffers kmod fixed the issue for me. I am not running adblock so cannot comment on that.

2 Likes

As of 23.05.2 (and also in SNAPSHOT), you can enable auto backup of the luci-app-statistics data on the rrdtool setup page.

See details at https://github.com/openwrt/luci/pull/6646 (jtkohl is @atownlede in the forums, if you have questions about it).

3 Likes

OK, it's been a couple years since I've switched, but I will try this in the morning (note: I'm not running adblock either, that must have been some other post) and then reboot:

opkg update
opkg remove ath10k-firmware-qca988x-ct
opkg install ath10k-firmware-qca988x
opkg remove kmod-ath10k-ct-smallbuffers
opkg install kmod-ath10k-smallbuffers

@DBAA Completely forgot about that. If the above doesn't work, I'll put it on.

I also noticed something has significantly changed in "Used" memory changing from 22.03.5 to 23.05.2; the vertical red line in the following pics is Sun 19th, when I upgraded to 23.05.2.

Last 4 weeks stats:

Last 3 months stats:

3 Likes

I just updated my two routers from 23.05.0 to 23.05.2.
One Netgear R6850, one Xiaomi Mi Router 3G. Both MT7621 devices.

umdns appears to crash at startup. Here's what I have in the system logs:

Sat Nov 25 05:48:44 2023 kern.info kernel: [   29.269293] do_page_fault(): sending SIGSEGV to umdns for invalid write access to 00000004
Sat Nov 25 05:48:44 2023 kern.info kernel: [   29.277676] epc = 77df362b in libubox.so.20230523[77df1000+1f000]
Sat Nov 25 05:48:44 2023 kern.info kernel: [   29.284048] ra  = 77df6a0f in libubox.so.20230523[77df1000+1f000]

Restarting umdns manually makes it work fine. This happens on both devices, and did not happen with 23.05.0.

I'm using the "vanilla" sysupgrade image on each device. I tried doing an attended sysupgrade for the first time, it worked great, kept all my packages including umdns... but I had this problem. So I tried going back to the vanilla image and installing my packages afterwards, like I did before, and that didn't fix it. So the attended sysupgrade process seems innocent here :grinning:

not sure, but there is something different in 23.05.x, if I return to 22 I don't have any issues using adblock-lean

Maybe I'm not reading that right, but it looks like your Available/Free memory is essentially unchanged despite the increased usage, which seems to have carved into Cached.

In my case, it's the Available/Free which has taken a hit, and unfortunately the guess above about the wireless driver was not the cause, since I've been on that for several hours and it's no better.

If it holds in the upper 30's, then this might not be a problem. I'm just not sure how far this will go without more time.

Upgraded my ASUS RT-AX53U from 22.03.5 to 23.05.2. I'm seeing that the WiFi interface names have changed from wlan0-1 to phy0-ap1. Guessing it doesn't just apply to this device, but a general change to naming standard in 23.05?

Also seeing that the WiFi LEDs can now be controlled, like discussed here Ax53u the wifi led indicator parameter is missing - #8 by saber716rus
But the WAN/internet light still can't be controlled.

looks good everything on vr200 passed 23.03.05->23.05.2 smoothly via this package.

  • Any config not preserved from previous version.

Dsl (Vdsl), Wi-Fi, Ethernet port(only tested one of them) works well. I even took almost cable speed next to it on Wi-Fi.

System
Hostname OpenWrt
Model TP-LINK Archer VR200
Architecture xRX200 rev 1.2
Target Platform lantiq/xrx200
Firmware Version OpenWrt 23.05.2 r23630-842932a63d / LuCI openwrt-23.05 branch git-23.306.39416-c86c256
Kernel Version 5.15.137
Local Time 2023-11-26 18:47:05
Uptime 0h 58m 6s
Load Average 0.17, 0.17, 0.37

lantiq/xrx200 target shows error messages in DSA switch configuration of the integrated GSWIP switch.

I can do any test for this for 2 days.

Thank you

1 Like

Upgrade from 23.05.1 to 23.05.2 on WRT1900ACSv2 appears to be working well. No issues detected.

I am operating a few Netgear R7800 running stable on 22.03.5. Unattended sysupgrade failed. I expected it. Proceeded with sysupgrade 23.05.0. that worked, but unfortunately my entire LAN rendered useless. Probably because of DSA (my wild guess). Unfortunately there is not much info out there for proper config DSA/VLAN. I had to revert back to 22.03.5. Keep up the good work.

R7800/ipq806x has not been migrated to DSA yet, not even on 23.05 builds.

1 Like

It has been in main-snapshots, post-23.05 so 24.xy.0 will have it (23.05.9999 will not).

Ok thanks. I have to think again what caused the damage. Maybe stubby.

Fresh install on a Linksys EA8300: /var/lib is missing (it was the case for 23.05.0 as well), but a "mkdir /var/lib" in the local startup fixes it (I use logrotate and it definitely needs this folder). Otherwise everything works fine! Thanks for all the efforts!

Did you keep settings? It's a pain, I know, but with major version upgrades like 22.x to 23.x, it is a good idea to not keep settings and reconfigure manually using a prior back up as a guide.