OpenWrt 23.05.2 - Service Release

I just encountered the same issue on the first boot after the upgrade. A reboot solved it for me.

Hi all

On the above link, I had reported that the multiple bridged network works, however with the upgrade to 23.05.2, I had noticed some 'weirdness' with the WRT1900ACSv2.

An ACER laptop (Win10) would crash. (TaskManager/Windows Explorer)
Android devices would not acquire an IPv6 address.
Both on the second bridge (wireless)

Switching boot partitions to the Master-r24238 (6.1.60 testing kernel), everything works (multiple vlans using bridge vlan filtering)

When you create another bridge under Network/Interfaces/Devices, the same MAC address will be used as the default BR-LAN bridge. After much exploring, change the MAC address (i.e. +1) on the new bridge, and everything works as expected.

Time and date were wrong on one access point. Thanks for the quick solution

2 Likes

I can't notice any difference in LUCI behavior..
Upgrade went fine here, too...
Unfortunately the WAN LED is still missing...

'ls' '/sys/class/leds/'**
ath10k-phy0
ath9k-phy1
green:qss
green:system
green:usb1
green:usb2
green:wlan2g
green:wlan5g

They do. I have been sysupgrading mine for years.

Up & running on TP-LINK TD-W8970 (lantiq/xrx200) dumb AP with Extroot for p910nd printer server and Collectd Settings with RRDTool; the new Port Status in homepage is very nice.

Many thanks to all the dev guys.

1 Like

Upgraded my Xiaomi Redmi Router AX6000 (OpenWrt U-Boot layout) from 23.05.0 to 23.05.2 and apparently DNS no longer works, nor on the router itself nor for the LAN/WiFi clients.

root@Pronichkin-Router:~# nslookup bing.com
nslookup: write to '127.0.0.1': Connection refused
nslookup: write to '::1': Connection refused
;; connection timed out; no servers could be reached

root@Pronichkin-Router:~# nslookup bing.com 8.8.8.8
Server:         8.8.8.8
Address:        8.8.8.8:53

Non-authoritative answer:
Name:   bing.com
Address: 13.107.21.200
Name:   bing.com
Address: 204.79.197.200

Non-authoritative answer:
Name:   bing.com
Address: 2620:1ec:c11::200

root@Pronichkin-Router:~# service dnsmasq status
running
root@Pronichkin-Router:~# service dnsmasq info
{
        "dnsmasq": {
                "instances": {
                        "cfg01411c": {
                                "running": false,
                                "command": [
                                        "/usr/sbin/dnsmasq",
                                        "-C",
                                        "/var/etc/dnsmasq.conf.cfg01411c",
                                        "-k",
                                        "-x",
                                        "/var/run/dnsmasq/dnsmasq.cfg01411c.pid"
                                ],

is it expectred that "status" says running but "info" says "running": false,"?

I just tried attended sysupgrade from luci, ER-X running 22.03.5. Seems to fail due to an SSL library conflict?

Collected errors:
 * opkg_install_cmd: Cannot install package acme-dnsapi.
 * opkg_install_cmd: Cannot install package luci-i18n-acme-en.
 * opkg_install_cmd: Cannot install package luci-i18n-adblock-en.
 * opkg_install_cmd: Cannot install package luci-i18n-ddns-en.
 * opkg_install_cmd: Cannot install package luci-i18n-wireguard-en.
 * check_data_file_clashes: Package libustream-mbedtls20201210 wants to install file /builder/build_dir/target-mipsel_24kc_musl/root-ramips/lib/libustream-ssl.so
	But that file is already provided by package  * libustream-wolfssl20201210
 * opkg_install_cmd: Cannot install package luci-ssl.

I've had auc do the wolfssl -> mbedtls conversion automatically on a bunch of different platforms, but if it's not working for you, then you should probably back up your config and start from scratch with a base image (or maybe a custom one using https://firmware-selector.openwrt.org/ if you have many extra packages installed).

I do have a script that does the swap manually (which you'd run before the upgrade), if you're willing to get your hands dirty and configure it.

Beyond that, the rather pointless -en packages have been removed a while ago.

Also, did your specify a time server in the drop down menu?
I missed that and the routers time was slowly drifting off.

1 Like

Interesting - auc -c tells me there are several packages I can upgrade at version 22.03.5, though nothing to do with auc or attended sysupgrade. Is it possible that I need to be more recent for attended sysupgrade to work?

Here are the packages it proposes to upgrade:

 luci-app-adblock: git-23.049.70484-d2c0e80 -> git-23.189.73167-ba11ad3
 avahi-dbus-daemon: 0.8-7 -> 0.8-8
 luci-lib-ip: git-20.250.76529-62505bd -> git-23.311.79310-704a335
 libwolfssl: 5.5.4-stable-1 -> 5.6.3-stable-1
 openssl-util: 1.1.1t-3 -> 1.1.1w-1
 adblock: 4.1.5-7 -> 4.1.5-8
 luci-i18n-acme-en: git-23.119.78447-aec994b -> git-23.281.54470-b176327
 luci-mod-status: git-23.093.42411-713f701 -> git-23.292.78392-20daafc
 libmbedtls: 2.28.2-1 -> 2.28.4-1
 luci-i18n-ddns-en: git-23.119.78447-aec994b -> git-23.281.54470-b176327
 curl: 8.1.0-1 -> 8.4.0-1
 sudo: 1.9.10-1 -> 1.9.14p3-1
 luci-base: git-23.119.80898-65ef406 -> git-23.292.78392-9f66674
 libopenssl: 1.1.1t-3 -> 1.1.1w-1
 luci-i18n-adblock-en: git-23.119.78447-aec994b -> git-23.281.54470-b176327
 acme-dnsapi: 3.0.1-2 -> 3.0.6-3
 libopenssl-conf: 1.1.1t-3 -> 1.1.1w-1
 libpcap: 1.10.1-3 -> 1.10.1-4
 uhttpd: 2022-10-31-23977554-1 -> 2023-06-25-34a8a74d-1
 libcurl: 8.1.0-1 -> 8.4.0-1
 conntrack: 1.4.6-3 -> 1.4.8-1
 ca-bundle: 20211016-1 -> 20230311-1
 luci-lib-jsonc: git-22.097.61921-7513345 -> git-23.298.74581-7dfbbca
 libexpat: 2.4.9-1 -> 2.5.0-1
 luci-mod-network: git-23.118.74641-4b1cbff -> git-23.170.81153-99d3815
 uhttpd-mod-ubus: 2022-10-31-23977554-1 -> 2023-06-25-34a8a74d-1
 wget-ssl: 1.21.3-2 -> 1.21.4-1
 hostapd-common: 2022-01-16-cff80b4f-16.2 -> 2022-01-16-cff80b4f-18.3
 acme: 3.0.1-2 -> 3.0.6-3
 urngd: 2020-01-21-c7f7b6b6-1 -> 2023-07-25-7aefb47b-1
 libavahi-dbus-support: 0.8-7 -> 0.8-8

You know you just use -b 23.05 to switch over to 23.05.X?

1 Like

No, as @lleachii said, use auc -b 23.05 if you want to jump releases. You can combine that with auc -c -b 23.05 to see what's going to happen.

Ah - thanks, that does appear to work. I didn't realize at first that the process is interactive. I thought replying y would apply the sysupgrade.
Just need to back up and see what happens!

1 Like

That worked like a charm, although I had to reinstall and restart the ddns and adblock services. Sweet - thanks all!

2 Likes

Just to be clear, plain old auc by default only checks for newer releases of whatever branch you're currently running on the device. You can use -b to change the release branch, by saying -b 22.03 or -b snapshot.

You can also use -B to jump around inside that specific branch, so if you already have 23.05.2 installed, but for some reason need to downgrade, you'd say

$ auc -b 23.05 -B 23.05.0

(auc has other tricks, but those are by far the most useful.)

Thanks - this is good to know. I did some searching and tested some combos, but couldn't find any concise docs on what goes where for auc. As a case in point -b 23.05.2 yielded error 22, which wasn't super .. um .. elucidative.

On a tangent, I know packages installed after the root (squashfs?) filesystem is built go into an overlay. Is it good/best practice to rebuild the firmware again with the complete package list, or is it better to leave it alone until next update?

I imagine

$ auc -f

will do the trick?

Why was the DSL metrics abbreviated? I know I can get the details via ubus call dsl metrics but it was nice having this on Luci...
image

Install luci-mod-dsl and go to Status -> xDSL. This new page provides even more details!

3 Likes