OpenWrt 23.05.2 - Service Release

Your best option would be to run the image builder yourself, that way you can stay with ext4, set the partition sizes as you wish, directly include all the extra packages and all the config files.

Thanks for the suggestion however I am not very technical so prefer a solution that will enable automated updates without the least amount of effort.

Have you or anyone found a cause or solution? I have exactly the same problem. Several sites are not loading, including duckduckgo.com, airbus.com

  • I'm also using a pppoe connection
  • I set my MTU to 1484 which is recommended by my ISP (M-Net)
  • Disabled IPv6
  • I only have a LAN with Wifi and a WAN, nothing complicated.

tcpdump:
The whole transmission has been captured. The missing previous segment is part of the problem.

35	3.736114	93.104.189.250	40.114.177.156	TCP	86	35124 → 80 [FIN, ACK] Seq=1 Ack=1 Win=502 Len=0 TSval=3324066197 TSecr=4047076876 SLE=1449 SRE=2435
36	3.743782	93.104.189.250	40.114.177.156	TCP	82	36258 → 80 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 SACK_PERM TSval=3324066206 TSecr=0 WS=128
37	3.753560	40.114.177.156	93.104.189.250	TCP	74	80 → 35124 [ACK] Seq=2435 Ack=2 Win=6820 Len=0 TSval=4047108076 TSecr=3324066197
38	3.761524	40.114.177.156	93.104.189.250	TCP	82	80 → 36258 [SYN, ACK] Seq=0 Ack=1 Win=7240 Len=0 MSS=1440 SACK_PERM TSval=3230053957 TSecr=3324066206 WS=1
39	3.763970	93.104.189.250	40.114.177.156	TCP	74	36258 → 80 [ACK] Seq=1 Ack=1 Win=64256 Len=0 TSval=3324066226 TSecr=3230053957
40	3.764142	93.104.189.250	40.114.177.156	HTTP	493	GET / HTTP/1.1 
41	3.782062	40.114.177.156	93.104.189.250	TCP	74	80 → 36258 [ACK] Seq=1 Ack=420 Win=6821 Len=0 TSval=3230053978 TSecr=3324066226
42	3.782301	40.114.177.156	93.104.189.250	HTTP	897	[TCP Previous segment not captured] Continuation
43	3.782781	40.114.177.156	93.104.189.250	HTTP	236	Continuation
44	3.784996	93.104.189.250	40.114.177.156	TCP	86	[TCP Dup ACK 39#1] 36258 → 80 [ACK] Seq=420 Ack=1 Win=64256 Len=0 TSval=3324066247 TSecr=3230053978 SLE=1449 SRE=2272
45	3.785166	93.104.189.250	40.114.177.156	TCP	86	[TCP Dup ACK 39#2] 36258 → 80 [ACK] Seq=420 Ack=1 Win=64256 Len=0 TSval=3324066248 TSecr=3230053978 SLE=1449 SRE=2434

[several connection retries after that]

I have not found a solution other than suggested by @logmod. I had to reset the device and reconfigure everything without using the backup archive.
Now its working fine.

I have spend some more time to do a comparison of the changes between my config backup and a new config from scratch. Somehow it escaped me that the MSS Clamping config of my WAN Zone firewall config was unticked. I do not remember unsetting this option (mtu_fix in UCI), but that was the culprit.

as far as i have information OpenWrt rescheduled 23.05.3 until summer, due to hard working and massive issues with OpenWrt One - celebrating 20 years of OpenWrt can anyone confirm this?

where did you get this info???

3 Likes

Congrat you recieve Most Bizarre post of the day award :joy:

6 Likes

in 4pda forum about some beeline routers, OpenWrt related people talkin is OpenWrt already ready to split for pay/free versions like redhat/fedora due to high money interest related to OpenWrt its own hardware, i personally think OpenWrt is new Ubiquiti and there is no time for stable patches like 23.05.3 so for me look legit

1 Like

in 4pda forum about some beeline routers, OpenWrt related people talkin is OpenWrt already ready to split for pay/free versions like redhat/fedora due to high money interest related to OpenWrt its own hardware, i personally think OpenWrt is new Ubiquiti and there is no time for stable patches like 23.05.3 so for me look legit

This is complete and utter nonsense. Please stop spreading unsubstantiated FUD, especially without quoting any actual sources.

Who are those OpenWrt related people talking there? Why are they talking in the 4pda forum and not in the OpenWrt forum? How is it related to Beeline routers?

9 Likes

that is totally random... can you link this forum/topic? Those kind of claim are BS.

Releasing minor release are not tied to any kind of waiting time. If we need to do it (due to a security vulnerability fixed, us fixing other kind of bug or having to fix a family of device broken) we just make it.

On top of that, Openwrt One will be based on an already well established base with the MediaTek SoCs... aka these "massive issues" doesn't actually exist.

The guys on that project don't want to put all kind of experimental crap (2.5g switch) (wifi 7 cards) for this exact reason of providing a good product.

7 Likes

Do they look like that?

9 Likes

:rofl::rofl::rofl:

6 Likes

Look at the OpenWrt meeting, luxury and big money spending everywhere!

10 Likes

Man! I wish I had the kind of money to just blow on Post-It notes like that!

3 Likes

Does irqbalance and packet steering works well together with mvebu? I'll get 500/100mbps fiber soon and I wonder if I should enable those options on my WRT3200ACM as I'm also using SQM cake layer_cake. Is there anything important that I should know about before installing the irqbalance package and enable packet steering?

You can enable both, but neither will do much. There is no multi-core DSA so most things will be on CPU0 with CPU1 not doing much. SQM cake works great on your target up to about 600 Mbps where it will max out the CPU.

1 Like

Is there any work being done to add multi core support in DSA?

Not to my knowledge. There was talk about it on the Turris Omnia/mvebu side for a bit but don't think it happened. (There are likely some significant technical hurdles there.)

It's already there from a lot of times... It's the mvebu driver that doesn't support it.