OpenWrt 23.05.0-rc4 - Fourth Release Candidate

The official source of the allowed bandwidths and power levels for each country is https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt

Alternatively, you can use the iw reg get command after setting the correct country code.

1 Like

i have this

country FR: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
        (5725 - 5875 @ 80), (N/A, 13), (N/A)
        (5945 - 6425 @ 160), (N/A, 23), (N/A), NO-OUTDOOR
        (57000 - 71000 @ 2160), (N/A, 40), (N/A)

so same my 2.4ghz is good for all ? but 5ghz wifi ax only 160 as two possiblity

country FR: DFS-ETSI
	(2400 - 2483.5 @ 40), (100 mW)
	(5150 - 5250 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW, wmmrule=ETSI
	(5250 - 5350 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW, wmmrule=ETSI
	(5470 - 5725 @ 160), (500 mW), DFS, wmmrule=ETSI
	# short range devices (ETSI EN 300 440-1)
	(5725 - 5875 @ 80), (25 mW)
	# WiFi 6E low power indoor
	(5945 - 6425 @ 160), (23), NO-OUTDOOR, wmmrule=ETSI
	# 60 GHz band channels 1-6 (ETSI EN 302 567 v2.2.1)
	(57000 - 71000 @ 2160), (40)

if i put auto then channel out right automaticly ?

Yes - in France, 40 MHz works on any channel number from 1 to 13.

Regarding the "auto" channel, try it. I do not use this feature because I tried all non-equivalent choices manually and verified that channel 149 is optimal in my place for 80 MHz.

2 Likes

OpenWrt 23.05 stable has been tagged as of 8 hours ago.

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=86e852bcd01c4e43423c03984ee431118d57f855

7 Likes

FYI - multiple brcm53xx devices have broken Ethernet since 23.05.0-rc3 (at least Netgear R8000 and Linksys EA9200) leading to an inaccessible router (soft brick) after installing anything newer than 23.05-rc2, including the stable 23.05.0 release from 8 hours ago. If wifi-enabled configs were not carried over, one needs to flash rc2 or some other working firmware to recover.

The cause is most likely this issue: bcm53xx: Linksys EA9200 ethernet is broken #13548

1 Like

I started flashing my router collection to 23.05.0-rc4 with images from the Image Builder. I have two wired, dumb AP ubnt_unifiac-lites w/ VLANs and 4 WiFi SSIDs per radio and they are fine, as well as a tplink_archer-c7 v2 and ubnt_unifi-ap-lr that participate in a mesh w/ GRE tunnels as wired source/wireless dest.

Everything is fine so far. I'd like to highlight GRE tunnels not working in 23.05.0-rc# where basically the max length of an interface name changed between versions and now silently fails if the interface name is too long, which caused me quite a bit of grief and consternation when testing 23.05.0-rc#.

For my main router, I still suffer from the iptables incompatibility issues w/ fwknopd, mwan3, and pbr (the latter two documented in Implementing policy routing in (or compatible with) mwan3). Given that 21.02 is soon to no longer be supported, I'm wondering if anyone knows what fwknopd's and mwan3's plans are for working with OpenWrt going forward?

1 Like

Is 23.05 final out now?

23.05.0 (final) has been tagged in GIT and it is being built. If no major issue is found during the build it is likely to be officially announced/released on this weekend or early next week.

BTW, this is just my own opinion based on what I've observed (git tag and draft release notes), it is nothing official.

1 Like

I guess the remaining items needing review here will be pushed to a future service release?: https://github.com/openwrt/openwrt/issues?q=is%3Aopen+label%3Arelease%2F23.05+sort%3Aupdated-desc+

I was able to use my Netgear WAX206 5GHz WiFi with 160 MHz channel width until 23.05.0-rc2, with rc3 (same settings) the channel width was reduced to 80 MHz and it stayed the same with rc4.

Does anyone else have the same issues with rc3 and rc4 and is there a possible way to fix this?

Could you please state your country code and channel number?

It's Germany and before I used automatic channel selection. With automatic channel selection it was using channel 104 with 80 MHz, now I changed it to the non DFS channel 36 that my WAX220 is using in the upper floor with 160 MHz channel width but it is still 80 MHz.

root@WAX206:~# uci show | grep wireless.radio1
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.path='1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
wireless.radio1.channel='36'
wireless.radio1.band='5g'
wireless.radio1.htmode='HE160'
wireless.radio1.country='DE'
wireless.radio1.cell_density='0'

According to the regulatory rules in the EU, Channel 100 is the only one where 160 MHz bandwidth is allowed.

2 Likes

From what I found it should be allowed in the channels 36 to 64 and 100 to 128 in Germany but switching to channel 100 and waiting for 10 minutes also didn't make any difference.

Strange indeed. Could you please paste the whole output of iw reg and iw phy to pastebin?

You want to have iw reg get, right?

root@WAX206:~# iw reg get
global
country DE: DFS-ETSI
        (2400 - 2483 @ 40), (N/A, 20), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
        (5725 - 5875 @ 80), (N/A, 13), (N/A)
        (5945 - 6425 @ 160), (N/A, 23), (N/A), NO-OUTDOOR
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

You can find the output of iw phy here: https://pastebin.com/yQdrpVdb

Thanks for correcting me. According to the regulatory rules printed by iw reg get, 160 MHz bandwidth is only allowed in the 5 GHz band if the whole transmission (not just the center frequency) fits into the interval between 5470 and 5725 MHz. This means "channel 100".

I could not find anything in the output of iw phy that would have disallowed the 160 MHz operation.

Please try again, wait 10 minutes again, and provide the whole system log (logread) via the pastebin.

Thank you very much. The funny thing is that the WAX220 (my other Netgear device, also running rc4) is giving me the exatly same output for "iw reg get" but decides to open up a 5GHz WiFi with 160 MHz on channel 36 with automatic channel selection. :thinking:

What exactly do you want me to do before waiting for another 10 minutes? The WAX206 is still on channel 100 and I just checked and it still provides 80 MHz of channel width.

For a good measure, please reboot it with the following settings (AFAIK, these are the same as the current ones): channel 100, bandwidth 160 MHz, mode ax, country DE. Then wait 10 minutes. Then provide the whole system log.

1 Like