OpenWrt 23.05.0-rc1 first release candidate

so it's a release bug, am i understanding this correctly?

Yes, i came across this too. Just run opkg install libubox20230523 and try again.

Yes, I could do that.
On the Fritz!Box 7412 I was using fq_codel with simplest_tbf.qos because that would still get about 60 MBit/s through that thing's two subpar cores instead of anything cake which choked everything down to about 20 MBit/s.

It's was a bit primitive though, as in, it just seemed to balance across all connections.
For example, I had a torrent downloading from 10+ peers horribly starve a regular download on another PC.

I guess I'll stick with piece_of_cake.qos for now and see how it goes. Even at 100% CPU0 load the ping times remain almost as low as with no load at all, and everything feels snappy in daily use.

Yep. Cake is single threaded. And provides nice features. The thing to observe for a system getting busy is watch the idle time (and the IRQ).

Have you tried the packet steering feature checkbox in Luci?

Another thing, when i started playing with OWT ans SQM... and was running a C7 with 1 720mhz core, I found it only able to SQM with cake at 110 -120mbits, not handling my 300/30mbit cable connection. But, I was able to get a lot of benefit from just caking the ingress, which the C7 could handle with ease. Otherwise, it was 115/30. So, that might be an option, if you're not symmetrical

Has been running for 4 days. I've found a fix for the "Maximum number of concurrent DNS queries reached" that't been there on 23,03 as well. I had to set it up as 500 and no errors anymore. The default 150 is too low.

And that's not my public IP. My ISP uses CG-NAT.

adguard home is not working (opkg failed), version is outdated, agh did fixes already, but in branch old version v25, new 27 version is working fine

Yeah! Just encountered the same on 22.03.4, been wondering what is the issue, changed config based on your input, thx!
Btw, should the default setting for dnsmasq be updated? Maybe this is because bad-behaviour of apps in recent years but we need to adapt to the needs somehow...

I am not entirely sure if it's bad behavior or just how things are intended to work. The result is a non-functional connection 'til a reboot of the router, so yeah, the default should be changed.

I have this issue with luci web access:

Unhandled exception during request dispatching
error loading module 'ubus' from file '/usr/lib/lua/':
Error loading shared library No such file or directory (needed by /usr/lib/lua/

In [anonymous function](), file [C]
called from function require ([C])
called from function [anonymous function] (/usr/lib/lua/luci/util.lua:15)
called from function require ([C])
called from function [anonymous function] (/usr/lib/lua/luci/template.lua:4)
called from function require ([C])
called from function [anonymous function] (/usr/lib/lua/luci/ucodebridge.lua:5)
called from function [anonymous function] ([C])
In [anonymous function](), file /usr/share/ucode/luci/runtime.uc, line 133, byte 10:
  called from function [arrow function] (/usr/share/ucode/luci/runtime.uc:141:63)
  called from function render ([C])
  called from function [anonymous function] (/usr/share/ucode/luci/runtime.uc:141:64)
  called from function run_action (/usr/share/ucode/luci/dispatcher.uc:778:34)
  called from function [anonymous function] (/usr/share/ucode/luci/dispatcher.uc:998:48)
  called from anonymous function (/www/cgi-bin/luci:39:12)

 `            die(ex);`
  Near here --------^

After run this:

opkg install luci-app-adblock luci-app-ddns luci-app-upnp luci-app-wol

So one of the above packages breaks luci. I'll see if I can find out which one.

UPDATE: Seems that is luci-app-ddns

this may indicate what is missing, here is the likely solution. give it a try.

1 Like

Yes! Solved! Many many Thanks!

1 Like

Hi there, may I know which UI is this? is the new on the 23.05.0-rc1? the typhography looks different.

It's a custom CSS stylesheet that I apply in the browser.
The font is Google Sans since I use ChromeOS.

thank you looks great!

1 Like

Looks like rc2 is out now.


A note about using new stable releases before they are announced

A few things to know before you try to install new versions prior to the official announcement:

  1. The build system may still be running, and it is a pretty big job. It typically takes several days for everything to complete. The official announcement will come after everything is done.
  2. Because of the fact that the builds take time, you may find that some targets/platforms are ready and others are not. This will almost always resolve with time as the build progresses.
  3. The same is true with user-installable packages -- it may appear that packages are missing, but really they just haven't been built yet.
  4. There is a relatively small chance that a problem will arise during the build process that may cause the build to fail. If this happens, the dev team may need to fix the issue and begin the build process again. Although it is quite unlikely, it is plausible that this could even include a major bug,

For all of these reasons, it is not recommended to install a new version before it is officially announced. And, if you choose to install, just remember that things are potentially still in flux, including packages you might rely on.


Having said that: rc2 runs fine on my 2 RT3200 AP's.

@hauke think it's better to close this to move people on rc2?


Seems standard. Every generation of openwrt on my C7 v2 consumed a liiiitle bit more ram. 17 to 18, 18 to 19, 19 to 21, 21 to 22. Nonetheless, impressive that it all still fits within 128MB of RAM.


rc2 has been released.

1 Like