OpenWrt 23.05.0-rc1 first release candidate

I suspect that it wouldn't work for your case as the script runs after install, so the image might not even install or boot properly (contents bigger than initial partition or whatever). But, if all the packages fit in `/rom', and the extra space in the overlay is needed only after boot, it may work.

I agree with your assessment, the image builder is probably the best way forward.

this new version is support NSS for AX6 yet?

No, and that's not scheduled to happen either, at all - which should not come as a surprise, if you'd be following the topic.

I have the same issue. I installed a snapshot due to problems adding packages to the 23.05 rc-1 image builder and got the lease expired messages. I am using unbound + dnsmasq for DNSSEC and thought it might be related so I have reverted back to 22.03.5. I am using 2 Belkin RT3200's in a mesh configuration.

Tried a local imagebuilder for a Netgear WAX206:

make image PROFILE=netgear_wax206 PACKAGES="luci-ssl mtr tcpdump"
...
Downloading https://downloads.openwrt.org/releases/23.05.0-rc1/packages/aarch64_cortex-a53/base/logd_2022-08-13-4c7b720b-2_aarch64_cortex-a53.ipk
Unknown package 'mtd'.
...
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency libubox20220927 for mtd
 * pkg_hash_fetch_best_installation_candidate: Packages for mtd found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package mtd.
make[2]: *** [Makefile:186: package_install] Error 255
make[1]: *** [Makefile:141: _call_image] Error 2
make: *** [Makefile:259: image] Error 2

If I read read this post right there are ABI-specific packages that aren't ready yet for rc1?

libubox was updated after rc1, so mtd won’t install properly until rc2 is released. Or you can download 23.05-SNAPSHOT and use that until rc2.

2 Likes

Thanks, built and installed snapshot. I'll start configuring and share anything interesting here.

Edit: So far so good. Just one ax/40MHz AP running. I also reduced txpower to 17 dBm since the router is in the same room as me.

I think that in order to use the DFS channel I ended up using I had to explicitly select US as the reg domain.

Radio LEDs are not configured to activate by default, but worked once I added the configuration in luci.

Overall, first impressions are good. If all goes well I plan on this unit replacing the main house router, a R7800, with this one.

Many thanks once again to all the devs!

Confirmed. Installed anew on a WRT32x and manually configured the router. When it came to adding the Guest wifi network back, it brought down the 2Ghz radio. Initially assumed a fault on my side with a view to returning to it later. Interesting this is also your experience.

Otherwise, 23.05.0-rc1 runs well on these units.

1 Like

I used 'Flash new firmware image' to upgrade Raspberry Pi 4B router from 22.03 to 23.05

With https://firmware-selector.openwrt.org/ I selected additional packages:
adblock luci-app-adblock curl libcurl4 kmod-usb-net-rtl8152 kmod-usb-net sqm-scripts luci-app-sqm luci

After update all is running well.

though Linksys WRT tends to be a favorite source of Wifi disappointments, this time it could be a general issue.
Somewhere above in this thread it was claimed that start and stop of Wifi via LuCi does not work in rc1, due to a bug. The mentioned workaround was, to reboot or start/stop WiFi via command line.

(edit) in #65: refering to https://openwrt.org/releases/23.05/notes-23.05.0-rc1#known_issues

Wifi interface start, stop and restart via Luci is working fine here with 23.05-rc1. Just tested for both interfaces: MT7622 b/g/n and MT7915E a/n/ac/ax on my Linksys E8450. So not a general issue.

Thanks, I had hoped that was the case too but sadly not. First re-added the interface then the wireless config and bang, the 2Ghz dropped out. Rebooted, no dice. CLI, no bueno. I may revisit this but will require a quiet window to test further.

initially I wrote down that they are the same as before, but I notice actually more connection issues, especially on tasmota devices,

june 10th,
3 random dropouts


then yesterday 73 (not all in screenshot)

this is the same device, using the same tasmota firmware, hasn't been updated or anything.

and I can make this schreenshot for more devices.

So I think something has chached for ath10k-ct,
but not for the better.

Same boat. Happy I’m not going crazy though, I’ll just wait it out!

My WRT3200 is running well on the latest release candidate.

Adblock with 400,000+ url's and the collectd suite.
I was up over 30 hrs. without a problem, till a squirrel killed himself and the power to the house.
Back up and running strong after the crash shutdown.
Both of the WIFI radios have had no problems using WPA2.
So far so good.

Thanks to the devs!

1 Like

Same here on my WRT32X. 10 day uptime on rc1 so far. SQM pushing 300Mbit cable with ease (perfect +0ms / +0ms results to bufferbloat), Samba 4.18 doing 100MB/s read write on my USB 3.0 external, simple-adblock, advanced-reboot, wifi 5ghz working great, etc.

My only concern is I hope this fix @champtar found makes it into rc2 because removing that hack does seem to fix this issue for me too. edit: looks like they did today :slight_smile:

1 Like

Following the chain of related issues, I landed at Disappearing DHCP Offers & bridge ageing_time and https://github.com/freifunk-berlin/bbb-configs/pull/481/files
Setting ageing_time to a small value on the bridge config might help work around the issue?
(My experiments so far tonight have been inconclusive but promising.)

Actually, the firmware selector's package customization started working for me (Ras Pi 4B) the day after I posted that, so about seven days ago. I've since moved to RC1. If it's still not working for you, that does sound unusual. Assuming you're on a supported device (see release notes), you may want to check again. If it still happens, maybe let the developers know.

R7800 craches
Second OOPS in a view days, ramoops:

Unable to handle kernel NULL pointer dereference at virtual address 0000000c
[33763.436846] pgd = 5a6825a0
[33763.445085] [0000000c] *pgd=00000000
[33763.447604] Internal error: Oops: 17 [#18] SMP ARM
[33763.451338] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet ath10k_pci ath10k_core ath wireguard pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mac80211 libchacha20poly1305 curve25519_neon cfg80211 slhc poly1305_arm nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_syslog nf_defrag_ipv6 nf_defrag_ipv4 libcurve25519_generic libcrc32c crc_ccitt compat chacha_neon ledtrig_usbport ip6_gre ip_gre gre ip6_udp_tunnel udp_tunnel ip6_tunnel tunnel6 ip_tunnel sha512_arm seqiv kpp cmac uas usb_storage leds_gpio xhci_plat_hcd xhci_pci xhci_hcd dwc3 dwc3_qcom ohci_platform ohci_hcd phy_qcom_ipq806x_usb ahci fsl_mph_dr_of ehci_platform ehci_fsl sd_mod ahci_platform libahci_platform libahci libata scsi_mod
[33763.452003]  scsi_common ehci_hcd ramoops reed_solomon pstore gpio_button_hotplug ext4 mbcache jbd2 crc32c_generic
[33763.543014] CPU: 0 PID: 13270 Comm: smbd[10.20.0.14 Not tainted 5.15.114 #0

I confirm, just tested on Linksys EA8300 radio 0 not working at all:
2023-06-20T15:15:15+02:00 OpenWRT netifd: radio0 (18530): Command failed: ubus call hostapd config_add {"iface":"phy0-ap0", "config":"/var/run/hostapd-phy0.conf"} (Invalid argument)

that is with the default configuration for wireless.
Radio 1 and 2 appear to be OK, however I did not have time to run more tests as I had to revert back to 22.03 quickly to restore my WiFi network.

23.05 working fine on EA8500 and WRT 32x so far.

1 Like