OpenWrt 22.03-rc6 "Build" for TV-boxes (rk322x)

i.e. just copy the file to /images and burn it. I don't know how to write it more clearly.

3 steps:

Get the OpenWRT image here:


FLASH IT (Multitool menu)

You are right, thanks. I am new to Linux image burning and i was learning from some videos and they were extracting the content of the file. Thank you again for taking a time to answer my question. Do you know if its possible to configure a Mash network using these TV box?

Good job sir :+1:
Can rebuild with last source ,:thinking:

Well, I can, but it's basically the same. Don't know if it's worth the trouble. What features are you missing ?

22.03.3 is the latest, this one was a 22.03.rc6

Maybe I'll build a new one with latest kernel and latest openwrt build 22.03.2, just in case. Give me a few hours.

I wonder if I should go for a stable or snapshot release. Maybe stable is better suited, but kernel 5.10.xx is a bit old.

1 Like

Sir @Wyk72
Can you share project build openwrt rk3229 on GitHub :thinking:

Last your source still detect undefined network with my windows :thinking:

The box has a fixed IP and no dhcp server enables, as I stated in the first port it's like a Raspberry PI2.

To reach its web interface you have to add a static ip to your machine in the range

You can of course activate dhcp server in the LAN section of OWRT.

Wifi is disabled as is working so badly I decided to disable it.

1 Like

@Wyk72 how to set WiFi On :thinking:
Thanks :pray:

le puedes extraer la SD card, multitool lo graba en la memoria interna. Pero te recomiendo hacer un backup antes de flashear, para volver al estado previo al flash si hay problemas.

Great work, no doubt that Android Boxes are much more cheaper than the cheapest router with USB and it has a lot more RAM, so for USB appliances (file server with external disk drive, bluetooth, and so on) is better choice than a router. I didnt test it yet, but I test ARMBian in a cheap 23 $ X88 pro 10 android box and it works like charm. It would be nice have a standard OpenWRT for those boxs.

1 Like

I think the key to understand these prices is: These devices are sold more massively than routers, and the cheapest models are hard to sell because people doesnt want it, people often wants android box with netflix drm support and so on, i.e: middle price devices.

These devices have usb 2.0 and even usb 3.0 ports, so in the case of connectivity problems (e.g: if you want a external wifi antenna) you can plug wifi usb, ethernet usb, usb hub, and so on. And even in that case, it would be cheaper and more powerful than same price routers.

Hi. I was able to flash it in my box.
but when I reboot, its only show blackscreen with blinking cursor on top left.
what should I do?

@Wyk72 is it a good idea to install armbian and then openwrt in a virtual environment like docker to get maximum advantage of these boxes or there are good reasons just to stick with openwrt?

I installed armbian on my rk3229 Box with legacy kernel 4.19.x because it was possible to use NAND of the box and also wifi sv6052 works with around 35 Mbit/s up and down. USB3.0 Gigabit Ethernet Adapter reaches around 270 Mbit/s and I can use it around this numbers as wireguard headend.

Could you please explain how to set up the vlan configuration and does this make sense with 100Mbit/s bottle neck?

Edit: I forgot to say... Great and awesome work! I wished already a long time that someone is able to port openwrt for these devices! Many thanks

@Wyk72 I installed it according to the instructions , but when i reboot and plug lan into my pc and set ip to . I tried to access but it not woking :frowning: . Pls help me fix it :frowning:

Hai @Wyk32. I'm really appreciate with this openwrt project you did for MXQ Pro device. I already follow your tutorial to install openwrt.gz to my device and its fully worked. However, i need to turn on the wi-fi because i really need it. My device was use RTL8189FS wifi-chips modules. I tried the command in forum which is tutorial how to enable the wi-fi, but somehow it was not work for me. This is what i type before :
echo rtl8189fs > /etc/modules.d/rtl8189fs

When i hit enter, the wi-fi still disabled. Can you tell me any ways to enable the wi-fi? Thanks before :pray:

You have to check if the module (.ko file) is present in the rootfs.

Can you please send the output of the command "cat /proc/cmdline" ? I don't remember if I disabled the whole wifi stack or just the internal wifi.

Attach an HDMI monitor and check the console at the box, if it boots properly than something else is wrong.

Well, running into LXC is another option. I don't know about performance.

I made some interesting tests about VLAN: it's generating way too much interrupts for such a limited hardware platform. So my inital "solution" was getting poor performance.

It's always better to use a simple USB network card for adding physical interfaces.

I try to use uart port and i saw , it don't boot . No signal and it only have led red .

After checking .ko file, i realize that realtek chipset wi-fi modules especially rtl8189fs have a bunch of problem compatibility with openwrt. I tried searching is that anyone success make a kmod for this wifi-chips, but it seems like no one can do it until now. Btw, this is output of "cat /proc/cmdline" of my devices :
root=PARTUUID=00628e24-02 init=/sbin/init rootwait console=ttyS2,115200 verbose=0 consoleblank=0

Hello sir i need help

After this and my rk3229 will be reboot
How to solve this, thanks