OpenWrt 22.03.2 second service release

I have seen several recommendations in recent months for enabling packet steering on WRT3200 (or is it more specifically mvebu in general?), but I have not yet tried enabling it yet.

My WRT3200ACM has been outperforming all of my expectations on 22.03.2 so much so that I am cautious lately about changing any settings. I am happier now with my WRT3200 than ever before.

Does enabling packet steering benefit wired connections specifically or is there also some benefit for wireless connections as well?

1 Like

In general I've just always enabled packet steering based on the discusison from the upstream Linux (Google wrote it I think) commit here: []

Mvebu has performance issues with 5.10 kernel where the switch is sorta acting like a hub, it badly needs 5.15 for the apparent bug fix. Nevertheless it's still fast and stable on 22.03.

Other considerations: if you have gigabit internet for our target also enable Software Flow Offloading under firewall. However, if you want to run SQM it'll handle 500Mbit or so no problem, I use SQM Cake on my 300Mbit cable modem for +0ms ul/dl latency with plenty of CPU left over for Adblock, Samba, etc. If you run SQM, don't enable SW flow offloading, they are incompatible features. For gigabit + SQM you would need something newer like a NanoPi R4S.

This is all discussed on the wikis too.


Just updated my Archer C7 V2.
It works fine, but still the WAN LED is missing.

Flashed on Netgaer EX3700 (ramips/mt7620).
I had to go back, because some clients have had WLAN connection problems (very slow connection, and timeouts) after upgrade.

The regression fix to firewall4 now works great for the loadfile command. My device boots correctly.

opkg update
opkg upgrade firewall4

Took me a while to upgrade, but on my Fritzbox 4040 I jumped from 22.03.0 to .2 using AUC (been doing that since 21.07.2) then I ran the commands above to update firewall4:

 * check_data_file_clashes: Package firewall4 wants to install file /etc/hotplug.d/iface/20-firewall
        But that file is already provided by package  * firewall
 * check_data_file_clashes: Package firewall4 wants to install file /etc/init.d/firewall
        But that file is already provided by package  * firewall
 * check_data_file_clashes: Package firewall4 wants to install file /sbin/fw3
        But that file is already provided by package  * firewall

I thought firewall4 was now the default...was it because of AUC?
How do I make the switch to fw4? Should I roll a new image? In that case, which packages should I omit, in addition to "firewall" itself? I have the list of firewall4 dependencies, that shouldn't be a problem.

Thanks, forcing installation isn't really a solution, rolling a new image with the right packages could be... I guess I'll have to work out a diff and get a custom image via AUC. The dedicated post is very old, I've seen it already.

bug: there seems to be an issue of the DHCP service crashing occasionally.
Milage may vary, how often you will experience the issue. In case you notice devices no longer reconnecting:

sec issue: Not may people use ksmbd, but if you use it, ksmbd has a security issue, which is fixed in newer kernel versions:

HI Pico
also wsdd2 has been broken for all of v21,v22 and still is
when a ipv6 address gets renewed & it cascades down to lan
it triggers an update
wsdd2 then starts updating the list of IP's
but from what it looks like the amount of interfaces for lan comes back with I bad valve
and is seem to keep adding interfaces passed the amount that's there until it crashes out

you can fix this by changeling a line in the file "/etc/init.d/wsdd2"
line 56
change from
network_get_device ifname lan
network_get_device ifname br-lan

this is more a workaround but at lest br-lan reports the correct amount of interfaces

Passing br-lan should always report zero interfaces since „br-lan“ is no valid logical interface identifier. The change inadvertently disabled that interface query feature instead of fixing it. Will prevent any buildup too, though.

I'm not sure that lan is even valid any more tho
do a ifconfig & there is nothing called lan only br-lan
and if you try to start wsdd2
wsdd2 -i lan -N OPENWRT -G WORKGROUP -W
the error is Bad interface 'lan'
but wsdd2 -i br-lan -N OPENWRT -G WORKGROUP -W
work until ddns triggers an update
then if you don't change that line to br-lan it stops,crashes or fills the terminal with garbage
but it yo do change it it all works like nothing is wrong

The network_get_device procedure expects a logical network name (name of a config interface … section in /e/c/network) - compare with ifstatus lan. The procedure should put the resolved device (commonly br-lan) into the variable $ifname.

so changing it to br-lan is removing the interface switch
defaulting it to all interfaces witch is why it works.
that's fine on an access point but not good for a wan interface
it's still something to do with the interface number
you can see the number it change when it breaks

1 Like

Other default services (uhttpd, dnsmasq, …) listen on the wildcard interface as well and rely on firewalling for wan, I think wsdd2 should do the same.

In any case it should not be hardcoding „lan“ into the init script. Some installations might not call their lan „lan“ or have multiple downstream interfaces they wish to serve wsdd2 on.

So removing the ifname binding completely is probably the right solution after all.


Just flashed an old Ubiquiti EdgeRouter X from the factory v2.0.9 firmware to 22.03.2 using the factory image (WebUI) -> sysupgrade method without any major issues. Running rock-solid so far.

I ran OpenWrt on an ER-X used as our home network gateway for a few years and found it to be a solid improvement over stock EdgeOS. I think you'll be glad you made the change.

The only reason I'm not still using the ER-X in this role is its MT7621 CPU could not keep up with SQM after our ISP speed increased to 500 Mbps - no fault of OpenWrt. Now I'm running OpenWrt on a NanoPi R4S for our home gateway. The R4S CPU is embarrassingly underutilized :grinning:.

1 Like

if I remember correctly, there is support for hardware flow offloading on that SOC

so you can give enabling that a try (SQM must be disabled)

There is. I did experiment with hardware offloading on the ER-X with OpenWrt and it worked. The ER-X will handle Gigabit with hardware offloading, but as you noted, that requires giving up SQM.

I want to keep SQM QoS enabled on my gateway. My 500 Mbps service is with a DOCSIS 3.0 cable modem. It does not even have PIE QoS like DOCSIS 3.1.

I finally got around to upgrading my "core" EA8500, more than two months after upgrading my ea8300 satelites. I'd been putting it off due to the perceived risk of having to install the factory image to update the partition layout. I finally decided to get it over with. It took less than 10m, including the added reboot to restore my configuration.

I got an issue with the latest version. the memory usage is too high even though it is just set as an Access Point.

the biggest memory consumption according to the process page is the hostpad

Have you read the 8/64 warning?

Current OpenWrt versions, with new kernels and newer wifi drivers and newer packages and ... consume a bit more RAM and flash, so that older devices slowly get unusable.

You device is resource constrained regarding both RAM and flash.