OpenWrt 22.03.0-rc6 sixth release candidate

I don't know.

Well, I understand, but let's give this -rc a bit of real-world testing :slight_smile: and yes I have warned that friend about the -rc.

1 Like

is it just for me or did Devs remove custom rules from firewall settings?

There is a different custom include method with the switch to firewall4/nftables. No more firewall.user support.

1 Like

After RC4 my Pi4 goes very bad with any other updates including RC6, frequent disconnection that is only solved after reboot, problems installing Kmod Asix driver for the Tplink usb ethernet, between others.

I suggest if some of you could please test the Raspberry pi4 on the latest releases because its unusable for me. I also think that the driver for the USB should come on the default RP4 image, every time having to compile it with it is annoying.

Thanks in advance.

The issue with the driver is known but not solved as of yet.

It's unlikely to ever be included by default, because there is no standard for what particular USB dongle (or more specifically, chipset) any given end user happens to have/use. Many don't use one at all and VLAN the single port.


Cool thanks for letting me know, fingers crossed!

I've had this problem for a while now with images created with the image builder. I added the whole configuration to the image, so I expected it to grab all new blocklists immediately.
However, when booting adblock complains that it cannot resolve the hostnames of the adblock lists. It is probably started before the networking services could be initialized.

To fix this I added a supervisor cron job next to the daily update. Whenever adblock ends up in the error state I can simply restart it to make it work again.
This is what my scheduled tasks for adblock look like:

* * * * * ([[ "$(/etc/init.d/adblock status | grep adblock_status)" == "*error" ]] && /etc/init.d/adblock restart) || true
30 04 * * * /etc/init.d/adblock reload

A sane default for updating and supervising would be a nice addition I guess.

My Pi4 has been rock solid on RC5 and RC6. I’m using a Tplink UE300 usb to Ethernet adapter. The drivers are kmod-usb-net-rtl8152.

1 Like

The rolling driver crash happens with Asix chipsets only.

1 Like

There is a bug in miniupnpd that results in no ports being forwarded.
The patch here solved my problem:

But, the Luci UI does not show any active redirects (despite verifying it now works). I found the Luci issue here:

Feels like this should work properly in a final release given how many people with game consoles rely on it.


watchcat broken for ping mode when not specifying address family (regression from 21.02.3), PR with fix is awaiting review:
workaround until this is fixed: specify the ping address family in the watchcat configuration

1 Like

Hi all.
Running 22.03.0 rc6 on these devices with various configs (router, repeater).

  • Linksys MR8300 (ipq40xx generic)
  • Netgear R6220 (mt7621)

Thank you to anyone involved in the development, and let's hope the final is near.


Happily running rc6 on old RPi3

Using a USB to ethernet adapter with it and no issues at all , after I swapped AX88179 for AX88772C adapter

Great job to all in development.

I've already made a small donation

AX88179 ? I reported issues a few posts above yours.

And see this:

Xiaomi AC2350 running very smoothly. No problems so far. Haven't been near the firewall side at all yet.

1 Like

Hi dears,
22.03 rc6 on Archer C7 v4:
After a few days of non-stop using I had to power off and on the router. When it turned on refused to dynamically assign IP address.
Before turning off, I had disabled odhcpd and removed odhcp6c and odhcpv6only to get rid of some errors regarding "odhcp error ip V6 network unreachable". In fact I am only using IP V4. So I enabled odhcp and restarted it then rebooted the router and controlled if it is running. Odhcp was running. Finally I tried to connect to the router via dhcp but failed. Now, I am using static ip to connect to the router.

Any idea?
Thanks in advance for your help.


What is the option DHCP - IP Sets exactly for? I wasn't able to find anything helpful about that very topic.

1 Like

Confirming same results for me.
Using 22.03.0 rc6 on Linksys MR8300 (Dallas) without issues. Using "standard" build from the download page.
Side note - had to increase the DTIM value due to issues with Apple iPhone hardware (this seems to be a "known" issue with Apple devices)

Smooth and stable. Less memory usage (more efficient). Hardware: Totolink X5000R
Package removed: dnsmasq, odhcpd-ipv6only
Package installed: unbound, wireguard-tools, privoxy, adblock, watchcat.

Thanks to all the developer of OpenWrt on earth.