OpenWrt 22.03.0-rc4 simple-adblock 1.8.8-1

Blocking XXXXXX domains (with dnsmasq)

ping blockedsite return bytes=32 time=32ms TTL=56

I've forced DNS and tryed about every bell and whistle in the config

nothing blocks anything.


after rebooting resetting reinstalling the package and trying to make this work again.

after a few hours I prob wasted 2 hours now. I was able to get it to semi function. (still bad)

It's still very buggy. but I've had to change and update settings multi able times for it to stick.

current working cfg below.

config simple-adblock 'config'
	option enabled '1'
	option config_update_enabled '1'
	option config_update_url ''
	option led 'none'
	option verbosity '0'
	option force_dns '1'
	option boot_delay '3'
	option download_timeout '6'
	option curl_retry '9'
	option parallel_downloads '1'
	option compressed_cache '1'
	option debug '0'
	option dns 'dnsmasq.addnhosts'

Even with this config it sometimes does not work. (esp after a reboot)
I get lots of errors here are just a few I was able to write down.

ERROR: failed to parse Config Update file!
Tue Jun 28 20:25:23 2022 user.notice simple-adblock [6599]: ERROR: failed to process allow-list!

If I was to reboot right now the config would break and I'd have to play with it for another few hours again, this has happened about 5, F.I.V.E. yes five times today, yes even after reinstalling with default sets.

This henders me to not restart luci anymore. too much a headache.

huge thing to note here also is wild card prefix *.

i use to be able to block for instance

by just adding "" as it would not matter if it had www. or m. or

now it seems I have to add the " www. " prefix in to all my host blocks.

I can block but still will work.
This was not like this before if I added a domain like it would be blocked reguardless of subdomains but now no. and this leads to pretty much all of my host blocks not working.

even if I add *. it still does not work.

I have to double my whole block list with www. now.

and I don't want to reboot and spend another 3 hours doing this.

so this is still unresolved and borked.

Are you asking a question?

@LEGION I thank you for commenting on your simple-adblock problem, but I had trouble following what you're saying, or what you would like others to do.

Could I ask you to re-frame the situation with:

  • What version of OpenWrt you're using? (probably 22.03.0-rc4)
  • When was the last time it worked as you expected (what OpenWrt version)?
  • What change did you see? (I think you're saying used to block *, but now it isn't doing that.)
  • Are there any other symptoms?
  • Do you have a backup from before upgrading to -rc4 that you can use to compare configs? Have you compared the old and new files?
  • Finally, what question(s) would you like Forum readers to answer?

Putting this information into a single message will make it much easier for readers to understand the situation and the changes/problems you're seeing. Many thanks.



Same thing happened here. I think the steps by the OP are clear to reproduce the problem...
Just pick a config file that worked in 21.02 and upgrade to 22.03, simple-adblock just no longer works. He gave examples...

Besides the daemon not starting sometimes, most noticeable cases are the ones where just you could just place to block things like but now it doesn't work.

TL;DR: bugs are confirmed, or the app underwent massive changes that don't seem to be documented, if anyone is willing to help, please do. Thanks.

@LEGION I installed luci-app-simple-adblock and in advanced configuration I changed the DNS service from "DNSMasq Servers File" to "DNSMasq Config" and I seem to have got back most of the functionality, e.g. now blocks but also Additionally, I think that by saving it from the luci web app it might have fixed some other stuff, but what definitely did the trick for me was changing the "DNS service" option. Maybe this will help in your case too?

Best regards


I'm currently using dnsmasq.addnhosts Config with no issues.