OpenWrt 22.03.0-rc4 fourth release candidate

The MAC1200R v1 has only 8MB flash and 64MB memory (8/64). See 864_warning.

Users that are not expert users of OpenWrt (those that can build their own images) should consider 16/64 as an absolute minimum for any device, with at least 128 MB of RAM being preferred.

Unfortunately, 19.07 appears to be the last stable release supporting this device and 19.07 was also the last stable release to support the ar71xx target. The MAC1200R v1 was not migrated from the ar71xx target to the ath79 target as of the 21.02 stable release.

1 Like

Hi there.
Successfully installed 22.03.0-rc4 on these devices, with various configs (router, mesh, AP)

  • x86-64 miniPC
  • Linksys MR8300 (ipq4019 generic)
  • Netgear R6220 (mt7621)
  • Netgear 3700v2 (ath79 generic). I have several of these as low-end APs. I have tested 22.03.0-rc4 on one, but I will reverse it back to 21.02 because it has a lower memory print.

Thank you to every devs and contributors.

1 Like

I successfully upgraded to 22.03.0-rc4 on these devices:

  • rpi-4-ext4 router which was previously on 22.03.0-rc1 using luci-app-attendedsysupgrade
  • eap615-wall access point which was previously on 22.03.0-rc3 using manual flash of sysupgrade.bin

Many thanks to all who contributed!

Is flow offloading fixed? Like for realsies? Can someone who previously had problems (ipv6 sites like google and facebook simply stop responding in a few minutes + general non-responsiveness) please test and post?

I've been waiting for flow offload to be fixed for over a year now, and want to upgrade only for that.

I use TP-Link AC1750 (Archer A7=C7 v5) in a fairly vanilla (internet->wifi/lan, guest radio) configuration. The only weird thing I have is ddns and vnstat. Those have previously worked seamlessly with sysupgrade (I had problems with the regular firmware upgrade before starting to use sysupgrade like the router stopped responding, and obviously I have to redownload and redo the config for the "non-standard" packages like ddns).

I also have a question - if I upgrade via sysupgrade to rc4, keeping configuration, is it likely to work seamlessly, and then also from rc4 to the release version? I read about problems with configs not working with migration to rc3 (?). I know nothing is ever "guaranteed" because open source, large team, etc. but still - has anyone tried and did it work for rc4?


1 Like

re: sysupgrade, it's more important what the delta is between what you're coming from and moving to. If your current setup is pre-DSA, you'll probably want to strongly consider manually setting everything up from scratch versus just a straight config-preservation upgrade. If you're already on RC1, for example, it's a very direct migration to RC4 (and final).

Used the imagebuilder to add all my packages and configs.

From 22.03.0-rc1 to 22.03.0-rc4 on a raspberry pi 4b

|Model|Raspberry Pi 4 Model B Rev 1.2|
|Architecture|ARMv8 Processor rev 3|
|Target Platform|bcm27xx/bcm2711|
|Firmware Version|OpenWrt 22.03.0-rc4 r19426-2b1941e47d / LuCI openwrt-22.03 branch git-22.140.66268-ef99568|
|Kernel Version|5.10.120|

Firewall warning:

mwan3 and vpn policy routing, seems to be still on iptables.

@feckert topic tells me it should work. (It does but complains about the use of iptables)

Installed iptables-nft, now the warning is only for vpn policy routing, mwan3 is now gone from the iptable list.

Made my image again, with only the extra packages, somehow iptables-legacy showed op in my config.This is now gone.Only FW4 is in my image. But still it tells me that mwan3 and vpr is using iptables.

It seems when I make an interface for a bridge with a VLAN - it doesn't work without editing the /etc/config/network file. I discovered this on a devices used as managed switch/AP - the config allows for WiFi.

:white_check_mark: Works:

config interface 'guest'        
        option proto 'none'    
        option device 'br-guest'

:x: Doesn't work (made by LuCI):

config interface 'guest'        
        option proto 'none'    
        option device 'br-guest'  
        option type 'bridge' #<---------

Western Digital N750:

  • Browsing to Status > Channel Analysis causes 5.4 GHz WiFi to enter disabled state (did not have a 2.4 GHz client to test)
  • Rebooting fixes the issue

Log when attempting to restart on LuCI:

Wed Jun 15 19:28:00 2022 daemon.notice netifd: radio1 (1928): Command failed: Request timed out
Wed Jun 15 19:28:00 2022 daemon.notice netifd: radio1 (1928): Command failed: Not found
Wed Jun 15 19:28:00 2022 daemon.notice netifd: radio1 (1928): Device setup failed: HOSTAPD_START_FAILED
Wed Jun 15 19:28:00 2022 daemon.notice netifd: Wireless device 'radio1' set retry=0
Wed Jun 15 19:28:00 2022 daemon.crit netifd: Wireless device 'radio1' setup failed, retry=0

EDIT: I cannot reproduce the issue again.

Tried it on one of my BT hub5a. Seems to have the boot issue quite bad on the router I tried it on. Sometimes it boots successfully, occasionally it appears to hang with the LEDs off and appears dead, but mostly seems to repeatedly boot. I've not got serial connections soldered on to check the console.

Please open a bug report and provide clear steps to reproduce, otherwise I won't get fixed until final.

  • A VLAN must noted in config with a MAC for it to boot online, it seems RC4 does this by default for LAN and WAN


config device
        option name 'eth0.x'
        option macaddr 'xx:xx:xx:xx:xx:xx'
  • I'm having some wireless issues...but I can't tell if this was related to the MAC/VLAN/bridge issue

GitHub..I assume.....
(FYI, can people make an account form here...because...think we're gonna loose people's bugs on this...)

I wasn't sure what "package" to note.

Shouldn't it be filed under openwrt repo instead of packages?

Well someone who know's how - please fix. Thanks.


well, if it's a LuCI issue than LuCI issues.'ll live. Smh...

(someone fix that too - thanks - I guessed that much, and now I have two posts I made a wrong bug

and TBH, the UCI config works when I it must be a LuCI package....I assumed. :man_shrugging:

Any Archer C7 v2 users try this RC yet?

Have some strange issue with NAT on the TOTOLINK X5000R
I have two different subnets on the router.
The one is just br-lan with static IP and gateway, it's linked with some wireless networks, there is no DHCP and no NAT.
The second network is connected to WAN and the WLAN NETWORK, WLAN is using "unspecified device" network for NAT, there are static IP on this network and DHCP enabled. This configuration works on the 21 versions and not working on the 22.x.
The problem is that in second subnet, clients are successfully connected to wireless network, getting IP, but can not connect to WAN, no internet, NAT is broken. I have tried clean install, tried all options, no luck. Any thoughts?

Thanks you very much