OpenWrt 22.03.0 first stable release

What's the safest way to upgrade from 22.03 rc4 to 22.03.0 and get it to work, on Linksys E8450?

I've tried upgrading 3 times, and all ended up in failure.
I'm currently using iptables, and I have miniupnp, watchcat, ddns, dnscrypt-proxy and sqm installed.
After upgrading, miniupnp doesn't work, and I can't ping from my computer connected to the router.

After upgrading to 22.03 (clean install with manual reconfiguration since it was a device that recently switched to DSA) on my Bt Homehub 5a i've encountered problems while using usb flash drives with luks/lvm and f2fs/ext4 filesystems. I've opened a thread here that describes my problem in details.

So many issues with 22.03.0 :frowning:
It should not called stable anymore, imho

Iĺl stay definitely on 21.02.3, at least til 22.03.1

22.03 has been flawless for me on my WRT32X, loaded up with lots of packages running. 24 day uptime since the day of release.

There are a few bugs yes, many have been fixed (e.g. upnp which I don't use anyway) and are well documented for next update.

6 Likes

Wifi is not working at 5Ghz on firmware 22.03.0 on TP-Link C20 V4, connects but does not work internet. I downgraded to version 21.02.3 and it worked again.

Hi
Successfully installed on

  • Linksys EA7300v2 (mt7621) factory flashed from Linksys GUI.
  • Netgear 3700v4 (ath79 nand) sysupgraded from 21.02.3 and keeping settings. You can't install much packages in this case, there is a 8MB limit file size.

Hi, how did you go about upgrading the router and where was image obtained from?

According to https://downloads.openwrt.org/releases/22.03.0/packages/aarch64_cortex-a53/packages/

The package is supported for Linksys E8450

Is the router working correctly without miniupnpd?

Try restarting the firewall please and making sure the lan and wan are correctly assigned.

Where you by chance using the UBI installer?

https://github.com/dangowrt/owrt-ubi-installer

Someone else was having image issues related to the filename.

https://github.com/dangowrt/owrt-ubi-installer/issues/116

Someone has stated a possible solution to this issue

I've retried with my device, went all the way back to stock firmware 1.00, did the two automatic updates on the way to 1.2.00.273012. When ahead and downloaded the installer file from github, uploaded to router and all works.

I upgrade using System -> Backup/Flash firmware and pressing flash image button.
The image was downloaded from https://downloads.openwrt.org/

Yes, I'm aware.

No, it wasn't.

No, I wasn't. See above.

That's standard. If you're doing custom builds, include luci in your package selection.

I want to use adguard home in openwrt22

In openwrt21, I only need to add custom settings to the firewall. The code is as follows:

iptables -t nat -A PREROUTING -i br-lan -p udp --dport 53 -j DNAT --to 192.168.1.1:5353
iptables -t nat -A PREROUTING -i br-lan -p tcp --dport 53 -j DNAT --to 192.168.1.1:5353

Now openwrt22.03 uses firewall4, how to add rules,
According to the instructions here, https://openwrt.org/docs/guide-user/services/dns/adguard-home , I use ssh to connect to the router, execute the following code,

nft add rule nat pre udp dport 53 ip saddr 192.168.1.0/24 dnat 192.168.1.1:53

But the line to the prompt: Error: Could not process rule: No such file or directory
Need to manually create a configuration file? Does anyone know what is the filename and location?

The only plugin I use in openwrt22 is adguard home, which I really want to use.

An alternative ad-blocking option is here incase you want to take a look:

Thank you for your reply, But English is not my first language. The Chinese results I found were all about openwrt21. Most of the English results I found were knowledge tutorials, not directly telling me how to execute the code to use adguard home normally. At present, I can't find how to set up to use adguard home normally. I need two functions of this plugin, dns parsing and ad filtering, so I don't want to deprecate this plugin.

Since 22.03 on r7800: Periodically - about every third day, Device is "down". Interfaces seem to be down, device is not accessible. Remote Logs are without any suspicious info. Weird.
Now, I have a script running that restarts the device every night.
Sad but true.

@moderators

This maybe considered a cross post yet the more eyes on this spreads word of mouth.

3 Likes

There's still a package in need of update to remove the dependency on the older package:

Package: px5g-wolfssl
Version: 4
Depends: libc, libwolfssl5.4.0.ee39414e

(which is, in turn, needed by luci-ssl)

What type of problems did you experience prior to disabling tx_amsdu? I'm asking as I am using a WRT1900AC v2 which uses 88W8864. I'm wondering if the tx_amsdu issue is something that will definitely occur or if I will get a performce increase by leaving it enabled.

Going back to the Issue discussed 4 years ago, disabling amsdu on mwlwifi driver devices with 88W8864 (wrt1200 and wrt1900) may reduce latency on 5GHz, but in doing so you will lose some throughput. It's never been reported to affect anything else other than that:

[https://github.com/kaloz/mwlwifi/issues/313]

1 Like

Am I correct that the same applies to 2.4 GHz?

Probably, but since the wifi firmware is close source and no one with a wrt1200 or wrt1900 ever posted any throughput and latency tests that I've seen, it's unknown. If you get better speedtest results post about it on one of the mvebu custom fw threads. I'll add that to the wiki, since I added a lot of this info to the wiki already.

This topic somehow comes up with every new release, along with the misconception that wrt3200acm and wrt32x are somehow affected when that's never been demonstrated either. I use a wrt32x and definitely never disabled amsdu.

1 Like