OpenWrt 21.02 x86_64 no internet on phones

Good day everyone! There is a problem after installing this release. The Internet via Wifi works for everyone (laptop, computer), except for telephones - they receive the addresses, but they do not go online! There were no problems at 19.07.

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd52:cc0a:6ce0::/48'

config interface 'lan'
	option type 'bridge'
	option igmp_snooping '1'
	option ifname 'eth1 eth2'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.254'
	option delegate '0'

config interface 'wan'
	option ifname 'eth0'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'static'
	option ipaddr '10.99.0.20'
	option netmask '255.255.255.248'
	option gateway '10.99.0.17'
	option dns '95.167.167.95 95.167.167.96 8.8.8.8'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:02.1/0000:01:00.0'
	option htmode 'VHT80'
	option channel '48'
	option country 'US'
	option txpower '20'
	option legacy_rates '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:02.5/0000:05:00.0'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'DSSS_CCK-40'
	option txpower '20'
	option noscan '1'
	option htmode 'HT40'
	option hwmode '11g'
	option channel 'auto'
	option country 'US'
	option legacy_rates '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Cisco_AC'
	option network 'lan'
	option encryption 'psk2'
	option key '*(tucson2005'
	option macfilter 'deny'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Cisco_24'
	option encryption 'psk2'
	option network 'lan'
	option key '*(tucson2005'
	option macfilter 'deny'

This doesn't look right. Did you try to bridge the ports?

Already bridged. PC with WiFi works fine

This is old, old config syntax. Stuff like option _orig_ifname and ht_capab was obsolete after version 17. I would suggest reset to defaults and reconfigure from scratch to get rid of that cruft and bring the syntax up to version 21 which changed several things.

You're running a DFS channel on 5 and HT40 on 2 GHz, some clients may not operate with those. Also there's macfilter deny with no MAC list?

1 Like

I was noticing this, too. I'm not sure if it matters or not given that it correlates to "allow all except listed" (so the net effect is that it will allow all anyway), but it is possible that it doesn't like an empty list. It would probably be better to simply disable the MAC filter).

What is in your DHCP file?

1 Like

Hmmm... Maybe. Thanks! I'll check it at evening.

Sorry, forgot to copy - at work now :frowning:

But why the PC with WiFi working well?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.