OpenWrt 21.02.4 fourth service release

Hello.. I would like to inform that the package for curl and libcurl4 is still using the broken version 7.83.1-2.1 (due to the security update for wolfssl) on majority of architecture builds. See links below for mipsel_24kc.

https://downloads.openwrt.org/releases/21.02.4/packages/mipsel_24kc/packages/libcurl4_7.83.1-2.1_mipsel_24kc.ipk
https://downloads.openwrt.org/releases/21.02.4/packages/mipsel_24kc/packages/curl_7.83.1-2.1_mipsel_24kc.ipk

With those versions, curl won't work for HTTPS/SSL URLs. So in short, updating via AUC or downloading the update firmware breaks curl capability to open HTTPS links.

I've actually posted this here: Mipsel_24kc release (21.02.3 and 21.02.4) doesn't have the updated curl and libcurl4

2 Likes