OpenWrt 21.02.3 Fritzbox 4040 with USB-Dongle

Hi,
I have a question for the configuration.

My Router is function, but I can not do Updates for Openwrt and I can´t login to Openwrt.

I just can login , when I put out the USB-Dongle, than I get login to the IP 192.168.1.1, but then I have no conection more!

My Router has the static IP 192.168.1.1 (br-lan)
My Huawei Stick has IP 192.168.8.1 (is managed DHCP).

When I conect by LAN with my Laptop or my raspi there is no Problem, both get connection to the internet.

Which configuration I have to do, that I can go to the internet, an posible to login and get updates.

Thanks
vorjak

did you by any chance put the Huawei stick interface in the lan firewall zone?

It can be. Do I have to change this setting under firewall in br-lan? so take it out?

Yes, change it, by moving it to wan.

That's my configuration.
I have now under br-lan only lan, but there is no change. And for WAN I have the eth0 (huawei-stick).


Where is the wrong configuration?
Thanks

WAN still doesn't appear to be in the wan firewall zone.

I have WAN to configurat? What is the resolution?
Put WAN into the Firewall.
Thanks

It is not stick, it is hi-link. Have you installed additional packages?

Yes I installed two packets usb-modeswitch and kmod-usb-net-cdc-ether.
My Problem is to get login. I hope I have only some configurations at the networks.

Give output of ip a s before, and after plugging modem.

The first log is the one with the Huawei stick (dongle)
The second is without a dongle and restarting the router.

1. With huawei-stick

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s10: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:23:32:b7:a7:6a brd ff:ff:ff:ff:ff:ff
    inet 192.168.8.102/24 brd 192.168.8.255 scope global dynamic noprefixroute enp0s10
       valid_lft 86279sec preferred_lft 86279sec
    inet6 fde5:cfa5:4e4c::f02/128 scope global dynamic noprefixroute 
       valid_lft 43081sec preferred_lft 43081sec
    inet6 fde5:cfa5:4e4c:0:26d5:45e5:f8:1cba/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::a486:f04d:43d9:3de2/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wls3: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state DORMANT group default qlen 1000
    link/ether 00:23:6c:7f:31:b2 brd ff:ff:ff:ff:ff:ff
4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 02:42:f7:67:37:02 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
       valid_lft forever preferred_lft forever

2. Without huwei-stick

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s10: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:23:32:b7:a7:6a brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.241/24 brd 192.168.1.255 scope global dynamic noprefixroute enp0s10
       valid_lft 43089sec preferred_lft 43089sec
    inet6 fde5:cfa5:4e4c::f02/128 scope global dynamic noprefixroute 
       valid_lft 43090sec preferred_lft 43090sec
    inet6 fde5:cfa5:4e4c:0:26d5:45e5:f8:1cba/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::a486:f04d:43d9:3de2/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wls3: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state DORMANT group default qlen 1000
    link/ether 00:23:6c:7f:31:b2 brd ff:ff:ff:ff:ff:ff
4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 02:42:f7:67:37:02 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
       valid_lft forever preferred_lft forever

Is the WAN configuration wrong with DHCP? But most things work, if the router was reachable I could test the updates for openwrt and everything would be great!

Can anyone help me further?

Please describe me, what I have to do.
I have to configure the firewall option and put WAN to it, or have I edit de WAN profil?

Thank you

Have you already looked in the firewall einstellungen tab, for the WAN interface ?

Hi, I look for the firewall configuration.


What have I to configurate?

  • the first line in the zones or

  • the second part called "wan"?

I the next step I can edit the covered networks under generel settings or Allow forward to destination / Allow forward from source zones??
At the advanced setting I can configure Covered devices by select br-lan and eth0=(wan).

thanks

You're not where you're supposed to be...

Hi,
when frollic wrote

i'm sure he meant you should look at "Netzwerkschnittstellen >> WAN -> Firewall Einstellungen".

1 Like

I looked for the configuration firewall.


I've tried a few things but nothing works. The problem is definitely with the firewall.
Which settings are correct?
I have attached an image.

If I understood it correctly, no firewall authorization for WAN should be assigned. But that didn't bring any change.
I still can't access the router when the dongle is plugged in.

When you look at the upper right picture, you'll see that the entry under "Firewallzone anlegen" is "unspezifiziert". I think, there should be something selected like "WAN" and "WAN6".
I'm not sure, because i've neither got a USB-dongle nor do i know which interfaces are represented by WAN, WWAN and WAN6.