Openwrt 21.02.3 can't save changes after reboot (Xiaomi Mi Router 3 Pro)

root@OpenWrt:/# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00040000 00020000 "Bootloader"
mtd1: 00040000 00020000 "Config"
mtd2: 00040000 00020000 "Bdata"
mtd3: 00040000 00020000 "factory"
mtd4: 00040000 00020000 "crash"
mtd5: 00080000 00020000 "crash_syslog"
mtd6: 00040000 00020000 "reserved0"
mtd7: 00400000 00020000 "kernel_stock"
mtd8: 00400000 00020000 "kernel"
mtd9: 0f580000 00020000 "ubi"
root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.8M      3.8M         0 100% /rom
tmpfs                   249.7M    248.0K    249.4M   0% /tmp
tmpfs                   249.7M     76.0K    249.6M   0% /tmp/root
overlayfs:/tmp/root     249.7M     76.0K    249.6M   0% /
tmpfs                   512.0K     40.0K    472.0K   8% /dev
root@OpenWrt:/# ubus call system board
        "kernel": "5.4.188",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "Xiaomi Mi Router 3 Pro",
        "board_name": "xiaomi,mi-router-3-pro",
        "release": {
                "distribution": "OpenWrt",
                "version": "21.02.3",
                "revision": "r16554-1d4dea6d4f",
                "target": "ramips/mt7621",
                "description": "OpenWrt 21.02.3 r16554-1d4dea6d4f"

i'v follow this step by step, manytimes, still can not save changes after reboot. anyone can help? many thanx!

I showed you the relevant error messages in your older thread about this.

Cc @chunkeey who knows at least something about this device.

1 Like

The wiki-entry at says there are issues with Micron NAND and OP's device, according to their logs, does sport Micron NAND. If I had to guess, there are probably bad eraseblocks in the overlay-partition.

A simple ubiformat might make it useable. Or ubiupdatevol -t.

1 Like

this's the problem overlayfs:/tmp/root
i just upgrade firmware from luci, it change to overlayfs:/overlay
now everything fine

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.