OpenWrt 21.02.1 - WRT3200ACM - OpenVPN Client don't start

Hi guys,
I would like to install ProtonVPN and followed the guide to create the VPN in LuCI and it was fine ( but when I start it not appen in LuCI.
I tried to perform the steps that according to ProtonVPN should not be done with version 21.02.1 but nothing has changed. If in command line execute the command:

/etc/init.d/dnsmasq restart


udhcpc: started, v1.33.1
udhcpc: sending discover
udhcpc: no lease, failing

And I think that the problem is "udhcpc: no lease, failing".

could someone help me?

The "udhcpc: no lease, failing" is a non-issue...

Did you install luci-app-openvpn?

Hi OldNavyGuy,
yes I have installed luci-app-openvpn...
I tried to perform the steps that according to ProtonVPN should not be done
Can you help me to config vpn?

I did exactly follow the Proton VPN instructions and did not have to rely to command line actions.

The main problem I remember having was that the VPN was not enabled in Luci and would not start.
In the example below, ProtonVPN is not running but I can switch to it by stopping the other VPN and enabling the ProtonVPN.

Is it enabled on your router ?

How can I check if VPN is enable?

Don't hesitate to look at the screenshot I posted ! There is a checkmark under the Enabled column and it means that the VPN can start. Without it, it won't start, even if you press the Start button.

the check enable means that the VPN must start at reboot. As you can see now I have also checked but it does not start

Press start (sometimes I have to press it twice), wait a while (30 seconds) and check the System log. What is logged about openvpn ?

Oh yeah! I have restarted wrt3200 and now vpn is started!!!
But if I check my ip (example is not the vpn IP but is the IP of my router ISP

Do you have VPN Bypass or another VPN policy installed ?

I think no....if I start vpn on my laptop linux ($ protonvpn-cli connect) my ip is VPN IP

What is your routing table ?
You should see some tun0 routes like here :

where I can find routing table?

Check again that you have done as described in the ProtonVPN help page at step 5 (Firewall).

In Luci main menu, Status, Routes

I have not ethernet adapter tun:0 but Wireless Network wifi1826v that is my actual connection....can I flag this ?

I am a very beginner with OpenWrt but did you follow the instructions from ProtonVPN ?

Click on the Advanced Settings tab and select the tunX interface (tun0 in the screenshot, which is the most likely if you have a single OpenVPN client/server running). Click Save, then Save & Apply.

I try to throw away the vpn and do it all over again.... :worried: